Previous 1 2 Next 17 Replies Latest reply: Nov 12, 2014 1:51 PM by The Keynote Guys
Robert Miller3 Level 1 Level 1 (0 points)

I created a Keynote presentation and have been updating it for about a week now. All of a sudden, the imported photos are gone. Why?

When I look at a thumnail version of the show, everything is there.

Keynote, Mac OS X (10.6.8)
  • tiffany_nj Level 1 Level 1 (0 points)

    i'm having a similar issue (in all the iwork apps) where the graphics just are not showing anymore but are there when i print or export as a pdf

  • iCube Guy Level 1 Level 1 (0 points)

    Suddenly, I'm having the exact same problem.  Created Keynote presentation on iMac & tranferred to MacBook Air via thumb drive.  NEVER had this problem before.

  • shmeck Level 1 Level 1 (20 points)

    same thing here.  my presentation is in 2 hours and my images are gone.

  • shmeck Level 1 Level 1 (20 points)

    this is a perfect nightmare.  i am rebuilding my entire presentation from scratch.

  • Robert Miller3 Level 1 Level 1 (0 points)

    This happened to me a while ago but I got it resolved by following the "More Like This" link above (Re: Images gone missing from slides). Try that first before re-building.

    Hope it works for you.

  • Jeff Axup Level 1 Level 1 (5 points)

    Is anyone from Apple actually responding to this issue?


    I saved a new version of a Keynote presentation with a bunch of images in it and made a bunch of additions.

    After a week I opened it back up and all the images won't load. It shows squares with x's through all of them.

    Settings is set to save all images inside the .key file.

    Why is it doing this? It's really not great to have presentation files magically imploding before a presentation.

  • iCube Guy Level 1 Level 1 (0 points)



    Too bad Apple seems to not be listening, and, it's been awhile since I commented on this thread (Aug. 2011) when I experienced the same problem.  It's rare that I've had problems with Keynote, but on those occasions when I have, I found that copying all of the slides into a new presentation usually restores things.   I don't know if that will help you with your missing figures, but it has helped me on those rare occasions when things have gone awry.  


    In Mountain Lion, we no longer can do a "Save As," which is what helped some people out in the other thread referred tro  by Robert Miller3.  I'm not sure if "Duplicate" would help; but, what I've tried does help.  


    In any event, Keynote remains superior to PowerPoint in terms of effectively handling media, which is why I abandoned PPT in 2006, and have not looked back since.


    I wish you luck.

  • Jan Renell Level 1 Level 1 (10 points)

    Please, let's all file a bug report using the feedback form.


    Similar problems with Keynote are described here and here.

  • Matthew Mclean Level 1 Level 1 (5 points)

    Has anyone found a solution to this!!! I'm experiencing the same problem and my presentation is tomorrow!


    please help...

  • casparammann Level 1 Level 1 (0 points)

    Using latest 6.1 on Mavericks, I today for the first time encountered this issue ... After many years of using Keynote, suddenly it looses images (replaced by big red crosses). I changed just one slide before a talk at a large conference, and boom, most of it gone! No use of dropbox, and also not iCloud. Just local harddrive. When digging into the package, the images appear broken, not just a mis-reference from the collection. I can open some old presentations, but once I start copying slides, they break too. Crazy!

  • mikeyMiami Level 1 Level 1 (0 points)

    Same problem, moved Keynote presentation to iCloud getting same error, 'missing images', but I can see all the images. Very annoying, problem, can't believe it's not fixed yet, it's been several months. Come on Apple this is not a feature request, it's a major bug that's causing major problems for many of us that use Macs for work, please put this on your A list.

  • Gary Andersson Level 1 Level 1 (0 points)

    I was just hit with this same issue. After working for 9 days on a massive presentation for a court case, I suddenly lost all the images. I have been using Keynote since it came out, and I consider myself somewhat of an expert with it, but I've never seen this before.


    Does anyone have an idea what happened and how to fix this? I don't use dropbox nor icloud for my material, only hardrive. Our material is too sensitive to be shared.


    I'm obviously crushed, and was working on the last slide when this happened. I'm so angry at the moment that I can't see straight.

  • iCube Guy Level 1 Level 1 (0 points)

    Have you tried copying all of the slides into a new Keynote document to see if the images will re-appear?  Also, you didn't indicate which version of Keynote you're using--iWork 09 or the still-evolving new version (which has not evolved enough for my use, which is way more than bulleted text and some images).  The copying-into-new-document worked for me the one time I had this problem.

  • Gary Andersson Level 1 Level 1 (0 points)

    Hi Mr. iCube,

    I'm using 6.2 and I did try to copy it to a new Keynote document. It did not help.

    The file size is 4MB, from 220MB. I'm afraid I'm hosed.

    Thank you for trying to help me.

Previous 1 2 Next