10 Replies Latest reply: Aug 7, 2011 9:46 PM by Patricia W
Patricia W Level 3 Level 3 (685 points)

This is driving me crazy. I have defined my Gmail account as IMAP in my Mail app. However there is a mailbox with the name All Mail but no Inbox. How can I just see valid messages and how can I mark messages as junk and remove them from All Messages and never see any messages from these junk senders again? For example JC Penney sends about one message a day and I have to manually delete them. I've looked at the Gmail settings via webmail and haven't found a way to get rid of them.

  • Patricia W Level 3 Level 3 (685 points)

    Even worse, when I delete them, they show up in my All Mail mailbox. Clearly there is something fundamental I am not understanding. I switched to using Thunderbird for a while but got tired of having to check in Thunderbird as well as Mail.

  • Len D Level 4 Level 4 (1,000 points)

    Gmail uses a concept called labels, rather than folders.  When you delete a mail item, you are simply removing the inbox label, but it will still show in All Mail unless you delete it from there.  I not a fan of the All Mail label, so I chose to hide the label from the Gmail account settings.  To hide All Mail, log into Gmail on the web, access your mail settings, and go to the Label section.  You can choose to hide any of your labels.

  • Patricia W Level 3 Level 3 (685 points)

    I'll try that but how do I see just my inbox messages? The list of mailboxes I see on Mail are:

    All Mail



    Sent Mail




    And how do I mark messages as Spam?

  • Len D Level 4 Level 4 (1,000 points)

    Are you sure the inbox isn't at the top of your mailbox listing?  You won't see it in your Gmail section:


    Screen Shot 2011-08-06 at 9.55.36 PM.png

  • Len D Level 4 Level 4 (1,000 points)

    You can mark a message as spam by right clicking on it, and saying mark as -> junk.

  • Patricia W Level 3 Level 3 (685 points)

    If I see a message in the All Mail mail box when I right click on it I can mark it as as Unread but the option to mark it as Junk is greyed out. I can mark it as Unread ... that is all. The Spam mailbox (under Gmail is empty)


    Thanks for the info about using the Gmail folder under the Inbox ... I hadn't noticed that because I usually don't have that list expanded.


    But really I want to get rid of all junk and never see it again.

  • Len D Level 4 Level 4 (1,000 points)

    If your mark as junk is greyed out, then you don't have the Mail junk filters enabled (it's in your Mail prefs).  I don't use Mail's junk filter because I let Gmail handle it.  If you let Gmail handle it, then you will need to log into Gmail directly on the web, and mark such messages as Spam using the spam button.  Gmail should learn your spam and prevent those from coming into your inbox (goes right to the spam folder).

  • Patricia W Level 3 Level 3 (685 points)

    That makes sense bcause I use SpamSieve to filter my other mail and I naively thought it was going to do the same for Gmail. I have tried marking mail as junk on Gmail but it didn't seem to do much. I guess I am going to have to do some research because this is very frustrating.

  • Len D Level 4 Level 4 (1,000 points)

    You could enable Mail's filter as well if you want.  If you do so, I suggest you tell Mail to use Gmail's Spam folder as Mail's Junk folder.  Do this by selecting the Gmail Spam folder, then go to the mail menu bar under the "Mailbox" menu "Use This Mailbox For" -> "Junk".  This way, when you mark a mail as junk within Apple Mail, it will move to the Gmail spam folder, thus telling Gmail it is spam.


    Alternatively, you could use Rules to kick out some of those mail messages you routinely get particularly if they always come from the same e-mail or have the similar subjects.

  • Patricia W Level 3 Level 3 (685 points)

    I turned off spam sieve and am going with Apples junk filtering. It is working for me now and much less of a hassle. Thanks.