14 Replies Latest reply: Jan 13, 2013 5:29 AM by Warachot D
chaoskcw Level 1 Level 1 (0 points)

After downloading Xcode 4 from the app store and running the installer it errors with

 

There is an unexpected error communication with the launched helper tool .

 

 

The seq is:

1) Launch "install xcode"

2) Agree to licenrse

3) Authenticate

4) error!

 

I have tried to use xcode 3 but the simulator is no longer available after lion installtion ....

 

How do I fix this error.


Mac book pro, Mac OS X (10.7), Lion
  • K T Level 7 Level 7 (23,700 points)

    Use 'Activity Monitor', locate and stop iTunes Helper then try the installer again.

     

    Also note that Xcode 3.2.6 works fine for me w/Lion after doing the required JAVA update.

  • chaoskcw Level 1 Level 1 (0 points)

    that didnt quiet do it as I couldnt find an Itunes helpder process running, nor was I getting the itunes error mentioned in other posts, but I did do a few reboots and evetually got it working. I dont know which process it was (and it could have been itunes helper) but it worked after 2 reboots and making sure not to start anything.

  • mthq Level 1 Level 1 (0 points)

    I have the same issue after upgrading to Lion. I had two Developer folders Developer Old and Developer. I used Clean my Mac to remove Dev Old but still had something leftover - i decided to remove dev completely and re-install from MAS. Now I have no xcode installed but MAS shows installed - I still have install Xcode in Applications and Launchpad but I get exacly same error as chaoskcw while trying to install.

     

    Is there any way I can remove whatever is left after previous xcode to have install available in MAS?

     

    Screen Shot 2011-08-26 at 09.07.00.png

  • rchou Level 1 Level 1 (0 points)

    +1 on OS X 10.7.1 (11B26), late 2008 macbook. i wanted to install the unix development package with it this time. please resolve asap. (wish Mr Jobs' health is good and improving)

    Screen Shot 2011-08-27 at 8.22.52 PM.png

  • mthq Level 1 Level 1 (0 points)

    I managed to uninstall xcode completely. I browsed /Library/Developer/4.1/ and found uninstall-devtools asked me for sudo so I run:

    sudo /Library/Developer/4.1/uninstall-devtools --mode=all

    sudo /Library/Developer/Shared/uninstall-devtools --mode=all - both worked fine

     

    Then I looked at the logs /var/log/system.log and saw something strange:

     

    Aug 28 04:41:28 Hadouken com.apple.kextd[16]: Can't load /System/Library/Extensions/iSpy.kext - no code for running kernel's architecture.

    Aug 28 04:41:18 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd): Throttling respawn: Will start in 10 seconds

     

    I don't know what the iSpy is so I went  /System/Library/Extensions and removed iSpy.kext and I got:

     

    Aug 28 05:27:51 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd[6406]): posix_spawn("/Library/iSpy/ispyd", ...): No such file or directory

    Aug 28 05:27:51 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd[6406]): Exited with code: 1

     

    I navigated to /System/Library/LaunchDeamons and removed com.taoeffect.ispyd.plist

     

    Restart and viola - worked!

     

    I hope this helps and I hope someone would be able to explain what the iSpy was - sounds scary.

     

    EDIT:

    Xcode installed and working just fine however I still get:

    Aug 28 06:09:34 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd[1762]): posix_spawn("/Library/iSpy/ispyd", ...): No such file or directory

    Aug 28 06:09:34 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd[1762]): Exited with code: 1

    Aug 28 06:09:34 Hadouken com.apple.launchd[1] (com.taoeffect.ispyd): Throttling respawn: Will start in 10 seconds

     

    And I dont know how to remove it anymore :/

  • tamainut Level 1 Level 1 (0 points)

    I get same problem but:

     

    • Any iTunes process on system.
    • Any helper process on system
    • /Library/Developer don't exist

    Apreciate help

  • markpb91 Level 1 Level 1 (35 points)

    If you are having trouble installing Xcode try this it worked for me:

     

    1. Open Terminal

    2. type 'sudo open'

    3. drag the 'Install Xcode' from Applications into the Terminal window

    4. press Enter/Return (you may have to enter your password)

    5. contiune with the installation.

     

     

    Hope this helps.

  • tamainut Level 1 Level 1 (0 points)

    Same problem after tips markpb91.

  • szdnb Level 1 Level 1 (0 points)

    Just right click on the install xcode app. Then choose show package contents. Follow this path "/Applications/Install Xcode.app/Contents/Resources/Xcode.mpkg" double click and boom

  • djgray Level 1 Level 1 (0 points)

    I have also downloaded Xcode installer yesterday to my iMac from App Store and it shows this ( Trying to locate volume at / ):

    Screen Shot 2011-11-19 at 10.45.46 AM.png

     

    if I click Show contents package/Contents/Resources and click on Xcode.mpkg i got this error (The installer is damaged - The installer can't open the package. There may be a problem with file ownership permissions):

     

    Screen Shot 2011-11-19 at 11.16.15 AM.png

     

    So if I extract all the files to some folders, click get info, the permissions are all set to Read & Write and I don't know what this is.

     

    Anyone got same problem, what should I do? I don't have iTuenesHelper ON or something.

     

    However, on my MacBook Pro I installed without problems..

     

    Some days ago I have added full permission to whole Macintosch HDD and all subfiles, cuz of problems with some other plugin... Could this cause the problem?

  • eschaal Level 1 Level 1 (0 points)

    Snapz Pro XScreenSnapz001.jpg

     

    I CANNOT get the xcode app to install, after trying numerous things. So far, I have wasted three hours on what should be a simple upgrade, (Love the informative error message they give)

  • ClaudioH Level 1 Level 1 (0 points)

    That worked for me. THANKS!

  • alicia_muench Level 1 Level 1 (20 points)

    May I ask...

    What is the error appearing on your screen

     

    Cheers.

  • Warachot D Level 1 Level 1 (0 points)

    Thanks work for me too.