8 Replies Latest reply: Dec 3, 2011 3:29 PM by BassoII
howwow Level 4 Level 4 (3,485 points)

Hello all,

 

Since moving to Lion, one of the apps I find useful in fullscreen mode is iCal, so I set it to:

  • Launch at Startup (and hide) the app
  • In fullscreen mode

 

So whenever I need to refer to my iCal, I just swipe using my mouse (gestures) to reveal iCal.

 

This is "not really biggy", but I notice a few times when I switch to iCal, it tends to "freeze" and non-responsive.  Just just now, I tried to search something and tried to type something in the search field, no response, no cursor, have to quit and launch again.

 

The other time I think I was trying to create a new cal event or modify one, same issue.

 

Anyone has the same issue/problem?

 

Thanks.


iMac 27", Mac OS X (10.7), iPhone 4 32Gb | iPad 2 64Gb 3G WiFi
  • 1. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    Hey_Its_Carter Level 1 Level 1 (0 points)

    Same issue here. Full screen iCal has been freezing when I switch to it. Any assistance anyone can provide is greatly appreciated. Running Lion 10.7.1

  • 2. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    Chris Jensen1 Level 1 Level 1 (15 points)

    Almost the same issue here, just not full screen mode. I think the problem is related to hiding: I launch iCal, everything seems fine, I hide it, and when I try to unhide it later, it won't reappear. It's in the Dock, I can left-click it (no response); right click it and bring up a contextual menu; switch to it via Cmd+Tab, but nothing brings it back.

     

    If I right click and choose "show all windows", ther don't appear to be any to show!

     

    if I bring up the Force Quit Applications window, iCal is not on the list.

     

    If I quit and relaunch iCal, it seems to work OK, as I mentioned before. I just tried it again, then hid it and tried to unhide it - it worked the first time. Then I try it again, and iCal does its new "gray spinning and reloading shared calendars" routine, then stops responding as above.

     

    The new iCal does indeed seem to be very buggy!

  • 3. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    WK604 Level 1 Level 1 (0 points)

    i have the same problem. Also with mail.  Tends to freeze in full screen mode.

     

    I am running latest update.

     

    I hope Apple can fix this soon.

  • 4. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    areasas Level 1 Level 1 (5 points)

    I just upgraded from SnowLeopard and I have the same problem too. It freeze as it starts. I had just the opportunity to set three new appointments and then no response. And when I restart, it starts quickly but I cannot operate for more than 10 seconds. It freeze also if I immediately start the iCal Preferences.

     

    I hope for a quick update!

     

    Carmine

  • 5. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    areasas Level 1 Level 1 (5 points)

    Dears all,

     

    I just checked that sometime it goes back to be responsive but I am not sure which is the trigger to have it working again.

     

    I just checked that, when it is freezed, in the Activity Monitor at pane "Port and Document open", the list is empty. So, I tried to catch it at the starting and I got the following list:

     

    /

    /Applications/iCal.app/Contents/MacOS/iCal

    /usr/share/icu/icudt46l.dat

    /System/Library/Address Book Plug-Ins/LocalSource.sourcebundle/Contents/MacOS/LocalSource

    /Applications/iCal.app/Contents/Resources/ListViewDateCell.nib

    /Applications/iCal.app/Contents/Resources/ListViewOccurrenceCell.nib

    /System/Library/ColorSync/Profiles/sRGB Profile.icc

    /System/Library/Fonts/LucidaGrande.ttc

    /System/Library/Address Book Plug-Ins/DirectoryServices.sourcebundle/Contents/MacOS/DirectoryServices

    /System/Library/Fonts/HelveticaNeue.dfont

    /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.fram ework/Versions/A/Resources/Extras2.rsrc

    /System/Library/PrivateFrameworks/CoreUI.framework/Versions/A/Resources/SArtFile .bin

    /System/Library/PrivateFrameworks/CoreUI.framework/Versions/A/Resources/ArtFile. bin

    /System/Library/Fonts/Helvetica.dfont

    /System/Library/Keyboard Layouts/AppleKeyboardLayouts.bundle/Contents/Resources/AppleKeyboardLayouts-L.d at

    /private/var/folders/rq/2whdkrnc8xl94h006s6kj31r0000gn/C/com.apple.LaunchService s-034501.csstore

    /usr/lib/dyld

    /private/var/db/dyld/dyld_shared_cache_x86_64

    /dev/null

    ->0xffffff801163ebd0

    ->0xffffff801163ebd0

    count=1, state=0x2

    /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.fram ework/Versions/A/Resources/Extras2.rsrc

    /Users/admin/Library/Preferences/com.apple.iCal.plist.lockfile

    /Users/admin/Library/Saved Application State/com.apple.iCal.savedState/data.data

    /Users/admin/Library/Calendars/Calendar Cache

    /private/var/folders/rq/2whdkrnc8xl94h006s6kj31r0000gn/C/mds/mdsDirectory.db

    /Users/admin/Library/Application Support/AddressBook/AddressBook-v22.abcddb

     

    I hope it may be helpful.

     

    Best wishes,

     

    Carmine

  • 6. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    Marsias Level 1 Level 1 (0 points)

    I experienced the same, on a first generation MacPro and a new iMac. E.g. trying to double click an event in full screen iCal does nothing after iCal was in the background for a while - I have to restart iCal to be able do anything again.

  • 7. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    bman99 Level 1 Level 1 (10 points)

    I had the same problem and someone responded with this which worked for me:

     

    * Go to your Finder "Go" menu hold the option key to choose ~/Library

    Go to Preferences/com.apple.iCal.plist and move this file along with all other ical plist files there to your Desktop, then log out and back in or restart.

  • 8. Re: Lion iCal Fullscreen tend to "freeze", non-responsive
    BassoII Level 1 Level 1 (0 points)

    Followed your instructions (what do I do with the plist files now on the desktop?).  I was impressed until the 5th keystroke, then back to slow responses.  Any additional help?