12 Replies Latest reply: Jul 2, 2013 8:42 PM by oshelef
HandySam8800 Level 1 (0 points)



I clean installed Lion on my MBP 2010 and Mac Mini Server 2010. I also installed Lion Server on the Mac Mini. I have the Server configured to share my drives like it was with SL Server. I made the same users and usergroup in Server.app.


I can access everything just fine over AFP with the MBP. But I have a problem with Windows 7. When I search for computers in the network it sees the server but when I double click it, it takes a while to load but eventually I get an error message saying that I have no access and that I should check the network path. I don't get a message box asking for credentials.


But when I type this directly in the adress bar: \\ (IP adress server Mac in local network) I get a message box asking for credentials. I'm perfectly able to access everything as it should this way. But why can't I access the server using it's name? If i type \\SERVER (name for Mac server) I get the same error message. I tried SMB sharing with the MacBook Pro with the same result. I tested this on 3 different Windows PC's and one was a fresh install of Windows 7 but they all gave the same result.


I really don't know how to make this work normal again. I'm probably not seeing something stupid. I know i can make a connection to a share in windows so that it access the share on boot but I really would like it normal again.


Kind regards

Mac mini, Mac OS X (10.7), 2010 Server model, Lion Server
  • D0GG Level 3 (945 points)

    Here is a very easy workaround...


    1. Right-click on the desktop of your Win 7 box
    2. Choose New->Shortcut
    3. Enter the IP address for your Mac (if it asks for the user/pass just enter them and check the box to save your credentials)
    4. Save it


    Now whenever you want to connect to your Mac and it's shares from your Win 7 box, just double click the shortcut and you are in.

  • HandySam8800 Level 1 (0 points)



    It works indeed but between all the shares I can also see the main HDD where Lion is installed. But I didn't share this drive. Is there any explenation for this behavior?

  • HandySam8800 Level 1 (0 points)

    I encounterd some new problems. I can't get Windows 7 backup utility to work with my Lion share where Snow Leopard Server worked perfectly.


    I use Windows 7 (Ultimate) backup utility to backup to a network location. This worked perfectly in Snow Leopard but it doesn't seem to work with Lion.


    When I configure Windows 7 backup It asks where the backup should be stored. I choose network location. then I type \\<ip adress for Lion server>\Backup (the share is called "Backup"). Then I fill in credentials username: SERVER\<username> and the corresponding password. The first time I click oke it gives me an error message saying that the share is not accessible. The second time I click oke with exaclty the same info it seems to work I then can choose which files etcetera...


    But when I start the actual backup process it first "prepares" the files and would start transfering but when it starts with the actual transfer it gives me an error message (nothing specific).


    I think this has something to do with the same issue why I can't just double click the "Server" in windows explorer.


    Again Lion was a fresh install and I just setup file sharing in Server.app.


    Any help with this would be great!



  • EgyptOfPrince Level 1 (0 points)

    I am also having the same problem described by HandySam8800 - I can access the share just fine, but the backup utility cannot.

  • HandySam8800 Level 1 (0 points)

    Yes, there is definitetly something wrong with SMB sharing under Lion. AFP works perfect.


    Maybe I don't know enough about the matter but I know Apple moved to a new SMB version. It's not SAMBA anymore now it is called SMBX and it's developed by Apple. I think there is just a little bit tweaking needed.

  • giovanniIMC Level 1 (0 points)


    (my English is not good so excuse my if I will not clear), I have the same problem, I cannot see the "root" tree of shared folders (with 10.6 server and 10.7.0 version it worked well). I looked the smb.conf file but I did not find documentation about it (in Lion OSX), do someone know how to change main parameters of smb.conf in an apple like way ? (I can try to change manually but I'm afraid that this can increase my problems). I ask to apple service support but they said me that it's not thier problem but windows (and linux) problem... today the little company where I work is sopped due ti this problem.

  • jordivic Level 1 (0 points)

    I have the same problem

  • Simon Falcon Level 1 (55 points)

    I also am trying to backup my lonely windows 7 machine.  The backup fails after looking like it's going..  Part way through it ditches with the error access denied.  I've tried to create a new share from within the server admin, I've tried to chmod the directory to 777 to no avail

  • Simon Falcon Level 1 (55 points)

    I've been doing some more trouble shooting at this - I have not made progress but thought I'd at least share what I've tried:


    I am using Lion Server 10.7.4 and I am able to share folders with the Windows 7 desktop without an issue - it's only the windows 7 backup that seems to have a problem with using the lion network share as a destination.


    I thought it might be the version of SAMBA so I tried to replace the SMBX with smbup as another thread had suggested.  With Lion server I wasn't able to get it to share anything at all and once I removed it (using their uninstall tool), my netbios name would no longer broadcast.  I coudn't figure out how to reverse the problem so I re-loaded the OS from scratch and started over


    I also read in another thread that some folks who had issues signing in had to use the domain of their server in the username line so I thought I'd give that a try as well.  The domain name is shown in the advanced tab of your network control panel under netbios name and the format to use simply DOMAIN\username - it's important to note you don't need a pair of slashes before you put your domain name as you would normally use in the server address field.  Mapping network drives with the username written with the domain preceding works but so does just your username.  I tried it within the windows 7 backup and it still gives an error on the first attempt then goes through on the second and ultimately the backup fails.


    Any other ideas?

  • Simon Falcon Level 1 (55 points)

    On my new install of lion server I tried samba3 and didn't make much progress - followed the directions found on johnlarge's blog and when I tried to start the service I got no error or feedback but smbd didn't start even though the nmbd was running. I then started over following the directions I found on macoxhints (with a fresh install of lion and server 10.7.4) but got the same results - the smbd wouldn't start.


    I decided to try smbup again and this time on a clean install of 10.7.4 server it works (not for the admin user of the box but for any user added).  The netbios name of my server is OFFICESRV and that's what I used in both the Name and Description settings of SMBUp.  I also changed the ports to 139 and 445 in the advanced server config setting and managed to setup scan to network on my xerox 6180mfp.


    My windows 7 box can see and mount shares but I'm still getting backup errors to the network share - now it says "access denied" after looking like it's been copying for a bit.  I can for sure read and write to the destination folder from the windows desktop so I'm not sure why it's still crapping out.

  • JMartinP Level 1 (0 points)

    I have encountered both issues addressed in this thread.


    I managed to solve the first problem (where Windows 7 machines were unable to mount SMB shares) using Alex Narvneys' solution found in this forum.


    The second issue (where the Windows 7 backup utility fails to access the Lion server) remains. The backup utility starts preparing files but stops with error code 0x80070005 (Access is denied). Did anyone manage to solve this so far?

  • oshelef Level 1 (0 points)

    I'm having the same problem with windows 7 backup to a Lion windows share. Any resolution/solutions/work arounds?