Previous 1 2 Next 24 Replies Latest reply: Feb 25, 2012 1:51 PM by philfromhampshire
silvermoonbeam Level 1 Level 1 (0 points)

I've just updated from 10.6.7 to 10.6.8 and from Safari 5 to Safari 5.1. To my surprise, PDFs are now displayed in QuickTime (first page only), where they had rpeviously been displayed in Preview. I moved the QuickTime plugin from Library/Internet Plugins to Library/Disabled Plugins, restarted Safari, and PDFs resumed being displayed in Preview, but I could no longer view movies (for example, from lynda.com). I saw that I had an AdobePDFViewer plugin, which I also disabled.

 

I did a search of the discussisons and found similar problems dating back to 2005 and 2006, but didn't come up with anything regarding Safari 5. I'm a long-time Mac user and have never encountered this before. I do not have Adobe Reader installed, as I have always preferred to have Preview display PDFs in Safari (although I do have CS5 and Acrobat 9 Pro installed).

 

So, right now it seems I can either view PDFs in Preview, or view QuickTime movies in Safari (depending on the status of the plugin), but not both, which I could easily do in 10.6.7.

 

Does anyone knwo of prefernce or plist files that can safely be deleted to fix this? Or si there some other fix? This seems as odd problem as it only involves Apple software which should work together.


MacBook Pro, Mac OS X (10.6.8)
  • Carolyn Samit Level 10 Level 10 (100,380 points)

    Right or control click a PDF file you have on the hard disk then click Get Info.

     

    Click the pop up menu where you see: Open with

     

    Select Preview (might have to naviagate to the Applications folder if it's not available from the list).

     

    Then click: Change All

  • silvermoonbeam Level 1 Level 1 (0 points)

    I already have Preview set as the default application for desktop PDFs and it has been the PDF viewer in Safari for years. There's something more complicated going on here, I think.

  • timcpi Level 1 Level 1 (0 points)

    I am having exactly the same problem you describe: in Safari 5.1 in Lion, I can no longer see pdf files. I get Quicktime opening the first (and only the first) page. I believe it is yet another bug in Lion which I hope Apple will rectify soon on a re-release of the OS, this time one that works.

  • Billy Huff1 Level 1 Level 1 (50 points)

    I have the same problem and have tried every recommendation shown previously on this forum and none of them work.  I am using 10.7 Lion but have the same problem in the prior version of the operating system. Everything has worked just fine for years until Safari 5 came out.  I have given up for now after having spent all day yesterday trying to solve the problem.

     

    If you are able to solve the problem, please let me know.

     

    Thanks,

     

    Bill

  • timcpi Level 1 Level 1 (0 points)

    Here's how, through sheer trial-and-error, I addressed the problem:

     

    1. When the stupid one-page opens just after the Quicktime logo appears, right-click on the pdf's first-page image and select "Save as source ..."

     

    2. In the Save dialogue box that follows, put the pdf "Source" wherever you want it.

     

    I just did his with http://www.irs.gov/pub/irs-pdf/fw4.pdf and it worked twice, so I recommend that you try it.

     

    Good luck!

     

    Tim

  • silvermoonbeam Level 1 Level 1 (0 points)

    I don't have trouble saving a PDF—I can always do that by right clicking the link to the PDF, or as you pointed out, by right clicking and choosing "Save as Source." The main problem is that we've lost the ability to view PDFs in Safari, like we could before Safari 5.1 and (for me, at least) the update to 10.6.8. As I see from the posters above, Lion has the same problem. This is critical to my research because oftentimes I want to view a PDF before I decide whether or not I want or need to download it.

     

    Anyway, thanks everyone for your responses. The usual fixes people have recommended (deleting preferences, plist files, plugins) haven't changed a thing. I'll need to switch browsers for my research (Chrome works okay; Firefox also thinks a PDF is QuickTime media; DevonAgent has the same behavior as Safari).

  • philfromhampshire Level 1 Level 1 (0 points)

    I, too, am having problems with the new Safari 5.1. I am using OS 10.6.8. Since I did the automatic upgrade of Safari (on two MacBook Pros), my .pdf display as only the first page and in Quicktime. Always in the past, my .pdf documents would open in .pdf (WHICH I STILL WANT) and with all pages available. Now only the first page. FireFox also displays using QT.   OR perhaps it was the upgrade to OS10.6.8. All I know is everything was fine until about 2 weeks ago.

  • silvermoonbeam Level 1 Level 1 (0 points)

    I finally figured this out and fixed the problem. As I was the one who began this post, here's my solution:

     

    Open the com.apple.quicktime.plugin.preferences.plist file in ~Library/Preferences with a property list editor.

     

    Open disclosure triangle for:

     

    "WebPluginMIMETypes";

     

    then for "application/PDF";

     

    uncheck the box in the "Value" column of "WebPluginTypeEnabled".

     

    Quit and restart Safari. PDFs now show up in the browser. The contextual menu item "Open in Preview" is gone (it seems), but controls appear at the bottom of the page when the cursor crosses it and if one clicks the Preview icon, the PDF will open as a separate Preview document.

     

    I'm sure there is a Terminal command that does the same thing, but if you have Property List Editor on your machine, it's pretty easy to do.

  • timcpi Level 1 Level 1 (0 points)

    Thanks, silvermoonbeam, for the clear instructions regarding Safari 5.1 pdf files. You must not have "upgraded" to Lion, because (at least in my Lion) there is no folder in ~Library/Preferences called "WebPluginMIMETypes."  I can find nothing that looks even similar, either in ~Library/Preferences or in ~Library/System/Preferences. Or indeed anywhere on my boot drive. Accordingly, I still cannot view pdf files in Safari 5.1.

     

    Am I missing something fundamental here? Or is this yet another "feature" of OS 10.7 that must await a fix from Apple?

  • silvermoonbeam Level 1 Level 1 (0 points)

    I'm still on 10.6.8. I understand, though, that the Library folder is hidden in Lion. But if you hold the Option key and choose Go > Library in the Finder,  should be able to see it. This TidBITS article has the details.

  • timcpi Level 1 Level 1 (0 points)

    I understand now why your instructions did not work for me. This now becomes a OS 10.7 issue merely complicated by the Safari 5.1 issue.

     

    One of the very first things I did after installing Lion was to disable the hidden Library folder; I am seriously irritated at Apple's decision to protect me from myself by hiding that folder. Accordingly, I am sure that I'm looking in the correct (and only) place.

     

    Thanks for your help anyway. I guess my only alternative is to wait for a patch.

  • John Newell Level 1 Level 1 (5 points)

    Hi silvermoonbeam. What is a property list editor? I need to fix the problem with Safari 5.1 and reading pdfs. Thanks.

  • John Newell Level 1 Level 1 (5 points)

    And where is ~Library/preferences?

  • silvermoonbeam Level 1 Level 1 (0 points)

    @ John Newell: You must be on Lion. Apparently the Library folder is hidden from users. I'm on 10.6.8, but have heard that if you hold down the option key while selecting the "Go" menu in the Finder, you'll be able to navigate to this folder.

     

    Once I found the quicktime plugin file, I right-clicked on it and had the choice of opening it with "Property List Editor," which I think comes with Xcode.

     

    A text editor such as BBEdit or TextWrangler can open it, but instead of a checkbox you'll have to find the correct line of text and change a value from "true" to "false," which is the text equivalent of unchecking a box. My directions above can probably help you navigate to the correct line of text. But this may be a bit too much "under the hood" for some people to feel comfortable with. I can only assume it will work in Lion. If you try it, please let us know.

     

    All I can say is that what I listed above worked for me without installing any extra plugins. (I was wrong, though, about the right-click "Open in Preview" being gone when viewing a PDF in Safari. It's there as before.)

Previous 1 2 Next