Previous 1 2 Next 22 Replies Latest reply: Jun 19, 2012 9:18 AM by Sheenalee
Morri665 Level 1 Level 1 (0 points)

I cannot access adobe.com. I continuely get this error message:  "UNABLE TO CONNECT! Firefox can't establish a connection to the server at www.adobe.com." My internet connection is working perfectly. I can browse other sites. I was able to access adobe.com with a hp pavillion over the same wireless connection with no problem. I tried using another browser (Safari), same problem. I contacted adobe they said everything was fine on there end and told be to call my ISP (Time Warner Road Runner). I called them and they said that my internet connection was working and had no problems. They told me to contact apple. I called them up they said they could help for a cool $50 which would only give me 30 days of support. Not gonna happen. Please help.


MacBook Pro, Mac OS X (10.7)
  • X423424X Level 6 Level 6 (14,205 points)

    Perhaps you are blocking it.  Are you using Little Snitch, Hands Off, or one of the Intego apps with some explict specification to block the adobe domain?  Is there anything in your /etc/hosts file?

  • Morri665 Level 1 Level 1 (0 points)

    No, I don't use any of those apps. Where can I find the /etc/hosts file?

  • X423424X Level 6 Level 6 (14,205 points)

    The hosts file is in /etc of course!   There are other ways to do this but the quickest to explain is to use terminal and type (or cut/paste) the following:

     

    more /etc/hosts

     

    This will display the contents of the hosts file.  Are there any lines that mention adobe in it?

  • Morri665 Level 1 Level 1 (0 points)

    Yes a lot.

     

     

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1      

    255.255.255.255 broadcasthost

    ::1             localhost

    fe80::1%lo0     localhost                                                       

    127.0.0.1 hl2rcv.adobe.com                                                     

    127.0.0.1 t3dns.adobe.com                                                      

    127.0.0.1 3dns-1.adobe.com                                                     

    127.0.0.1 3dns-2.adobe.com                                                     

    127.0.0.1 3dns-3.adobe.com                                                     

    127.0.0.1 3dns-4.adobe.com                                                     

    127.0.0.1 activate.adobe.com                                                  

    127.0.0.1 activate-sea.adobe.com                                               

    127.0.0.1 activate-sjc0.adobe.com                                              

    127.0.0.1 activate.wip.adobe.com                                               

    127.0.0.1 activate.wip1.adobe.com                                              

    127.0.0.1 activate.wip2.adobe.com                                              

    /etc/hosts

  • X423424X Level 6 Level 6 (14,205 points)

    Somewhere, some time, you must have added those entries to keep adobe software from calling home and a few others I don't recognize.  You are going to need to edit your hosts file to remove or comment out some of the lines.  Specifically the following:

     

    127.0.0.1 t3dns.adobe.com

    127.0.0.1 3dns-1.adobe.com

    127.0.0.1 3dns-4.adobe.com

    127.0.0.1 activate.wip.adobe.com

    127.0.0.1 activate.wip1.adobe.com

     

    I've singled those out because I personally also have all the others in my hosts file.  They are there because I put them there and don't interfare with me updating flash, etc.  That's the  only way I know they can get in there.  I can't say whether those additional entries are responsible for your problem.  I'm just saying I don't recognize them.

     

    You could elect to just remove or comment out all of them.  Hosts is just a regular text file.  You edit it with any text editor.  You comment lines out by prefixing the line with a pound ('#') as shown near the start of the file.  Or you just delete the selected lines.  If you delete all the adobe entries your hosts file should be back to its original state which would read as follows:

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1       localhost

    255.255.255.255 broadcasthost

    ::1             localhost

    fe80::1%lo0     localhost

     

    With your editor you need to navigate to the /private/etc/hosts file, open it, edit it, and save it.

     

    See if removing the above entries or all the adobe entries solves your problem.

  • Morri665 Level 1 Level 1 (0 points)

    When I enter /private/etc/hosts file into terminal I get this mesage:

     

    Traviss-MacBook-Pro:~ Travis$ /private/etc/hosts file

    -bash: /private/etc/hosts: Permission denied

    Traviss-MacBook-Pro:~ Travis$

  • X423424X Level 6 Level 6 (14,205 points)

    You don't execute /private/etc/hosts.  It's a text file you edit with your favorite text editor.  And you need root privileges to do it.

     

    You can do this a number of ways.  For example log in as root or use sudo vi.  But the easiest way for you is to probably go into terminal and type (or cut/paste) the following line:

     

    sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts&

     

    You will be prompted for your admin password.  After that you will be in TextEdit and you can edit the file normally. 

     

    You might want to keep a backup somewhere.  From terminal you could do,

     

    sudo cp /etc/hosts /etc/hosts-bak

     

    And if you wanted to restore from the backup,

     

    sudo cp  /etc/hosts-bak /etc/hosts

  • Morri665 Level 1 Level 1 (0 points)

    Tried that and I got:

     

    Traviss-MacBook-Pro:~ Travis$ sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts&

    [2] 9500

    Traviss-MacBook-Pro:~ Travis$

    WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.

     

    To proceed, enter your password, or type Ctrl-C to abort.

     

    *********

    -bash: *********: command not found

     

    [2]+  Stopped                 sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts

    Traviss-MacBook-Pro:~ Travis$

     

     

    (**********) I blocked out my password.

  • X423424X Level 6 Level 6 (14,205 points)

    Ok, try the command without the '&' on the end.  I suspect that because control was given back to bash (because of the '&') it didn't give you an opportunity to enter the password and your were already back in bash when you entered the password.  Hense the bash command not found error.

     

    If you can't get past this problem then you are going to have to enable root and logging as root and then you can edit the file to your hearts content.  Just be careful.

     

    Update:

    Enough of this...  I did some google searching on the assumption someone, somewhere, at sometime must have written a user application to edit the hosts file.  I found an app called Gas Mask and it looks promising (I tried it).  Try using that to edit your hosts file. 

  • Morri665 Level 1 Level 1 (0 points)

    That did the trick. Thanks for all the help. It was greatly appreciated.

  • bmal01 Level 1 Level 1 (0 points)

    Hi,

     

    I've got a similar problem after I've done a new install of Adobe Creative Suite 5.5 on my new MB Pro - MB Pro isn't connecting to (or allowing connection to) activate.adobe.com to authenticate so I can't fire up any of the Creative Suite. I've just spent an hour on the phone with adobe who are saying its a Mac problem.

     

    This seemed to be the closest discussion on the support communitiy at the moment, and after reading this my hosts file appeared to look normal (to my untrained eye):

     

    ##

    # Host Database

    #

    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##

    127.0.0.1          localhost

    255.255.255.255          broadcasthost

    ::1             localhost

    fe80::1%lo0          localhost

     

    I've turned off firewall for the moment to rule it out and the adobe support guy just said that there is something in OSX blocking it and that it is not their area... not much help from that end...

     

    The only other thing I can think of is that I have to run Sophos antivirus when I take my machine in to work cos that's their regulations for private machines, but I can't see anything in its settings that would block it at the moment.

     

    Any suggestions would be greatly appreciated.

     

    Thanks.

  • X423424X Level 6 Level 6 (14,205 points)

    That's the standard initial hosts file you have.  So if you are being blocked it isn't from that.  Do you have Little Snitch or Hands Off installed and configured to block adobe?  Have you tried seeing what happens if Sophos is turned off?

  • bmal01 Level 1 Level 1 (0 points)

    thanks for reply... don't have little snitch or hands off. I disabled Sophos for the moment but still no joy with any Adobe CS products authenticating when they try to start for the first time.

     

    When I try and start anything up from CS It just tells me that the reg code I have is not valid for this product (but I just used it successfully to install all the CS suite). This is where the Adobe guy told me that it was something blocking activate.adobe.com

  • X423424X Level 6 Level 6 (14,205 points)

    Run the Network Utility.app in you Utilities folder.  Select the Ping tab.  Enter activate.adobe.com as the address to ping.  Click the ping button and wait a couple of minutes.  If that address can be reached you will see a bunch of lines displayed showing a time and a summary at the end showing some statistics.  If it cannot be reached you will probably see some timout messages and a summary showing 100% packet loss.

Previous 1 2 Next