5 Replies Latest reply: Aug 9, 2011 4:46 AM by Saki_Guzman
Saki_Guzman Level 1 Level 1

I've been trying to update my iPad 2 version from 4.3.3 to 4.3.5 without success. It takes me an hour or more, and at the end of the file download for the update, I get an error message saying that 'I have to check my network settings, network error, etc.'

 

Hope someone can advise me on this. I'm using a Windows 7 pc to update, and the effort is costing me a lot of wasted time :( since nothing happens. I've already turned off my antivirus program (I read somewhere to try this), and transferred my app purchases, but nothing has worked. I really need to update this version since they've fixed a security issue, but it's proving impossible for me to do so.

 

hope someone can post a solution for this problem. :(


iPad 2, iOS 4.3.3
Solved by JimHdk on Aug 8, 2011 12:49 PM Solved

You turned off your anti-virus software but did you disable any firewall software that may be running?

  • vazandrew Level 6 Level 6
    expertise.appletv
    Apple TV

    Have you checked your network? If it's taking that long to download then either you're on a low speed or there's an issue. Took about 20 minutes to download on my system.

  • JKilbreth Level 1 Level 1

    I had a similar situation updating my iPhone iOS software.

    The short solution I used was to borrow a friend's computer (he had a very reliable, high-speed internet connection), plugged in my iPhone, synced it with his iTunes and downloaded the iOS update when prompted. It took about 15-20 minutes to download and another 5-10 minutes to update my iPhone's software. It might not be the fix for your PC, but it might be a workable get-around for now.

     

    Hope this helps!

  • JimHdk Level 7 Level 7

    You turned off your anti-virus software but did you disable any firewall software that may be running?

  • Saki_Guzman Level 1 Level 1

    Thanks for the tip :) I closed my firewall aside from my antivirus and have been able to update. looks like it was the firewall that's been causing all the problems :)

  • Saki_Guzman Level 1 Level 1

    Thanks to all who've offered advise on this. I'm using a broadband connection and don't usually have problems downloading large 600mb and above sized files. Turning off the antivirus and* the firewall seems to have done the trick, even if the download took more than an hour...at least it it worked :D