Previous 1 2 3 4 Next 111 Replies Latest reply: Dec 16, 2014 6:07 PM by Foremost authority Go to original post
  • Sebast1aan Level 1 (35 points)

    Did you happen to solve the problem? I have the same issue.

  • danberg369 Level 1 (0 points)

    im back on snow leopard after this issue on Lion.

    i think the Lion install must have gone bad but rather than retrying, I have opted for Leopard which is faster and more stable (plus the new features of Lion are not enough to warrent the bugs)

  • src105 Level 1 (0 points)

    I wrestled with this as well, I work in a DoD research facility and use a CAC card (smart card) for some websites and other things. Since Lion dropped smart card support, I had to install the libraries from the OpenSC project .


    Dagwood's post led me to try something I hadn't thought of before. I rebooted with my CAC removed, and was able to unlock all preference panes. As soon as I put my CAC in, the lock would not open. Not sure what the next steps are as far as a resolution, but for now that is the cause, at least on my end. Hope that helps someone.

  • Marcelo Grebois Level 1 (0 points)

    Same here, also with creating a new user. 100% sure its a apple issue.

  • Dagwood Level 1 (0 points)

    I also use a CAC card (using OpenSC since Lion upgrade).  I haven't had any problems recently since I deleted ~/Library/Preferences/ and rebooted.

  • SFSavoia Level 1 (0 points)



    I am having the exact same problem as you described.  Have you found a solution?



  • Ironhorz Level 1 (0 points)

    I've tried to find "~/Library/Preferences/", but I don't see it inside of the folder. Even tried to show hidden files and folders, and still didn't see it. Am I missing something?? Am suffering from the same issue described, but can't find this file to delete, reboot, and see if that helped.


    Any suggestions out there??

  • Sebast1aan Level 1 (35 points)

    I did find the files and deleted them. I also found of lock files with the same file name like I also deleted similair files from /Library (I had to sudo to do that). Closed SysPref, deleted the files (HIToolbox, Syspref plist, syspref cache, lock files etc) and rebooted, still the same problem. I did plug in a card reader, but I never installed the software (because it doesn't go passed the "enter admin pass" dialog) and it's now disconnected.

  • softwater Level 5 (5,370 points)

    Deleting lockfiles doesn't do a thing. If reparing disk permissions and deleting the systemprefs.plist didnt' solve your problem, you need to reinstall.

  • softwater Level 5 (5,370 points)

    This was suggested by others in a different thread for what looks like a similar problem:


    I used Directory Utility (/System/Library/Core Services/Directory Utility) to delete two extra Guest accounts ("Guest1" and "Guest2").


    After deleting those two records I could open the Users & Groups System Preference Pane.

  • Sebast1aan Level 1 (35 points)

    I don't have those accounts. Still have the problem.

  • kjarvius Level 1 (0 points)

    I have a DOD CAC Card as well and am having the same problem. I reenabled CAC card by downloading CAC.tokend and and placing them in /System/Library/Security/tokend


    Connecting CAC reader does not cause the problem. Placing CAC card in connected CAC reader causes problem (can't unlock preferences, clicking on the 'lock' icon does not bring up the authentication prompt). Logging out/logging back in does not clear the problem. Killing processes that appear when CAC card does not clear the problem. Repairing permissions did not clear the problem. Rebuilding the keychain does not clear the problem.


    The only thing that clears the problem is rebooting. There are no errors or other messages generated in the console related to connecting CAC reader or inserting CAC Card. There are no messages or errors generated in the console when attempting to unlock preferences.

  • Mangeurdpommes Level 1 (0 points)

    Hi everyone, I also have this issue: iMac mid-2010, Intel core i7 - 2,93GHz - 1TB HDD - 256GB SSD - OS X Lion 10.7.2 bought on AppStore. First I "upgraded from Snow Leopard" and got the "unlock preference panes" problem. I tried everything I found here and on other forum and nothing worked.


    So secondly I restarted from the EFI partition, format the SSD and clean installed Lion again. At the beginning everything were fine, but after a few hours, same problem. I have no more access to unlock any preference pane item. When I click on the lock icon, it asks for my password (I have a admin session) then I click OK and nothing happen, the lock still locked !!!


    Any news anyone ? Is Apple teams working on a patch or even know this problem ??


    Please, help !!

  • Mangeurdpommes Level 1 (0 points)

    Ok guys, I found something interesting !


    As I can't log on any admin user account, I decided to use the root session. Here is how you can do:


    • If you didn't set up the root account before, 2 ways to do it :

         - 1st way :

         - 2nd way :

              * Open Terminal (via spotlight or /Applications/Utilities/

              * Type : "sudo passwd root"

              * It will ask for your admin user password (your user account) -> "Password:"

              * Then define the root password -> "New password:"

              * Finally, confirm new password -> "Retype new password:"


    • You can test if everything went well by typing

         - "su root" in the terminal windows

         - It will ask for the root password, type the one you previously choose, and a bash command should start ! If so, you root password is set and you can quit the bash command via "exit".


    • When the root account is set, you can go back to your preference pane and set anything. When you'll click on the lock, replace the "Name" field automatically filled by "root" and type the root password in the password field. It should be fine, it worked for me.


    Of course, this is a temporary solution to the preference pane problem, but for now, and after many hours of experimentations, it works !


    Tell me if it works for you too !?

  • Sebast1aan Level 1 (35 points)

    That's a great workaround. It's the only thing that works for me. Btw I don't use a CAC card.


    It's strange that sudo works my user, so on a Unix level permissions seem to be ok. I can use root to unlock the preference pane, but the admin user cannot. It's only the GUI related security permissions that are not working. I have not a good understanding of those, should read up on it.

Previous 1 2 3 4 Next