Skip navigation

Can't Unlock Preference Panes

43772 Views 106 Replies Latest reply: Jan 28, 2014 8:35 AM by neptune2000 RSS
  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 3:28 PM (in response to stephen.bradley)

    Well... now that 10.8.1 is released, it is obvious, that Estonian ID card users got no help from this. Same old thing as before

  • Dagwood Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 24, 2012 1:46 PM (in response to nmt1900)

    Updated to 10.8.1 and I still can't unlock Preference Panes to make changes.

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 28, 2012 2:08 AM (in response to nycradik)

    I use Thursby's pkard, it works as advertised. Allows email signing and encryption and access to CAC-required websites. It does not solve the locked system preferences problem people are reporting, that's an OS issue which is an open bug in 10.8.2 (as it has been since 10.8 beta).

     

    If you're using 10.8.x, make sure you get the current version of pkcard, it's like 1.2 or 1.3 for compatability. The website still said 1.1 at my last check, but it downloaded the correct version for me.

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 28, 2012 2:12 AM (in response to nmt1900)

    Youre not alone. Whatever it was that "fixed" the problem in the 10.8.1 build, it was either a fluke or it was reverted for some reason, because the final build caused the problem to reappear for me. It's possible it was never fixed and I was just getting very lucky with it working.

     

    I re-filed the bug for 10.8.2, hopefully this next update will stay in beta longer and they'll have time to look more closely at it. This is the single most annoying thing OS X does - actually it's the only thing that really bugs me - so I'm going to keep the bug alive for as long as I'm involved with testing.

  • Ratamaq Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 8:08 AM (in response to persal)

    Thanks persal,

     

    #killall -9 securityd

     

    Worked for me.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2012 12:53 PM (in response to stephen.bradley)

    Well... same old, same old - 10.8.2 didn't make a difference...

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2012 7:15 PM (in response to nmt1900)

    Actually I stand corrected - by myself...

     

    Something has definitely changed in system - although the core problem remains.

     

    Change is seen, when "sudo killall -9 securityd" is tried - it caused before to be unable to mount any removable media, but now it is other way around - automounting works as it should, but unmounting/ejecting cannot be done.

  • bizringer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 12:35 PM (in response to Sean L.)

    I am running 10.8.2 and having the same issue with Pkard. I contacted Thursby tech support and they are aware of the issue and have a bug ticket for it.

     

    Quick solution is to simply start/restart without your CAC card or reader plugged in.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2012 1:12 PM (in response to nmt1900)

    Well... now I can not be absolutely sure if it was exactly this thing, that might helped, but everyone can try it out to see.

     

    1. Open Keychain Access

    2. Go to Edit -> Change Settings for Keychain "login"...

    3. Activate both options available in this window ("lock after xx min inactivity" and "lock when sleeping").

     

    These options are probably both inactive by default - I have not touched these ever before and they were both unchecked.

     

    Now after this I do not have any problems when using my ID card. Logout and re-login or even restart might be in place after that - at least i made the restart, but for other reasons.

     

    Please try it out - then we can see, if it solves the problem for you or not.

     

    P.S. This thing will have one side-effect in daily use - when any application tries to access the keychain after this timeout or after sleep, you will be prompted to enter the login keychain password (same as your login password by default).It might appear as annoyance at first, but actually it offers additional layer of security - and this timeout value can be adjusted to suit your needs.

     





  • Oleg-S Calculating status...
    Currently Being Moderated
    Jan 13, 2013 12:09 AM (in response to nmt1900)

    nmt1900, it worked for me (10.8.2): both checked, rebooted and settings are unlocked. thanks a lot for the hint.

  • ttoomema Calculating status...
    Currently Being Moderated
    Jan 14, 2013 5:36 AM (in response to nmt1900)

    I have tried the solution you've mentioned and as far as i can say it does not help.

     

    Tried on 3 different OSX and the result is same.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2013 2:59 PM (in response to ttoomema)

    Unfortunately You are right. I got this impression when doing the simple test of login with the card, but actually the main part (digital signing) of the sofware was not operable then. I am not sure, what was wrong, but when I got the whole ID card software working again, I was disappointed to notice, that the problem is back.

     

    It was just one other error condition causing this erroneus impression, that the main problem (from this thread) was gone.

     

    Sorry about that.

  • Phir Calculating status...
    Currently Being Moderated
    Feb 2, 2013 8:33 AM (in response to drache713)

    I had the same issue, and tried every solution as described by drache713.

    Solved in the same way, via CMD+R at reboot, then reinstall Lion (it kept the same version 10.7.5 and all my files).

  • iCerberus Calculating status...
    Currently Being Moderated
    Mar 7, 2013 8:53 AM (in response to Sean L.)

    Just started using my CAC on my mac, and ran into this problem too.  I know this thread is old, but still somewhat active.  Here's what I found (located here: http://community.centrify.com/t5/Express-for-Smart-Card/Mac-amp-System-Preferenc es-Locked/td-p/8790)

     

    open terminal and type:

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.securityd.plist 

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.securityd.plist

     

    The first command will take approximately 20 seconds to complete, then restart System Preferences. The padlock should be now unlockable.

     

    I've also noted that other apps that use the keychain (i.e. save passwords) will have issues unless they are closed are reopened, like mail and facetime.

     

    So far this doesn't seem to have any of the unwanted additional side effects of "sudo killall -9 securityd". 

     

    Using OSX 10.7.5, MacOSforge Smarcard Services 2.0.b2.

  • Raymond Dishman Calculating status...
    Currently Being Moderated
    Mar 7, 2013 2:02 PM (in response to iCerberus)

    This is an ongoing issue that I am still trying to resolve. Understand, I have NOT tried the solution iCerberus has described, but instead would like to know what others think first. While I do not think a sudo kill will result, I am just overly cautious.

     

    Does this proposed solution with with the Estonian AND/OR Oberon Cards? 

     

    Glad to see there is still some movement/interest in this issue.

     

    R/

    Oky

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.