1 2 3 Previous Next 106 Replies Latest reply: Jan 28, 2014 8:35 AM by neptune2000
Sean L. Level 2 Level 2 (245 points)

I noticed that my monitor didn't go to sleep last night, I opened System Preferences, pulled up Energy Saver but I am unable to unlock that or any other preference pane... I click on the lock, it flashes, but no dialog window ever appears asking for my admin password.

  • 1. Re: Can't Unlock Preference Panes
    nycradik Level 1 Level 1 (0 points)

    I just noticed the same issue on my MackBook Pro.  None of the preference panes will unlock when the lock icon is clicked.  It flashes and returns to the 'locked' state without displaying an authentication dialog.  My machine also does not sleep unless the lid is closed, regardless of how the Energy Saver preferences are set.

     

    The sleep issue has been going on for over a year, since about halfway through Snow Leopard and continues now.

     

    Security & Privacy.pngToday is the first time I've noticed that the preference panes won't unlock.  Although the 'Require an administrator password to access system preferences with lock icons' option has been cleared for years and the preference panes have always required authentication regardless.

  • 2. Re: Can't Unlock Preference Panes
    scaramanga89 Level 1 Level 1 (0 points)

    I had this issue after upgrading. Was onr the phonew with Apple support for an hour - ended up just doing a reinstall via Command and R  - then just reinstall LIon - it leraves all the files but repairs permissions. My problem now is nothing will lock, but it's the lesser of two evils. Still a bollocks - hope this gets fixed in the next update.

  • 3. Re: Can't Unlock Preference Panes
    wdurk Level 1 Level 1 (0 points)

    i had same problem on my imac...

     

    i looked at my macbook pro and this was not present...

     

    i downloaded lion on my macbook pro just a few days ago, while i downloaded lion on my imac on the day of release - much earlier...

     

    i re-downloaded lion via the internet with command r...

     

    the newly downloaded lion does not have this bug & works perfectly - it both locks and unlocks as it did in snow leopard...

     

    apple must have fixed this bug between my first lion download on the day of release and now...

     

    i think you have to re-install your os...

     

    hope this helps...

     

    ps the re-install was not really difficult at all..

  • 4. Re: Can't Unlock Preference Panes
    Dagwood Level 1 Level 1 (0 points)

    Same issue here.  Any solutions other than re-install 10.7.1?

  • 5. Re: Can't Unlock Preference Panes
    Sean L. Level 2 Level 2 (245 points)

    I didn't make any changes to my mac, as I figured a future update would fix it, however it just went away on it's own.  I'm pretty sure I didn't even restart, just tried again a few days later.

  • 6. Re: Can't Unlock Preference Panes
    Dagwood Level 1 Level 1 (0 points)

    I got it working again but not sure how.  I tried the trick of deleting ~/Library/Preferences/com.apple.HIToolbox.plist and then rebooted. It works now after the reboot. 

     

    I also removed my Common Access Card (CAC) from the reader.  Didn't think about that proir so it could have been the problem.  Confusing the Keychain...?

  • 7. Re: Can't Unlock Preference Panes
    jonathan150 Level 1 Level 1 (0 points)

    Is Apple going to address this problem soon?  Just found out I have this problem also on my MacBook Pro.  Can't add a user or anything.  Accepts my password and does nothing.  Can't install any software or anything. 

  • 8. Re: Can't Unlock Preference Panes
    Mark Miller1 Level 1 Level 1 (25 points)

    Removing the Prefs file and rebooting worked for me. Thanks!

  • 9. Re: Can't Unlock Preference Panes
    ramatsu Level 1 Level 1 (0 points)

    Same here: removed ~/Library/Preferences/com.apple.HIToolbox.plist and rebooted and appear to be ok. I've only tested a couple of system preference panes but before couldn't unlock any. Thanks!

  • 10. Re: Can't Unlock Preference Panes
    danberg369 Level 1 Level 1 (0 points)

    I believe I have the same problem but when I try to delete the com.apple.HIToolbox.plist file I get the following message:

    The operation can’t be completed because an unexpected error occurred (error code 100022).

     

    To clarify, my problem is that I have lost my admin privelages dispite being logged in with the admin account.

    At the password stage of installing any package, when I enter my password, the password the dialogue box will disapear but I will not have advanced a step in the package wizard.

    Also, when trying to unlock the padlock in system preferences, once the password is entered, the dialogue dispaears and the padlock remains locked (but is highlighted like when you hover over it).

     

    I know I'm entering the right password because if I enter any other password, I get the standard wrong password reaction. I am also definately an admin, it says so under my name in 'current user' sidebar of 'users and groups'.

     

    I am running Mac OS X 10.7.2 on a 2.3Ghz Macbook Pro.

     

    Any help is greatly appreciated that doesn't involve reinstalling the system.

    Many thanks,

    Dan.

  • 11. Re: Can't Unlock Preference Panes
    LukePounds Level 1 Level 1 (0 points)

    I'm still having this issue I deleted the file in the Library folder and I still can't do anything. I can't install programs, delete apps or change system settings.OSX Lion is updated too.

     

    Please help!

  • 12. Re: Can't Unlock Preference Panes
    nycradik Level 1 Level 1 (0 points)

    I'm still unsure as to why this is happening to our preference panes.  What I have found in my case is that, while I experienced the issue of my Mac not sleeping when running Snow Leopard over the past few years, I can now attribute the preference panes not unlocking behavior to one piece of software.  Unfortunately I wasn't running this software until Lion and the developer is also aware of this issue and is confident that it is a bug on Apple's part.

     

    PKard for Mac v1.1 by Thursby Software

     

    Does anyone else have any experience with this software?  It's great at what it does and stays out of the way but does trigger this issue and requires a reboot after each use because of that.

  • 13. Re: Can't Unlock Preference Panes
    Sebast1aan Level 1 Level 1 (35 points)

    Same problem. Deleting the preferences files doesn't help. The problem started yesterday after my wife tried to login my sleeping Mac, but it wouldn't unlock after providing the password. It does take the password, because if you enter a wrong password it will actually tell you, but with the correct password the login box will just flicker and ask for a password again.

  • 14. Re: Can't Unlock Preference Panes
    Sebast1aan Level 1 Level 1 (35 points)

    <snip>

1 2 3 Previous Next