11 Replies Latest reply: Oct 7, 2011 10:24 AM by DVM2
Chelley Vician1 Level 1 Level 1 (15 points)

When I first connected the iPad2 to my iMac, the iTunes app would start up automatically.

 

I also sync my iPhone to my iMac, and iTunes app used to start up automatically also.

 

Now, it seems that the iTunes app will NOT automatically start up when the devices are connected to the iMac.

 

However, if I startup iTunes, then the devices properly show up in the iTunes window, and the sync process begins without my intervention.

 

Is there some sort of preference setting (on the Mac) that I need to kill/trash to get this automatic iTunes startup to work again with both my iPhone and iPad2 devices?

 

Thanks (in advance) for any help you can provide.


iMac 3.06 GHz Intel Core Duo, Mac OS X (10.5.7)
  • King_Penguin Level 10 Level 10 (114,050 points)

    I'm on a PC but I assume it's the same for Ma. When the iPad is connected to your computer's iTunes, on it's Summary tab in the Options section half-way down the screen is there a tickbox for 'Open iTunes when this iPad is connected' ?

  • Chelley Vician1 Level 1 Level 1 (15 points)

    Yes, this option is ticked in the Summary section.  I'm still getting this behavior.

     

    I finally found a similar discussion in another forum here....it seems to be related to 10.6.8 update.....

     

    https://discussions.apple.com/message/15897015#15897015

     

     

    Any more thoughts?

     

    Thanks in advance.

  • Demo Level 10 Level 10 (85,775 points)

    Launch iTunes on your computer. From the menu at the top go to iTunes>Preferences>Devices. At the bottom of the window there is a box that says "prevent iPods, iPhones and iPads from automatically syncing". Uncheck that box so that they will sync again automatically and then if the box is checked in iTunes to open when connected all should work ok again. You have to allow automatic syncing to get iTunes to launch automatically.

     

    After you make the change in the iTunes preferences, quit iTunes and restart your computer.

  • Chelley Vician1 Level 1 Level 1 (15 points)

    My Preferences setting in iTunes for "prevent iPods, iPhones, and iPads from automatically syncing" is NOT CHECKED.

     

    I still have this behavior where iTunes will not automatically start up for me when either the iPhone or the iPad2 are connected.  As pointed out in the other thread, strangely enough the iPhoto app still automatically starts up when the iPhone is connected, but not iTunes.

     

    Any ideas?  How can this get reported to Apple Support?

  • King_Penguin Level 10 Level 10 (114,050 points)

    Try turning off iPhoto starting and then see what happens when you next plug the iPad in : http://support.apple.com/kb/TS1501

     

    iPhoto normally starts if you've got photos on the iPad that were taken with it, transferred to it via the camera connection kit, or saved from emails/websites etc i.e. it's so that you can copy them to your computer.

  • Chelley Vician1 Level 1 Level 1 (15 points)

    Ok, here's what seems to have worked....but will need to monitor to see if this stays "stable".

     

    1)  As suggested above by King_Penguin, I turned off iPhoto startup on the iPhone.  Then ejected iPhone from USB.

     

    2)  Reconnected iPhone via USB.  iTunes did not start up.  Started up iTunes manually.  Went to Summary page for iPhone, unchecked the "open iTunes" option, selected APPLY button.  Let iTunes run its application process.

     

    3)  Then checked the "open iTunes" option.  Selected APPLY button.  Got a dialog box asking if I wanted "iTunes Helper" to be installed; selected YES.  Let iTunes run its application process. Ejected iPhone.  Closed out iTunes.  Reconnected iPhone via USB.  AND iTunes STARTED UP AUTOMATICALLY (yay!).  Let iTunes do some backup and sync'ing.  Ejected iPhone.  Closed out iTunes.

     

    4)  Connected iPad via USB (on computer).  AND iTunes STARTED UP AUTOMATICALLY (yay!).

     

     

    I don't know for sure that the iPhoto "automatic launch" was causing the interference, but it seems like the "uncheck/check" the "open iTunes" option seemed to re-set the problem that I encountered.  I don't want to say for sure that this issue is fixed, but it appears to be under control for the moment.

     

    Thanks to everyone for your thoughts and assistance.  Maybe this info will help someone else out now that it's in the forums/discussions.

  • Lepto Level 1 Level 1 (0 points)

    I'm running into this problem also, where the iPad is not automatically synching when I plug it in.  I made sure that the "Open iTunes when this iPad is connected" is checked; and also made sure that iPhoto is not opening when the iPad is plugged in; and just in case, made sure that "No Applications" was selected in the Image Capture application.

     

    I'm suspecting that iTunes 10.4 has a bug in it, because all this happened when I updated iTunes.  I'm also running OS Lion just FYI.

     

    It's not a huge issue for me, but just an extra step for me to synch my iPad with my Mac (open iTunes manually) - more of a nuisance than anything.

  • Lepto Level 1 Level 1 (0 points)

    Excellent!  Just did the work-around and it worked.  I still think it's a bug in iTunes 10.4.  Thanks King Penguin and Chelley Vician 1!!!

  • Steve Macaulay Level 1 Level 1 (15 points)

    Thanks -- this also solved my similar problem with both my iPad2 and iPhone.  iHappy, I am.

  • dgford Level 1 Level 1 (0 points)

    Thanks...and yes, that approach also worked for me.  Thank you for bringing it forward...

  • DVM2 Level 1 Level 1 (0 points)

    Thank you so much for the execellent and accurate advice re this "bug" in iTunes 10.4 .  This procedure worked flawlessly for me too.  Kaplah!