Previous 1 2 3 Next 38 Replies Latest reply: Jul 14, 2012 10:16 AM by erseee
ubiquity75 Level 1 (0 points)

Hello -


I'm a longtime Mac user (20+ years) and have owned more Macs than I care to count.  I also can't seem to get logged into the support discussions under my usual username, but I digress.  I upgraded to a new MacBook Air about two and a half weeks ago, opting for the 13" i5 model.  I took it home and was impressed by its blazing fast speeds.  A few days into use, however, I began experiencing intermittent and unexplained chokeholds on Internet access via my wireless network.  I've done hours of troubleshooting with a colleague on this, eventually tearing down the home network - AT&T DSL - and rebuilding it. I also ended up swapping out the first Air for the one I am currently on, the 13" i7 1.8 GHz model. 


Here's the symptom:  I'll be browsing or viewing something on the web, checking mail via, etc., and the network connection suddenly drops precipitously - pages take several minutes to load, or stop loading altogether. is unable to check or retreive mail.  When I test the connection throughput using's speedtest, my typical 5.17 Mbps download speed drops to 1.x or slower and takes minutes, rather than seconds to complete.  During this time, I have _full bars_ on my Air.  This happens in different physical locations in my home.  This does not happen to any of the other 4-5 machines and myriad devices used to test alongside the troublesome Air (among them, a 2007 series MacBook Pro run 10.6.x, a late 2009 MacBook Pro running 10.7, a 2008ish MacBook running 10.6.x, an XBox, two iPads, two iPhones, an Airport Extreme, printers and probably other stuff I'm forgetting).


Here are some things I've done, in chronological order:


- After many hours messing with the 2Wire-as-wireless-router, I reconfigured the network to use AT&T's 2Wire router as simply a modem and connected my Netgear wireless router (auto-negotiating mode, set to channel 5 at present but also set to auto-select channels in the recent past) to serve out WiFi.  All other machines are able to use this setup successfully (but also had no trouble when it was just the 2Wire modem/router combo).  This has made no real appreciable difference on the problem with the Air, as far I can tell.


- Swapping out the first MacBook Air for the current one, the i7.


- Run Keychain First Aid and followed other suggestions as described here: this resulted in an error in my Keychain that was corrected by running Keychain First Aid as follows:


Permissions incorrect on ~/Library/Preferences/com.​, should be -rw-r--r-- , they are -rw-rw-r--


This was repaired.  I also told Keychain to "allow all applications access to this item" in the Access Control settings.  This did not result in a solution, as the slowdowns/chokes continued not long after I changed this setting.


I have spent probably 10 hours total troubleshooting this problem, and am probably glossing over some of the things I've checked and tried, but now I'm looking for more suggestions, as well as any other confirmation that others are having a similar problem.  Again, this is not a case of losing bars on the Wifi indicator, and all other machines are working without incident on this network.  It's the Air that is choking.

MacBook Air, Mac OS X (10.7), 13" i7 1.8 GHz
  • ubiquity75 Level 1 (0 points)

    Well, here's today's update:


    I took my Airport Extreme that has been in use as a network client hosting my HP printer and have turned that into the wireless router for my network.  Note that this took an extremely long time, due to the fact that the Air could not configure it no matter how many hard/factory resets I did to the Extreme.  In the Airport Utility, it returned with an error of "An error occurreed joining the selected wireless network" over and over again.  I then decided to try configuration via ethernet - except, oops, my Air doesn't have it, so I went and retrieved my 2007 MacBook Pro (currently up for sale on eBay and about which I am now having second thoughts re: selling) to plug it in.  Surprise - I didn't need to; the Air saw the Express (reset and identifying with its factory default name) in Airport Utility and allowed me to seamlessly configure it. 


    I set it up using WPA2 Personal for the security protocol and OpenDNS servers and  The setup is now:


    AT&T DSL -> AT&T 2Wire modem -> Airport Express using WPA2 and OpenDNS -> my machines


    The 2007 MacBook Pro has had no trouble grabbing and staying on this network.  The Air successfully authenticated to it, then had some issues losing connectivity twice but has been up for about 10 minutes or so as I write this post.  I'll continue to test.  The loading times continue to be strangely slow, with hangups constant on the Air.  The MacBook Pro continues to behave as expected.  Whatever the problem is, the Air is definitely affected by it in a way that none of the other hardware tested (see list in previous post) has been.  This makes me very concerned about the viability of this computer as my main work machine.  I'm still within the window to return it, if I must, as I can't seem to get any feedback on what to do about troubleshooting this further, and my own extensive troubleshooting is neither leading to a conclusive source of the problem nor resolving the issue.


    My next bout of testing will take place shortly, when I take the machine to a public WiFi hotspot to see how it behaves there.  There is no authentication to that network; one theory I currently have is that the Air has trouble with authentication.  Thoughts?


    In fact, I'm going to go into my Keychain right now and "Allow all applications to access this item."


    Any comments, thoughts, ideas or feedback are _most_ welcome.  Thanks.

  • ubiquity75 Level 1 (0 points)

    Okay, I've been running on the public WiFi for about an hour without any trouble.  My new theory is that the Air as a model (because I've had two 2011 Airs now with this same problem) is having trouble either with DNS at home, or with authentication.  The network I'm on right now is wide open with no authentication.  Having controlled for other hardware, the router (tried three now - the 2Wire's service, a Netgear and now the Extreme), two types of authentication (WEP and WPA2 Personal) vs. none, and three different DNS settings, I seem to be closing in on the problem.


    Does anyone else have any other thoughts about what I could test, log, look at or change?  I need to isolate this issue to decide if I can keep this machine or not. 

  • AstroMacMan Level 2 (295 points)

    Appreciate your posting of what's been going on for you.  I'm no techie and so do not have anything to help you with in that regard (and I've been in a similar situation with wireless routers before and they are a bear to trouble-shoot). 


    But I would definitely call Apple support immediately.  You're eligible for 90 free days of assistance--and they're often quite good.


    The only other thing I can suggest is deleting all network prefs from the MBA and starting over again with configuring it from scratch.


    Good luck with it!  And keep posting so that others, including prospective buyers such as myself, can find out how this gets fixed!

  • crh24 Level 3 (920 points)

    ubiquity75 wrote:


    Okay, I've been running on the public WiFi for about an hour without any trouble.  My new theory is that the Air as a model (because I've had two 2011 Airs now with this same problem) is having trouble either with DNS at home, or with authentication. 

    The authentication part would fall into line with another thread I've read recently and with my own experiences.


    Up until a couple of days ago I was running an Airport Extreme (4th Gen) feeding a D-Link DIR-655.  The 655 was used solely to extend the wireless.  This arrangement has worked great for several months when using my various iDevices (iPad, iPhones) and my MBP running Snow Leopard.


    After moving to Lion on the MBP and also purchasing a 2011 MBA with Lion installed I began to have similar problems.  From the many reports I've seen I assumed it to be a Lion problem and likely to be fixed in the first update so I decided to just live with it.  Then I read the thread I mentioned above.


    The poster said that Lion apparently didn't have stability in the networking when the Mac was set to security WPA/WPA2 Personal and the router was set to WPA2 Personal as my DIR-655 was set to.  There wasn't a setting of WPA/WPA2 Personal available in the D-Link so I decided to finally retire it in favor of a new AirPort Extreme (5th Gen).  Now both AirPort Extremes are set to WPA/WPA2 Personal and likewise for my MBP and MBA.  Networking problems solved.  Anytime I run a test I get 50Mbps down and 45Mbps up--close to my metered maximum for download and far above it for upload (I guess my ISP has opened up the upload spigot).


    I don't know if you have read the thread or if you have tried the settings I used--it isn't clear from your postings--but if not it might be worth a try if your routers can both be set to WPA/WPA2 Personal.  If you have already tried that then I guess your problem isn't the same as I had.

  • ubiquity75 Level 1 (0 points)

    Hi, there - thanks so much for these responses. It's nice to feel like I'm being heard, even if folks don't have a specific solution as of yet. crh24, which thread are you referring to? I'd love to check it out.  It really has to be a combination of:


    authentication issues + the Air's architecture

    authentication issues + Lion

    authentication issues + Lion + Air's architecture


    I feel like I'm closing in on the nature of the problem, at the very least.

  • crh24 Level 3 (920 points)

    As I had the same problem on my mid 2009 MacBook Pro with Lion and did not have the problem with Snow Leopard I tend to believe it is a Lion issue but I have no proof and we'll just have to wait to see what Apple fixes in the next release of Lion.


    I believe I first saw the solution I mentioned in this thread:


    Lion Wi-Fi Connection Problem


    but it is so long (481 replies and counting...) that I didn't re-read it to verify and to be honest there are many (many, many!) reports of Wi-Fi problems with Lion not all of which are in these forums.

  • ubiquity75 Level 1 (0 points)

    Another data point: the problem is particularly severe when I am operating the Air in closed mode, connected to an external monitor/keyboard/trackpad.

  • ubiquity75 Level 1 (0 points)

    Another data point: the problem is particularly severe when I am operating the Air in closed mode, connected to an external monitor/keyboard/trackpad.

  • maayank Level 1 (0 points)

    ubiquity, I had the same problem with my new MacBook Air 13". It was driving me crazy. It seems like there really is a problem with Lion and the new MBA WiFi chipset.

    I finally solved it by replacing the 802.11 kext with an older version as detailed in another discussion. (Yippy!!! )

    I posted a recap of the whole experience (and solution instructions) here:

    Hope you find it helpful!

  • ubiquity75 Level 1 (0 points)

    Hi, Maayank -


    Thanks for your response. I'm going through your blog post right now.  For example, I note that I have the same hardware profile and related firm/software as you:




      Software Versions:

      CoreWLAN:    2.1 (210.1)

      CoreWLANKit:    1.0 (100.43)

      Menu Extra:    7.0 (700.42)

      configd plug-in:    7.1 (710.2)

      System Profiler:    7.0 (700.3)

      IO80211 Family:    4.1 (410.1)

      WiFi Diagnostics:    1.0 (100.26)

      AirPort Utility:    5.5.3 (553.20)



      Card Type:    AirPort Extreme  (0x14E4, 0xE9)

      Firmware Version:    Broadcom BCM43xx 1.0 (

      MAC Address:    [redacted]

      Locale:    FCC

      Country Code:    US

      Supported PHY Modes:    802.11 a/b/g/n

      Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

      Wake On Wireless:    Supported

      AirDrop:    Supported

      Status:    Connected




    So I will try the kext fix/downgrade to 10.6.4 drivers, and post an update later today/tonight, when I'm back on my home network.  By the way, were you able to trace the trouble to authentication? In other words, were you attempting to authenticate on the network that gave you trouble? I ask because I'm once again at a wide-open public WiFi spot with ZERO trouble.


    I hope Apple will begin to acknowledge this issue and plan to fix it.

  • maayank Level 1 (0 points)

    My home network (the one with the problem) has WEP authentication.

    The other networks (i.e. cafe, library) I recall testing my MBA against [and there it worked ok] all had WPA authentication.

    Admitedly, I didn't try to disable WEP completely on my home network.

    I also didn't try to change channel or the SSID.

  • ubiquity75 Level 1 (0 points)

    I started out with WEP on my home network, and, through the course of testing and changing a variety of things including moving to the Airport Express, I'm now using WPA2 Personal.  I suspect authentication is an issue; I have not fully disabled it at home, either, during this testing.  I did attempt changes with regard to channel and SSID, however, so I can vet that those things have been tested and are not factors.  Thanks for this info.  I think we're gathering a significant bit.  I'm eager to test your kext fix this evening.

  • cpickrell Level 2 (260 points)

    Apple normally likes to use the latest iterations of wireless standards. It would be helpful to ensure your router has the latest firmware update. I also think WEP is a very insecure protocol and would steer away from it towards WPA/WPA 2. You should also call apple and report your findings with moving to the older kernel extension. If there is a bug, they need to know.

  • ubiquity75 Level 1 (0 points)

    As I previously reported, I am using WPA2 Personal.  The Airport Express has current firmware.


    Once I install and test with the older kext, I will have enough information to relay. 

Previous 1 2 3 Next