Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: Nov 24, 2012 3:48 PM by Go to original post
  • fruhulda Level 6 (15,120 points)

    Before reinstalling iWork you have to certain you have uninstalled  all important parts, not just the iWork folder with its applications.

  • Martin S Taylor Level 1 (20 points)

    So which are the 'important parts'? How do you uninstall them?



  • fruhulda Level 6 (15,120 points)

    If you have installed the iWork '09 from CD or from Apple, not AppStore, There are parts in Macintosh HD / Library/Application Support/ iWork '09

    Easiest is to use Yvans's Script. Go to



    Download :

    For_iWork:iWork '09:uninstall iWork '


    Expand the archive and run the script.


    Restart the computer for good mesure and instal iWork again.

  • DuncanFromChichester Level 1 (15 points)

    To Martin S. Taylor et al.


    I have been having the same 'ignored keystrokes' problem, and have found a way to reproduce the malfunction entirely reliably.  It is when you use the magic mouse with one hand, the keyboard with the other.  I have been seeking a solution from Applecare support for 3 months, now, but nothing to date.  I suspect it is a bug in iWorks.  I would be very interested if someone can reproduce the problem and report back here.  Here is the sequence that produces the problem 100% reliably for me:



    1. Open a new document in Pages and type a few words to make sure it is working properly
    2. Hold the magic mouse in your normal way, between you thumb and another finger.  (Not your index finger)
    3. Slowly stroke the top of the mouse with your index finger as if you are scrolling (very lightly, in any direction) BUT DON'T LIFT UP YOU FINGER AFTERWARDS.  With your finger still touching the mouse surface, try typing some characters with your other hand.  If it works for you as it does for me, all keystrokes will be ignored, until you raise your index finger from the mouse surface.
    4. This is very annoying for anyone like me, who tends to leave his finger resting on the mouse surface after dragging, clicking etc.  Randomly and intermittently keystrokes get ignored …  sometimes for many seconds (until, inadvertently, you lift up your finger from the mouse).



    It happens particularly when you are copying and pasting because you normally use the mouse to indentify the text to be copied in one hand, while typing with the other hand.  Any confirmation would be much appreciated.



    Duncan Butlin

  • Jellyfilled studios2 Level 1 (0 points)



    Thank you. This has been driving me nuts since installing Lion. I have a Magic Mouse and a wireless keyboard. Sometimes Pages and Numbers remain unresponsive even after lifting my finger. The only way to get it to respond again is to select some text with the mouse, then lift my finger. Other times, it's exactly as you found.


    I can duplicate this every time in both Pages and Numbers

  • Jellyfilled Studios Level 1 (5 points)

    I also have a Magic Mouse and Wireless Keyboard. Your sequence causes the same problem for me everytime. This is extremely annoying because as you say, it mostly occurs with cut/paste operations.


    I also use "MagicPrefs" so I removed that and confirmed that your sequence repeats the issue everytime whether MagicPrefs is loaded or not.


    Thank you so much for figuring this out. Hopefully Apple will fix the problem now

  • DuncanFromChichester Level 1 (15 points)

    Jeyyfilled Studios2


    Thank you very much for replying so promptly.  You are the first person to confirm this with me since it started, over 3 months ago (immediately after I installed LIon)!  I too have a wireless keyboard, but keystrokes on the internal keyboard also get ignored.  I've never had the problem persist once I have lifted my finger, however, except that 'right click' persistently fails for me, intermittently …  but I don't think it is related.


    Thank you very much again for getting back.



    Duncan Butlin

  • Jellyfilled Studios Level 1 (5 points)

    I also have the issue with right click (or control click) not responding. I assumed they were related. I'm very glad you found this. I show as the 4th person to log this issue back in September and at that time people were saying it's too rare to be anything other than a user error

  • DuncanFromChichester Level 1 (15 points)

    Jellyfilled Studios


    Thanks very much for reproducing the problem as well.  Yes, I stand corrected:  the right-click failure does seem to be related …  but for me it is not always cured by raising my finger from the mouse.  However, when I tested it just now, raising the finger always DID fix it.  Whenever it's intermittent it becomes a real problem, blast it!  I can confirm that I also get the problem with 'control-left-click'.  Interestingly, only part of the 'right-click' is being ignored:  if you use a right-click over cells in a table, the highlighted cell changes to where you click …  just that the context menu does not appear!


    I also use MagicPrefs, but it cannot be interfering, because the problem persists even with a completely clean Lion and re-install of iWork, with nothing else added at all.


    If everyone who can reproduce the problem contacts Apple, perhaps they will start responding?



    Duncan Butlin

  • Niklas Luhmann Level 1 (45 points)

    I have the exact same problem. I have earlier seen other threads suggesting that it is a particular problem for the following combination:


    Lion + Magic Mouse + Wireless Keyboard + iWork


    I have not tried using a different mouse or keyboard, but this is my situation and I have the same problem. I have written Apple abou this - no response.

  • DuncanFromChichester Level 1 (15 points)

    I think the combination is just:


    Lion + Magic Mouse + iWork


    because the problem occurs whether I use the wireless keyboard, the laptop keyboard, or by clicking on the keys in the keyboard viewer.  Thanks for confirming the problem.

  • pmcquade Level 1 (0 points)

    This is my identical problem.  Been to Genius bar four times and on support twice to no avail.  Everyone thinks I'm nuts.  This is so cathardic to find this string! I'm not insane!  Everytime I tried to use my iPhone to video the problem for proof, it would go away.  I realized after waiting a few seconds it often started working (the time it took to get my iphone on video mode!)


    I use magic mouse, wireless keyboard and a new MacBook Pro.  (However! I had it happen right at the Genius bar in Keynote, trying to Command C, Command V a graphic, when I tried to show the Genius it worked perfectly, like a nice little Gremlin)  So that may discount the Magic Mouse wireless keyboard issue to some degree. (I was using my right finger for both arrow nudging and track pad so they were not simultaneous like the helpful description of that problem as well, which I also experience)


    I will be showing this string to the Apple support folks to prove I am not nuts.


    So most of my noticeable issues are the delete key not working, nudging using the arrow keys goes away, and the command X, C, V combo keystrokes.  I am using American English with all updates in place.  Apple Store even replaced iWork with their own version on the store hard drive and it still happens.  These issues apply to Keynote, Pages and Numbers.  So evidently all my third party apps are more compatible with Lion than Apple's native software. Interesting!



  • DuncanFromChichester Level 1 (15 points)

    Thanks for posting, glad you have been able to reproduce the problem, and glad that it has been of help.  I’ve had no official response from Apple, since I’ve learnt how to demonstrate the problem reliably …  so I wish you luck, and please tell us if you get any joy from them.


    Duncan Butlin

  • PeterBreis0807 Level 7 (34,065 points)

    pmcquade wrote:


    This is so cathardic to find this string! I'm not insane!


    Did you mean cathartic? In which case it means exactly the opposite of what you probably think it means.



  • Niklas Luhmann Level 1 (45 points)

    I've been trying to figure out a way to reliably trigger the problem (useful if someone wants to demonstrate to people at Apple). This seems to work in Keynote:


    Click in an element and do a partial scroll gesture - just a slight scroll gesture is enough. The keyboard will not respond until you lift up your hand from the mouse. Essentially, doing a scroll (even one so small you don't notice it) is enough to lock up the keyboard. This should be considered a bug. You can report bugs here:



    I suggest everyone test if this method of reproducing the bug works for them in various iWork apps, and if it does, please report the bug to Apple.