Previous 1 2 Next 16 Replies Latest reply: May 29, 2014 2:13 PM by GraeneyMac
Dan VanDeRiet Level 1 Level 1 (115 points)

I've been working on a large Excel file (Office 2008) on my MacBook (core 2 duo/Snow Leopard) and recently got an iMac with Lion. I transferred everything from the MacBook to the iMac via Time Machine. Now when I open the file on the iMac it comes up as "Read Only".

 

I've checked the permissions and it was still "read/write" for me; I tried giving "read/write" to everyone and it still opens as "Read Only".

 

Any thoughts?

  • montygirl2@btinternet.com Level 1 Level 1 (10 points)

    Hi, I believe if you save the file to a different name (only a 1-letter change will do this) you should be able to use normally.

  • Dan VanDeRiet Level 1 Level 1 (115 points)

    Ding, ding,ding,ding,ding--we have a winner. Thanks for the tip

     

    Bonus points if you can tell me why this problem cropped up.

     

    Dan

  • ArizonaLoco Level 1 Level 1 (0 points)

    I am having a very similar problem.  Running Lion 10.7.2 and every Excel file I open will open as Read-Only.  It will let me save by changing the name, but it won't let me save and replace.  When I open the new file name it also opens as Read-Only.  This is sending me a clear message, learn how to use Numbers much better.

  • JH117 Level 1 Level 1 (0 points)

    I had the same problem.

     

    To fix it go into the "General" system preferences pane and uncheck "Restore windows when quitting and re-opening apps".

     

    Unfortunately I don't think this fixes files which have already been affected by the "Read only" problem - they contnue to open as read only -  but any files you haven't opened recently and any newly saved files seem OK.

  • JH117 Level 1 Level 1 (0 points)

    Sorry guys - posted the wrong solution.

     

    The problem with files opening "Read Only" is caused by using a filename that would be invalid in Windows. My file had a "/" in the name and would only open read only. If I remove the "/" evereything is OK.

     

    Unfortunately the test I did after trying the "restore windows ..." fix led me to the wrong conclusion - sorry for that.

     

    Anyhow, remove those "Windows illegal" characters from your filename and I think all will be well.

  • SofiaA Level 1 Level 1 (0 points)

    I had the same problem and as soon as I removed the  / from the file name all my "read only" problems were solved.

  • Adalom Level 1 Level 1 (0 points)

    Thanks so much JH117. That problem has been driving me crazy. Finally resolved.

  • GraeneyMac Level 1 Level 1 (0 points)

         Hi!

     

         Thank you very much JH117 for the above solution to the problem as outlined on the original post. You have really got me out of a spot. Could somebody now please help with the following related issue?

         When I save the document, however, the XLSX icon is in landscape orientation with the word NAME in bold red capitals at the centre whereas the original was in portrait with a green band along the top containing the Excel logo and at bottom left was a ptotruding cartouche containing XLSX in green capitals. Is this a cause for concern? I noticed that when I drag the 'new style' icon off the desktop to put it into a file, it reverts temporarily to the original style with a green plus sign, but when I unclick, it returns to landscape.

     

         Regards,

     

         DG.

  • Matthew Goeckner Level 1 Level 1 (15 points)

    While the above answer MIGHT be one problem - the solution is related to the computer name.  In moving the data to my new machine, the OS created a new name for the new machine.  The old computer had my last name "goeckner" ... and the new one was my last name with (2)... "goeckner (2)"  As soon as I changed the computer name to match the old name, the files all openned as they should. 

     

    I THINK that MS office is looking at the computer name - and deciding that it should be read only because the file is not on the "correct" computer.  This has advantages if one wants to share/jointly edit files. (Likely what MS wants you to able to do.) Here it does not work correctly.

     

     

    =====

     

    For the record the computer name is done so that the IT people know who is sitting on our network....  If it were left up to me, I might call it "flaming death star".

  • MikeBurns Level 1 Level 1 (0 points)

    I had the same issue after I got a new laptop with 10.8.  I believe this is caused by having the restore windows options selected and having a new computer with a new hostname.  I was able to navigate to the directory and remove the file starting with ~.  This resolved the document from opening in read-only all the time

  • Frances54 Level 1 Level 1 (0 points)

    JH117, you should specify that users need to go to Apple>Preferences to make that change. I spent 30 minutes trying to find the setting in the Excel Preferences!

     

    I am working on a Mac Pro using Lion OSX. I have an Excel file that I created and saved to my harddrive over a year ago. I add infor to this spreadsheed occasionally. Today I opened it, made changes, then tried to save it only to get a message telling me it was Read Only. Now, it has never been Read Only, and when I checked Get Info the file is categorized as Read and Write.

     

    I finally saved the file by adding another charcter to the file name and deleting the original.

     

    I still want to know WHY this has happened without any alteration on my part.

  • BBJ_Tim Level 1 Level 1 (0 points)

    Removing "/" from filename fixed it for me too.

  • relativitydrive Level 1 Level 1 (0 points)

    Hi,

     

    I had the same issue today and a non-read-only file is copied and worked on.  When I changed the name it then went to read-only.

     

    The solution for me was to create the copy then rename it only a few charachters at a time i.e. first rename read "No.1" then the second was "No.1 WE 16" and so forth until I got the name I wanted and at each change I opened the file to check the status (that appears in excel at the top with the file name).

     

    Not a good solution but it worked.

     

    Good luck.

  • cthammer Level 1 Level 1 (10 points)

    I had the same issue with a file that I opened from an attachment in Outlook. When I moved it to my desktop, I was able to save correctly.

Previous 1 2 Next