Skip navigation

2011 27" iMac wireless stuck at 54Mbs (G Speeds on N network)

1889 Views 7 Replies Latest reply: Oct 13, 2011 9:43 PM by dean_j_arnold RSS
_R_ Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 11, 2011 11:23 PM

Recently bought a 27" iMac and no matter what I do, the wireless won't connect on anything but 54Mbs speeds either on G or N networks, but my 2010 13" MBP connects to my N network at 300Mbs no problem, same with a friends 2010 15" MBP that I asked him to bring over for a test (connected at 300mbs on N no problem)...

 

Netgear WNDR3700 DualBand Router

Router has an Atheros chipset

Wireless G - set at 54Mbs, WPA2-AES security, Channel 11

Wireless N - set at 300Mbs, WPA2-AES security, Channel 161

DNS: 8.8.8.8

IPv6 is Off

 

2011 27" iMac

Atheros wireless chipset

Currently connecting to the router over G network because if I connect over my N network, it'll connect to the router, but have no network activity.  Everything times out or doesn't load at all. 

3.7MB/s peak transfer speeds

DNS: 8.8.8.8

IPv6 is Off

 

2010 13" MBP

Broadcom wireless chipset

Currently connecting to the router over N network

20.1 MB/s peak transfer speeds

DNS: 8.8.8.8

IPv6 is Off

 

Things of note:

• G network @ 54Mbs = all computers connect and have full network activity

• N network @ 300Mbs = all computers connect, only MBP's (both 13" and 15") would have actual network activity, iMac everything times out

• N network slowed to 54Mbs = all computers connect and have full network activity

• Distance to router not an issue, it's one room away

• Both computers are running Lion, but had same results under Snow Leopard

• Need 300mbs (N network) because of a network share drive.  G speeds take way too long to transfer files

• I've tried every channel available, same results.

• It's not a setup issue since 2 MBP's connect at 300mbs no problem, only computer with issue is the iMac

• Trashed preferences, reset keychain, Clean install not an option.  It's behaved like this straight out of the box

 

ideas?

iMac, Mac OS X (10.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.