Previous 1 2 3 4 Next 46 Replies Latest reply: Jun 2, 2015 5:39 AM by Daniel_Carrizo Go to original post
  • azurar01 Level 1 Level 1 (0 points)

    For those of you with Netgear / Nexon / Infrant NAS's there is progress on new firmware.



    Beta at present, but I expect it will be final soon.

  • elipsett Level 1 Level 1 (0 points)

    I am obviously in far over my head here, but so far this is the only discussion that has anything to do with connecting old macs (OS9) to Lion macs. We have been running a 10.4 AppleServer and connecting to WinXP, WinVista, OS9 and OSX10.4/5. That machine died, and we have purchased a new 10.7 mini Mac as the new server.
    When we try to access it from one of our older OS9 machines, it says the server is running an incompatible AFP, and access is not possible.

    Apple has confirmed that even Lion AppleServer does not support OS9, leaving us with FTP or hardwire access only.


    Your post suggests that it is possible to rewrite the AFP code for compatibility.


    A few questions, if I may:

    1. Is this likely to also solve my problem?

    2. By doing so, would I make it difficult or impossible to access the 10.7 machine from Win XP/Vista or OSX10.4/5 machines?

  • dotjay Level 1 Level 1 (5 points)

    If you want to undo the changes to, I don't think you want to delete the whole plist. To only reset the changes made, use:


    sudo defaults delete /Library/Preferences/ afp_disabled_uams


    And then:


    sudo defaults write /Library/Preferences/ afp_host_prefs_version -int 10

  • BobbieMac Level 1 Level 1 (0 points)

    This "workaround" looks ok if you are a Linux whiz, but for the rest of us, where is the Apple solution in a neat package?

  • Abscate Level 1 Level 1 (45 points)

    I upgraded my Mini 2009 to Lion and found I can't mount my older(2004)  network Iomega drive


    The chmod scripts above did not work for me.


    I was using this drive to bridge between Mac and PC platforms but just use IDisk instead, once I figured out how to mount iDisk on WIN XP ( easy and well documented)

  • BobbieMac Level 1 Level 1 (0 points)

    One solution for the problem is to run Lion Server.  I put Lion Server (costs $49) on the machine that was, in fact, the server.  This allowed the other Macs in the household to connect and backup to the drives on the server.    It was pretty straight forward, but you do have to do some server setup to get it working.


    It's also worth noting that the TIme Machine first backup (when it does your whole disk) is very slow - 250GB took a day to finish.  I'll say that the Lion Server solution is working, but there is still some protocol wasting a lot of time on the network (which is all Apple in my case.).


    The above solution of using iDisk to bridge between Windows and Mac  is a good idea and Dropbox will also work.  In fact, with iCloud coming  and MobilMe going away, Apple techs are suggesting Dropbox.  It works  great.   I think perhaps Windows Live Sync will also do this job, but I  get nervous trusting Microsoft with my data.  However it can be pretty  slow backing up to the cloud, depends of course on your internet  connection speed.

  • fditt Level 1 Level 1 (0 points)

    I have a Mac OS leopard in an old machine that sits on my "home office" room, which I'll just call "server". It has all media (photos, music, videos) and files that are shared to my MBP and for my wife's MBAir, not to mention iPad, IPhone, and Apple TV, and time machine that runs in this server.

    I normally use "share screen" feature to control some activities that run on the server remotely. Before Lion upgrade, it was really straightforward, connect to the ASUS RT-13N wireless, and in seconds the server would appear under shares on the left hand side of finder window. Just click on it and them in share screen and I was controlling the remote server.

    After Lion upgrade in my MBP, it stopped working. The server don't appear as a share anymore. 

    After a long session of troubleshooting, things that I discovered:

    - my wife's MBAir still in Snow Leopard and the sharing works as always worked with ASUS  wireless;

    - if I use a wired connection with ASUS, the share works just fine in my Lion MBP 

    - if I connect my MBP using a secondary wireless router I have for coverage purposes (D-Link DIR-825) the share works just fine as well


    I've tried every possible wireless configuration within ASUS, including copy every advanced setting from the D-Link router, removing security, but nothing worked.


    So for me is pretty clear that Lion has an issue with ASUS wireless, and based on all the forums I've been during troubleshooting, probably it is not only with ASUS, but seem a major issue with wireless in Lion.


    So Apple, what's the plan?

  • MiamiC70 Level 1 Level 1 (0 points)

    So looks like LACIE has decided too screw it's 5Big v1 customers and after several support tickets has basically given me two options.
    1. go back to OSX Snow Leopard
    2. buy a 5Big v2


    Way to make my 5Big v1 still under warrranty a door stop.

  • biovirus Level 1 Level 1 (0 points)

    I have the same problem, I tried to change something I do not understand any sudo....... and it does not work well, I regret that I bought to upgrade the lion, now will it cost me more money purchase of new NAS. I am very disappointed!


    QNAP TS-109pro TimeMachine working.

  • Ken Clarke Level 1 Level 1 (20 points)


    Like all of you, I'm having a nightmare connecting OSX Lion to (in my case) my buffalo Terastation pro TS-1.0TGL/R5.


    I've had a ticket open with apple for over 2 weeks and finally got a response from the agent this evening.


    We have tried the afp workaround terminal commands I'm sure you've read them as well ( karound/) turn on DHCAST128 blah blah... there are lots of people out there claiming they found the answer and that's the kiddy but it certainly didn't work for me and didn't for many many others.


    So. Apple have no offical solution to this, neither have they received any official statement from up above regarding a fix (probably because good ol' stubborn apple want us to all go out and by time capsules instead of supporting other brands!)


    The agent on the phone has directed me to 2 websites:

  orkaround/ working/

    The first detailed pretty much the same steps I had already taken, so I'm following the 2nd - installing some 3rd party tools.

    I'm working through them as we speak and due to the large download size of Xcode it's taking a while!

    I'll update the thread when I've completed them and hopefully running on smb shares again!

  • ssuddell Level 1 Level 1 (0 points)

    Hi Ken,


    Did you get any joy with this?


    I've just bought a MAC mini with OS X and hit the same problem with my TS-1.0TGL/R5.  I downloaded the Buffalo utility for the MAC that is supposed to enable connection to this device, alas, that did not work.  I got an error message that says "this version of server is not supported..." or similar.  I would love to hear that you cracked it.



  • Ken Clarke Level 1 Level 1 (20 points)

    Hi Steve

    Afraid not. After installing a lot of crap it didn't get lion to work with it and there's no instructions on how to back out the changes so I don't know if I've done any damage to my OS.

    Ultimately, I just bought a new NAS (symbology ds411slim) and its awesome, but comes at a price.

    I had hoped someone would bring our some new firmware for the terastation but no such luck.

    That said, the terastation has always been reliable, until apple decided they didn't like it.


  • Beth Ernst Level 1 Level 1 (45 points)

    Running Lion 10.7.2 and trying to connect to a Server 2003 computer. I have tried following these steps but there is no AppleShareClient.plist file on my computer to edit. Any suggestions?

  • Craig Best Level 4 Level 4 (1,145 points)

    I'm having a similar problem, my G5PM with Leopard 10.5.8 can see the shared drives just fine, it's connected via Ethernet. I have 2 drives in a PC and one connected to the router/hub. The new MacBook Pro with Lion 10.7.4 (using wifi) can't see any of them, but used to connect to the PC shared drives. SHARED is also now missing in the Finder window, using (Command k) then typing in the address (smb:// says it can't find the server, but it is still working on the G5. WiFi is built into the ADSL router and the LAN is hooked into one of the Ethernet ports. All computers can access the same Internet connection.


    To me it sounds like an IP problem at the MBP, it is not on the same (10.0.0.#) address as the Ethernet computers but it sets the IP automatically and all attempts to change it results in the MBP loosing it's Internet connection and still not SHARED drives.


    I was told that some shared NAS drives are no longer compatible with OS X Lion but this should not affect connecting to my PC unless more recent OS X updates have changed this?


    I'm more concerned with this now because while the MBP is my mums laptop and she doesn't connect to the LAN ofter I'm getting a new iMac soon and it needs to be connected, I was hoping to use wifi but if the is the problem might have to go back to Ethernet for this also, meaning a new hub on my desk as the router and other hub is in another room. That's assming it's WiFi and not a Lion issue.

  • Superfly-SP Level 1 Level 1 (0 points)

    I am so COMPLETELY FED UP this.. I am not an expert - thats why I switched to Apple - because stuff should work. Now spent more then 6 hours already going and trying all kinds command line bs.


    Where is APPLE in this conversation and why dont they give some decent guidance???


    All I can do is open a 695US$ support ticket to hear that smb/afp is not supported any more.. come on!

    Buy a new NAS??


    I REGRET SO MUCH I upgraded to Lion... for me it stinks.