6 Replies Latest reply: Feb 12, 2013 1:00 PM by LloydCCAuto
m021478 Level 1 (0 points)

I have a Mac-Mini at the heart of my home media center. For the last couple years when I needed to access the computer, I would simply use OS X's built in screen sharing capabilities, because the Mac-Mini doesn't have a mouse/keyboard connected to it.


The problem I'm having with Lion is that when I try connecting to the Mac-Mini using the same screen sharing method I've used for years, I now get this pop-up message:


Now, I do have two user accounts on the Mac-Mini and if I choose "Connect to a virtual display" I can connect to the 'background' user account of the mac-mini without any problems, but that's not the one I am trying to connect to.


When I choose the option to "Ask to share the display", it won't let me connect unless I use the Mac-Mini to confirm that I want to allow this connection - which in my case isn't possible because there is no keyboard and mouse connected to the machine.


Why is it that it won't allow me to connect to the currently signed in user on the Mac-Mini unless I confirm this from the mini itself? If I try using screen sharing to connect from iMac to my MacPro (or vice versa), both of which have only one user account on each machine, then I am able to directly connect and control either machine from the other without the need for any confirmation.


Any thoughts on how I can get the Mac-Mini to allow me to connect without the confirmation? Do I have to delete the second user account so that the Mini is only running one user account?


Any suggestions would be greatly appreciated... Thanks!

  • Tony T1 Level 6 (8,975 points)

    Well, I don't know if this will help, but....

    I have a mini w/o monitor or keyboard that I connect the same way in Lion (both Mac's) as in SL.

    Difference is, I have the same User name on both machines and in Sharing Preferences I "Allow Access To" only me.

  • nickfromhalam Level 1 (0 points)

    I have exactly the same issue, I tried setting the user name to the same and playing with who could have access, but I still couldnt get past the 'waiting for user to answer' screen. I can get in to the mac mini using logmein software, but it really shouldnt be necessary given the sharing functions built into Lion.


    Like m021478, i can get into my other macs without it asking. Its just the mac mini that needs this.


    Any other suggestions?

  • Rob Gendreau Level 1 (145 points)

    I'm not sure what you're using at the client end, but you need to log into Mac screen sharing from a remote connection using the user name and password of the account you're trying to access; at least that worked for me. Otherwise I got stuck at that login screen. Some VNC clients only asked for a password, which I had set in the Sharing pref pane. But that didn't work; I needed the user account info. And when I log in it throws a dialog and I choose to log in as a "registered user," NOT "By asking for permission."



  • Per.J Level 1 (0 points)

    I found a solution: In the Safari address bar type vnc://user@host but don't press enter (user is the account short name which you can find in the account settings). Drag the globe icon to your desktop, and it'll create a bookmark, which you can double click to access the remote machine. If you don't want the password prompt, you can use vnc://user:password@host but be careful about that since it'll save the password in plain text.


    If the user doesn't have a password, use vnc://user:@host (the dialog won't accept an empty input).

  • D. Hoffmann Level 1 (15 points)

    I didn't have your issue until I re-installed Lion on my wife's computer and subsequently only retoring her user folder and none of the system settings. This leads me to surmise that before, after I had done an upgrade-install over Snow Leopard, some setting must have been copied over that caused the user on the target system to not be required to consent to the screen sharing session. Perhaps such a setting is accessible through the defaults write mechanism.

  • LloydCCAuto Level 1 (0 points)

    From finder when you highlight the mini you will see at the top bar on the right Connect As and the user name and there are two buttons to the side of that. "Share Screen" and "Disconnect". Hit "Disconnect" and then "Connect As" then log in as the user that you want to connect to the mini with. The issue I was having was the same and the problem lies with checking of the remember in keychain box. If you use the user name and password that is currently logged in then it will not promt to share screen and will simply work. Hope this helps!