1 2 3 4 Previous Next 124 Replies Latest reply: Jan 26, 2014 2:19 PM by moonmen Go to original post
  • 15. Re: kernel_task running wild!
    ylluminate Level 1 Level 1 (0 points)

    Having the same problem here.  It is not Dropbox, it is not encryption, nor anything else suggested here.  I am finding that my bluetooth Magic Trackpad goes insane in terms of latency.  I would suggest you file a bug here: bugreport.apple.com with the details of your experiences for more detailed analysis. 

     

    The short of it, here, is that it appears that whenever there is very heavy file system activity the kernel_task shoots through the roof (~300-400% each time here) and then system latency likewise goes nuts.  It appears to be an IO blocking issue.  It also tends to be more likely to occur when you're pushing the upper thresholds of your memory limit.

     

    Running on a Mac Pro 16 core system, 20GB RAM.

  • 16. Re: kernel_task running wild!
    neversleepz Level 1 Level 1 (0 points)

    I think ylluminate, you may be having a slightly different issue with the same symptoms.  Eg your kernal_task cpu is caused by the IO blocking issue you describe where-as the OP has an issue with time-machine on encrypted backup disks.

     

    I can state that I can reproduce the problem exactly as the OP describes.

     

    I'm have a 17" MBP 8,3 w/ Lion 10.7.2 and have an external hard drive which I encrypted using Time Machine.

    Its a 750GB disk with a majority partition of some 650GB devoted to time machine.  The other partitions are one for Windows of < 50GB, and the remainder for a Linux partition + swap partition 50gb

     

    Time machine goes to backup to an encrypted partition on a external usb drive.  Its state says 'preparing backup' and stays their until I cancel.

    At the same time, one virtual core of my i7 becomes pegged at 100% with system cpu activity.  Activity monitor reports kernal_task using just over 100% of CPU.  I can see its one core, using the menu-meters app.

     

    The issue wont occur if I start the mac with the hard drive already connected, then kick off a TM backup.  It will only occur if I plug in the disk after I've started it and then go to do so.

     

    I think reporting to bugreport.apple.com is a fair idea though

  • 17. Re: kernel_task running wild!
    rodcha Level 1 Level 1 (0 points)

    Yes pedrosp2 it was DROPBOX!

  • 18. Re: kernel_task running wild!
    ylluminate Level 1 Level 1 (0 points)

    I think the real takeaway here is that Apple needs to add better kernel_taks logging output for us to ascertain issues.  It's too much of a blackbox presently and even passing issues through gdb are extremely time consuming as there are too many moving parts generally to track an issue down without enormous time investments.  When we get situations like this, it should offer a bit more verbosity in terms of what is going on so that we can isolate out what is actually happening and actually help Apple to resolve the issue.  I think that's the bugreport that we should really file at this point. 

  • 19. Re: kernel_task running wild!
    rodcha Level 1 Level 1 (0 points)

    Well, not quite Dropbox either.  Although is much better now, my Mac totally slows down when Time Machine is active. Apparently, it has also to do with having an external HDD encripted with Time Machine.

  • 20. Re: kernel_task running wild!
    colin N Level 1 Level 1 (0 points)

    It is more likely hardware than software.

     

    So many of us using different software, on the same hardware - MBA have the same problem. I get it when I use Safari, Mail, iPhoto, iMovie, while doing a Time Machine Backup to a non-encrypted Time Capsue.

     

    But ONLY on battery. (i.e. everything runs smoothly on AC, have you guys tried pluging in to AC?)

     

    It's an energy saving thing beacuse the MBA batteries cannot deliver enough power for the processor and fans at the same time, should the demand for processor clock increase.

  • 21. Re: kernel_task running wild!
    neversleepz Level 1 Level 1 (0 points)

    @colinN What happens when the backup finishes? The problem described here keeps the kernal_task on high CPU AFTER Time Machine has done its work (or is cancelled) and remains pegged high until you reboot.  Doesnt matter what apps you run.  Is that what you are experiencing, or just slow perf when on battery?

     

    My MBP is pretty beefy so I dont get the slowness but I am unable to keep the laptop in my lap once this starts as it gets very very hot when the one of the cores is pegged at 100%.

     

    When I reboot with my USB plugged in, and can start a time machine backup without issue, my CPU doesnt peg.

  • 22. Re: kernel_task running wild!
    colin N Level 1 Level 1 (0 points)

    OK. I'm sorry, the slowness kicks in DURING backup. I'm getting this slowness on my MBA (Lion, latest gen) whenever:

     

    1. I'm on battery
    2. I'm doing more than one thing at a time: Mail+Safari OR iTunes+Safari OR Preview+Pages or a combination of these, making it even more disastrous! (or sometimes, just one thing, like watching a Youtube Video on Safari)

     

    (Both conditions above fufilled. No problems on AC: I can render a video till it hits 90 degrees celcius and I don't get any slowness!)

     

    I have a MBP that is never slow doing things. It gets hot, but whether on battery or AC, it is responsive. Sadly, no SSD there unless I upgrade.

  • 23. Re: kernel_task running wild!
    neversleepz Level 1 Level 1 (0 points)

    Yeah thats ok. My first thought was that it was slow because of disk IO, but then realised the MBA has an SSD in there!

    The one thing I've noticed coming from PC land is that the Mac hides its power saving decisions.  On a PC I could see and set what items (wireless, SSD, etc) went into power save mode and what level to put them on.  If I had any issue with performance I could temporarily tweak it up.  Its been good so far on OS X not having to worry about power management settings nor have to power saving settings from Economy mode but I can appreciate when the Mac is making bad decisions about how much power to use it can be frustrating to resolve.

    Without wanting to distract too much from the original point of the thread, perhaps you can try:

    1. re-nice'ing the processes of the apps you are running so they have more priority cpu/time over the kernel_task (a windows/linux trick. dont know how you'd go about it on mac outside of the cmd line)
    2. find out how Mac does its power saving modes and tell it to stay in AC power mode
    3. find a tool or utility that disables or pauses time machine once you go on battery mode (google or start a new thread)

    Good luck

  • 24. Re: kernel_task running wild!
    colin N Level 1 Level 1 (0 points)

    Yeah. You can't tell it what to do, it tells you what to do, and it has a mind of it's own.

     

    I could re-nice the tasks, but I think nothing will override kernel_task

    Perhaps we could see how they control the power. There's a coupple of AppleIntel kexts

    You can disable Time Machine Auto backups by sliding the switch to "OFF" in System Preferences. I've already done that for some time, so I only backup when I'm going for a toilet break or a drink. (i.e. not doing anything else for a while)

  • 25. Re: kernel_task running wild!
    thegiorgio Level 1 Level 1 (0 points)

    Same issue here on macbook air, after shutting down both Dropbox and Evernote and waiting a good 5 minutes, my CPU is back to normal. I don't know which one of the apps is faulty, most likely Dropbox but that solved the issue for me!

  • 26. Re: kernel_task running wild!
    marc.mielke Level 1 Level 1 (0 points)

    same-same on my mbp8,3. i had'nt used the backup for a while and my kernel_task was always around 35-40%. after reading all that infos regarding kernel_task behaviour i found that nothing of all the suggested solutions worked for me.

     

    as the only change since my kernel_task wen wild was switching off time machine i switched timemachine on again and used a different external drive as backup volume and did a backup.

     

    my kernal_task behaves again... taking .5 to 1.5% max.

     

    so for me the problem clearly was related to my backup situation. 

  • 27. Re: kernel_task running wild!
    marc.mielke Level 1 Level 1 (0 points)

    i forgot to mention: i'm using dropbox too, it's active and for my constellation it does not seem to be part of the problem.

  • 28. Re: kernel_task running wild!
    kallisti Level 1 Level 1 (0 points)

    a lot of ppl are citing dropbox as the major suspect, so I just switched it off.  I tend to run pretty heavy realtime dsp processes that are frequently interrupted by this wildfire cpu bs

     

    I should know within the next 24 hrs if killing dropbox solves anything.

  • 29. Re: kernel_task running wild!
    makalu57 Level 1 Level 1 (0 points)

    I have a MBA and a connected 27" Cinema Display. The Activity Monitor shows the Kernel Task taking over 300% of CPU% at times. This seems to happen only after the MBA has been running for a while. From Googling this problem and looking at how my Mac behaves I think this is a problem due to CPU overheating: The CPU on an MBA works harder when an external display is connected. Likewise I would guess that other processor intensive tasks (encryption, video editing, and - Steve Jobs was right - Flash processing!) trigger this condition. Initially I solved like everyone else, by restarting the MBA. If I don't connect the external display the condition does not seem to occur, or at least the Kernel Task is not appropriating too many CPU cycles.

     

    Having said this, when I reconnected the monitor and the problem arose again I followed Damitri's advice and clicked on the Inspect button in the Activity Monitor: the problem went away immediately (thanks Damitri). I suspect this resets a variable somewhere, and the Kernel Task runs out of control because of a bug in the OS that Apple hasn't fixed yet.

1 2 3 4 Previous Next