Previous 1 2 3 4 5 6 Next 125 Replies Latest reply: Aug 17, 2014 2:00 PM by smitting Go to original post
  • makalu57 Level 1 (0 points)

    The problem seems to affect different people in different ways. I have a MB Air and on which the Kernel Task ran wild after about one hour from power up. I am running the Mac in clamshell mode with an external Cinema Display. The problem only occured when I connected to an external power source. When I disconnected the monitor or ran on battery the problem went away. This seemed to indicate that if I reduced processor overload the problem would disappear (on battery the processor works in power saving mode and removing the external display means that I am no longer using the graphics processor as much). However the problem always returned when I plugged in to power and added the monitor. Up until that point I had always run the Mac in it's protective leather cover. An employee at the Mac store where I purchased the Mac in Bangkok suggested that the cover might be contributing to the overheat problem. So I removed it when using the MB in clamshell mode and the Kernel task problem has never occured again!


    My experience seems to indicate that heat is a problem somehow. But others in this discussion disagree, based on their experiences. All I can say is that by removing the protective jacket from my MB the problem went away and has never reoccurred. I run 10.7.4, Safari (that with Flash is a really crappy processor hog), MS Office, Aperture, iPhoto, iTunes and another processor hog that is Carbonite offsite backup. I connect through WiFi and use Bluetooth keyboard and mouse.


    I am sure that Apple are aware of this, but I am also sure that the "new Redmont" people in Cupertino will never acknowledge the problem until they fix it...

  • e__soriano Level 1 (0 points)

    I think it has to do with power saving, it seems to be a bug in the kernel extension. I think it happens when the laptop is running out of battery.


    This worked for me:


    preferences -> energy saver

    disable all the settings (put the hard disk to sleep and so on).

    restore your settings



  • e__soriano Level 1 (0 points)

    Well, it happened again, and the previous trick didn't work, so forget it.


    Power saving is the suspect #1 anyway. It seems that if the laptop is suspended and resumed, the load gets normal again...

  • StAxis Level 1 (0 points)

    MBP 2010, I just experienced my first kernel_task crash and decided to do some looking around, I had all of my power saving features maxed out for performance and experienced a crash, it shouldn't have been at any time particularly intensive, had a game and music running, but nothing compared to what I have done even in the past couple days and had not experienced a crash then so I don't think it's necessarily power saving, haven't seen anyone on any forum with a definite answer though. I have seen some suspect of Nvidia graphics cards, but others who have Radeon and may be experiencing the same thing so I don't know if that is the place to pin it either.

  • VailGeek Level 1 (0 points)



    Just want to keep this thread going. I'm an Apple Certified Technician and I too am expereinceing this problem on my Mid-2009 13" MacBook Pro running Mac OS 10.7.4


    I've tried all the tips and tricks that I know as well as most of the above mentioned.


    Reset PRAM

    Disable Start Items

    Uninstall LightSpeed Systems User Agent

    Login with and without the computer running off external power

    Start in Safe Mode

    Reset Energy Prefs



    You get the idea. The only "quick fix" that I've found is that if you put the machine to sleep it will wake back up and the Kernal_task will operate within normal parameters then. Hopeing Apple finds a fix to this soon, because giving Kernal_task 80% of my processing power isn't really an option for me. I need da POWER! =P

  • e__soriano Level 1 (0 points)

    This bug is REALLY ANNOYING.


    Is OSX becoming Windows NT or what?

  • IEBA1 Level 1 (5 points)

    I was KT free for a while, and then it reared its ugly head again. Couldn't get rid of it for a couple days, and it seemed to keep using more CPU power.


    I tried rebooting once and the computer wouldn't even come back up- just a grey screen.


    I unplugged the laptop, took the battery out, flipped it over, put an 8" clip fan blowing on the bottom and let it cool down completely for a few hours. Plugged it back in, booted up, and then the KT hasn't come back for a week now.


    It really does seem heat related- something gets "stuck" and the only think I've found to resolve it is to kill the power for hours, or even a day.


    My next machine may be a Mini, and then I'll buy one of those dorm refrigerators and put the Mini inside there. Its not "overclocker" cold, but it may keep the runaway Kernel Task from ever coming in the first place.

  • kallisti Level 1 (0 points)

    hey vailgeek


    I seem to have solved my own cpu wildfire issues with a bit of tedious work by correlating other ppl's solutions in the various threads about this problem.  Of course this means i resorted to the shotgun technique, as follows:


    • The first thing I did was to manually download and run the updaters for every extension/driver/system addition/helper utility, Firmware Updater in my rig.   This included things such as Stuffit, Dropbox, VMWare, Drobo, Motocast, Proprietary Hard drive menus, Logitech mouse drivers, Audio interface drivers, Midi interface drivers, printer drivers, scanner drivers, Matrox drivers etc....try not to miss any.


    • After enabling and rebooting the machine as root user, I opened up the root Library and created the following folders:


    Internet Plug-Ins (disabled)

    LaunchAgents (disabled)

    LaunchDaemons (disabled)

    PrivilegedHelperTools (disabled)

    StartupItems (disabled)

    Audio (disabled)

    Quicktime (disabled)

    Components (disabled)

    ScriptingAdditions (disabled)


    • from here I meticulously picked through all of the files in the correlating resident folders and looked for old/outdated software (some updaters/installers dont clean up their garbage) as well as stuff that I never intended to be on this machine.  It's a good idea to list modification dates on this junk since plugins over 3 years old are probably extinct and causing problems....for example I found an ancient launch product from Cocktail that was attempting to "tune" my bandwidth.


    • I then moved onto the System Library.  Here I created the folder "Extensions (disabled)".
    There's something pretty satisfying about discovering PPC kernel extensions from 2003 among other old and useless garbage.  Check the startup items folder in there too just in case.


    • At this point, doing anything else in your system will trigger the instabilities inflicted by removing active extensions, so its a good idea to reboot.

    While resetting the PRAM on this boot, hold those keys down until it chimes THREE (3) times.


    • Using Fontbook, I selected all the fonts in my system and told it to hunt for problems.  I corrected even the minor problems.  very handy app with a convenient bulk-processing feature.


    • Then I ran the Onyx utility to scan all of the preference files for found a few.  After which I set Onyx to clean every last cache in my system.


    • reboot again


    • I know it sounds weird, but once you're fully booted and logged in: reboot one more time


    • If you have a ridiculous number of external drives (I have 23 drives on my MBP quad i7) it is extremely possible that a bad drive in an array is freaking everything right the **** out.  It is your mission to pinpoint that drive.  Besides just running the Disk Utility repair function, you should run the "write a single pass of zeros over free space" function.  This will not only map out some bad blocks, but it might reveal a drive who just doesnt want to cooperate under heat-load.


    • If this kernel bs persists after you did everything, try running the extended hardware test with everything plugged in, and then run it again, without everything plugged in.   Some stuff fails under load.  Some stuff wont fail on the test until you take the load away.  I dont know why.


    Anyway, my wildfire kernel task is pretty happy these days.  I use a few beta apps, like the Dropbox leading edge beta, Firefox, and Transmission.  It's always a good idea to manually check for updates since some betas dont update automatically.  It wouldn't hurt to start ripping out outdated Firefox extensions.


    I found tons of junk.  Something(s) I removed fixed it


    Good luck

  • VailGeek Level 1 (0 points)

    Thanks for the help Kallisti


    First I wanted to pass along that this problem will persisit if you upgrade to Mountain Lion (which took 2.25 hours btw). Not sure if this Kernal problem is what made the upgrade take so long, but I think 2.25 hours to update on OS is a bit outta line. I'll either give up and do a clean install or try your suggestions, but I'm outta patience with this problem. It is a huge drain on system resources and I think a clean install should fix it... but I'm still not sure why an OS upgrade didn't.


    Thanks again!

  • kallisti Level 1 (0 points)

    A clean install will definitely fix the problem completely


    i did a little experiment and popped a clean install on an external esata drive and behold, the problem did not I stopped hunting for a hardware issue and committed myself to the above drudgery

  • e__soriano Level 1 (0 points)

    >> A clean install will definitely fix the problem completely


    Sure. Buying a brand new macbook-air also solves the problem.


    Apple must release an update to fix this problem. A bug in a kernel extension

    is too serious.


    This is the typical solution of the Microsoft World: a clear install.

    No, thanks. Is Apple the new Microsoft?


    Maybe it is time to go back to Linux or BSD.

  • kallisti Level 1 (0 points)

    I dont think you really get it.



    its not apple's kernel extensions causing the bug


    its 3rd party crap left behind in your system most likely from a migration


    also its not exclusively kernel extensions

  • e__soriano Level 1 (0 points)

    >> I dont think you really get it.


    No. I think you didn't get it.


    >> its 3rd party crap left behind in your system


    3rd party userland crap should never make the kernel crash or go wild like this.

    If this happens, it's the kernel's fault.  Operating Systems 101.

    The only 3rd party kernel extensions in my system are the VirtualBox kexts

    (and they are not the problem).


    >> most likely from a migration





  • kallisti Level 1 (0 points)

    yes tell us more about how much you dont get it

  • IEBA1 Level 1 (5 points)

    kallisti wrote:


    A clean install will definitely fix the problem completely


    i did a little experiment and popped a clean install on an external esata drive and behold, the problem did not I stopped hunting for a hardware issue and committed myself to the above drudgery


    I installed a bare SSD in my laptop. Installed 10.5 clean from CD. Installed fresh drivers for my attached peripherials. I still had to boot off my old drive, now external, for various tasks to use software that I wasn't going to install here. Within a day, KT was back.


    The only thing that gets rid of it for me, sometimes, is turning the system off, for hours, and forcing it to cool down. (add an external fan, etc) And I use mine in an air conditioned home office.


    But then, once I quash it, its gone for days. And I can be hammering the system editing AVCHD. Safari can be using 90% of the CPU to do nothing, I can have a handbrake compression going on... and when I quit Safari and Final Cut, and Handbrake ends, as long as the Kernel Task hasn't cropped up on its own, the fans will slow down and I can leave the system idle for days without issue.


    So it's clearly not what I have installed or attached. It's the OS.

Previous 1 2 3 4 5 6 Next