5 Replies Latest reply: Nov 20, 2012 11:03 AM by notats
susanfromclifton Level 1 Level 1

I have a MacBook and an Epson NX 420 which is connected wirelessly through a router.   The wireless setup is good as a PC can print successfully, but attempts to print from the Mac return "communication error".  There is no error code associated with it.  The OS version is 10.6.8 and the printer driver version is 8.6.0, both of which are up to date.  At one point this setup worked but now all I get is this "communication error".  Does anyone have any thoughts?


iMac, Mac OS X (10.6.8)
  • Epson Mac Tech Level 2 Level 2

    My name is Syd and I work for Epson America, Inc. 

     

    Try the following:

     

    Power on the printer.

    1. Open System Prefrences

    2. Open Print and Fax

    3. Highlight the NX 420 driver

    4. Click on the "-" sign

    5. Restart the Mac

    6. Reopen Print and fax

    7. Click on the "+" sign

    8. Select the NX 420 Bonjour driver

    9. Click on Add

     

    If the above does not work, you will need to reset the Printing System, which will delete all of you driver, and reinstall it again. If you must reset the Printing system please know you will need to reinstall each driver, you currently have installed, one at a time.

    Here to help,

    Syd

  • rememberer Level 1 Level 1

    I'm experiencing the same issue. How does one "reset the Printing system"?

  • Matt Broughton Level 5 Level 5
  • notats Level 1 Level 1

    I am getting same error. But when I plug USB cable into PC Laptop printer scans and prints fine. Seems wireless function of printer no good. I have Airport Extreme Router sometimes it sees printer sometimes not. No ryhme or reason when it works, just get lucky.  Wouldnt recommend this printer even though Apple Store does.

  • notats Level 1 Level 1

    Hello Syd-

     

    I also am having many issues with the Epson NX-420 either wireless or with USB connected to Airport Extreme router. Sometimes router sees printer with USB, sometimes not. Right now it does not, and if I try to scan or print from Epson control window also get many errors with communication. PC laptop only system that works but only with USB. Please Help!