Previous 1 2 3 Next 30 Replies Latest reply: Aug 8, 2013 7:56 AM by berlindude Go to original post
  • berlindude Level 1 Level 1

    I have reported the problem to Apple who have taken reports from our Mac Mini Server, I'm hoping to receive some positive feedback in the next day or so.

    I have also reported it (one or two years ago), don't expect any help …


    Are you still running OSX Server 10.6.8 … the AFP problems have been around for several OSX versions.

    Yup, still 10.6.8 – don't believe in Apps ;-)

    I startet reproducing it with 10.5.7 (client-version) and it's not hardware specific (had this also with an iMac and a MBP).


    I can't understand why more people have not experienced it.

    They do, but they don't see it.


    Something must trigger this AFP issue because we did not experience the problem with our old Server …

    Like I already said, It's the speed. You need a min. of 40 MB/s in both directions at the same time. Our second server is a G5 PowerMac and I never got this speed out of it.


    Please can you expand on your workaround

    E.g. you have the shares A, B and C (folders a, b and c on the RAID), take the shares away, make a new folder d and the share D and put the folders a, b and c in d.


    and do the combined shares still appear as separate hard drives

    This you can put to "pain in the a…" – you can't any more. The clients see separate folders, maybe with separate restrictions but no more separate shares

  • cygnusx Level 1 Level 1
    I have also reported it (one or two years ago), don't expect any help …



    I really hope this is not the case, having spent over £2,000 on a new server/RAID setup. I now feel we should have stuck with the slower yet more reliable G5 PowerMac setup.


    E.g. you have the shares A, B and C (folders a, b and c on the RAID), take the shares away, make a new folder d and the share D and put the folders a, b and c in d.


    I'm not sure this will work for our setup, we have a Pegasus R4 RAID which has been partitioned and we share each hard drive partition over the network, we also have a separate thunderbolt drive for achived files.


    I imagine we would need to reformat the R4 to a single drive then use a folder system on the drive as you have suggested.


    I will forward this thread to the Apple support adviser I have been speaking too, in the hope something gets resolved. I'm not giving up on Apple yet, but I can see how you have after all these years.

  • berlindude Level 1 Level 1

    I'm sorry to say, but I think too that the "start from scratch tactic" with one single drive will be the best way. The safety and usability is going to **** (Maybe there is an App for this ), but who cares, it's fast like thunder.


    And hey, 2k is no money in this world here. We've spent over 25k € in last 5 years for Apple hardware. I now need some new client machines and maybe a 3rd server. But great: you can't buy these overpriced MacPros any more here in Germany. There are no more Xserves or any kind of machine to buy in the Apple world wich you could call "Server". The MiniSe… how to put an FC or SCSI Card into it?


    And for my clients? They need a powerfull machine and a non glossy display … what was the problem with the MacPros again? Ah, the EU laws.


    We want to give them our money, but they don't want it because with iStuff the profit margin is much better.

    Right now Apple is a Consumer Computer and Telephone selling company.

    They simply don't want us poweruser any more. The dau is a better cow


    I'm sorry, I am realy pi..ed on Apple. After 16 years loyalty I now have to learn working with Linux if they don't bring something good at the next WWDC.


    <Edited By Host>

  • flyingcactus Level 1 Level 1

    Not sure if it is available in Germany, but for FC there is always the Promise SANLink sn3=49


    And for other cards there is the Sonnet Echo box


    I have used the promise SANLink, and it works well, but it is too bad it is not 8Gb though.

  • berlindude Level 1 Level 1

    Hi cygnusx,


    did you got some new information on this? Maybe from your Apple support adviser or someone/-where else?



    I know these boxes, but what's next? You have to buy an "MacRack" to get these so called Servers into your rack. You need two of them to have a redundand power supply. Because you now have two machines, you also need two SANLinks or Echo boxes to get your Storage attached and where do you put them into your rack. You can tape them under the MacRack

    Or you buy the new Sonnet Echo Express III (don't think this will be inexpensive)

    In the end you've got a 3U-two-separate-system-server where the XServe did the same job with 1U.

  • cygnusx Level 1 Level 1

    Only just finished testing in the last few days but I believe I have solved our AFP file corruption problem. After extensive testing and a number of reinstalls, the problem was being caused by Objective Development's Little Snitch application. This was installed on the Mac mini server and client Mac's, once uninstalled from all computers I have been unable to replicate the file corruption. We installed Little Snitch to protect the computers, but it seems to have been interfering with AFP share copies. Not sure if this helps you?

  • berlindude Level 1 Level 1

    Finaly a new idea. This sounds plausible and it's possible that in all my testings always was min. one computer with Little Snitch on it. I've tried deactivating it, but I didn't try uninstalling it.


  • cygnusx Level 1 Level 1

    Yes deactivating Little Snitch does not work, it needs to be uninstalled using the Little Snitch uninstall application and then the Mac restarted. The problem needs to be reported to Objective Development when I get around to it, but I can't trust their software on our network now.


    berlindude, let me know if this fixes your issue and I will report it to Objective Development

  • berlindude Level 1 Level 1

    I'll test it asap and write here my results.

  • berlindude Level 1 Level 1

    You've got it!

    I've copied 5x a package of 4GB Photoshop Files from share A to B (both on an SSD for max. speed) complete without Little Snitch – 5x no MD5 differences!


    After that I've installed Little Snitch on only one machine, deactivated it, copied the files again and got the first MD5 errors.


    So I would say you're absolutely right. Please report this to them and I'm gona do the same – just in german.


    Thank you very much!

  • cygnusx Level 1 Level 1

    Glad it resolved your problems as well, can't trust Little Snitch now even if they fix the problem which is a shame. I did not quite make it to a million Thank you's

  • berlindude Level 1 Level 1

    cygnusx wrote:


    can't trust Little Snitch now even if they fix the problem which is a shame

    Me neither.

    Did you wrote them too?

    I already got an answer and they don't believe me. They say, that they are not able to reproduce the Problem.

  • cygnusx Level 1 Level 1

    Not had time, if they have Little Snitch running on both Mac's (the server and client) they can't miss the problem as it increases the file corruption. They can't be testing properly, as removing the application solved both our file corruption issues.

  • Trey Level 5 Level 5

    I just wanted to comment to say that I'm having what seems to be the same problem at a particular client's site. I'm pretty sure no one there has Little Snitch though, but I'll check to be sure.


    Can you guys verify that you haven't seen this behavior since getting rid of Little Snitch?

  • cygnusx Level 1 Level 1

    I have not seen the problem since removing Little Snitch off our networked Mac's. I'm now very careful with installing any application that monitors network traffic.