11 Replies Latest reply: Mar 10, 2013 6:35 PM by danielwkuss
BGRCONCORD Level 1 Level 1 (0 points)

I have a lovely Epson AccuLaser CX11N pruchased in 2007 that worked like a charm on Snow Leopard. But stopped working after install of Lion. Dammit.

 

Epson tech support says any updates would be thru apple software updates...THEN that

 

"Thank you for contacting Epson regarding the Epson AcuLaser CX11N. I apologize for any inconveniences you may been experiencing. Since there are no updated drivers for Lion, I would recommend that you connect this printer to an older compatible operating system. I do not know when updated drivers will be available."

 

Are they ******* kidding me?

 

So now I am looking around at printers in the Apple store and they all get low reviews. THEN I talk to some genius at WC Apple STore and learn that most of the printers there don't even work with Lion cause it's new tech.

 

EXCUSE ME? How many beta updates went out to developers prior to the release of Lion?

 

Epson and other print vendors should be in jeopardy of losing whatever Apple certification it has  for not supporting the Lion platform.

 

I looked at Gimp page and nothing yet on Epson drivers for Lion.

 

I also can't get at "generic postscript driver" to see if that works.

 

This is a goddam mess.


iMac, Mac OS X (10.7), epson, acculaser cx11, lion, driver
  • 1. Re: epson printer drivers
    Kappy Level 10 Level 10 (226,855 points)

    Have you installed Apple Epson Printer Drivers 2.7 drivers update for Epson printers? Also, see Epson's page regarding Lion support.

     

    Before using any of the Lion drivers it would be a good idea to open Print & Scan preferences, delete the existing printer(s) you have installed, CTRL- or RIGHT-click in the list space and select Reset Print System from the contextual menu. Now try re-adding the printer and locating a driver included with Lion.

  • 2. Re: epson printer drivers
    Tony T1 Level 6 Level 6 (8,385 points)
  • 3. Re: epson printer drivers
    BGRCONCORD Level 1 Level 1 (0 points)

    Epson page

    http://www.epson.co.za/Printers-and-All-In-Ones/Laser/Epson-AcuLaser-CX11NF/Driv ers-Support?target=article&extn=.html&articleId=4894#toc5

     

    says "current driver (5.4) is compatible.

     

    NOT

     

    I was able to select image of printer in add printer and select v 5.4 but then when I went to print I got message that printer was not responding not connected despite the ethernet connection.

     

    Now when I go to setup printer I get nothing in the window.

     

    I cannot get RESET PRINT SYSTEM to appear

  • 4. Re: epson printer drivers
    BGRCONCORD Level 1 Level 1 (0 points)

    After RESET PRINTER, Add Printer Window comes up blank, when default icon is highlighted

    click on IP icon lets me choose :ine Printer Daemon or Internet Printing Protocol

     

    Because I have had NOTHING BUT f*&cking problems with LION since install (safari and iTunes and Mail and Finder) I had to reinstall lion over lion.

     

    It seems to me I may have wiped out all epson drivers per apple instructions

  • 5. Re: epson printer drivers
    John Blanchard1 Level 5 Level 5 (4,740 points)

    According to http://support.apple.com/kb/HT3669, the printer is supported on Lion.

     

    Have you tried adding it with USB? Can it be added with the "Default" tab?

  • 6. Re: epson printer drivers
    BGRCONCORD Level 1 Level 1 (0 points)

    AL CX11 does not have USB connectivity. Nothing shows up in the DEFAULT tab.

     

    Epson has to make this good. It says it is Lion compatible and I have current rev of printer driver (5.4) poer its page cited above.

     

    I have asked Epson tech who told me to go away that EPSON should contact me to fix.

     

    No reply.

  • 7. Re: epson printer drivers
    John Blanchard1 Level 5 Level 5 (4,740 points)

    BGRCONCORD wrote:

     

    AL CX11 does not have USB connectivity.

     

    I have asked Epson tech who told me to go away that EPSON should contact me to fix.

     

    The docs on Epson's site show it having a USB connection.

     

    Good luck with Epson.

  • 8. Re: epson printer drivers
    BGRCONCORD Level 1 Level 1 (0 points)

    BINGO.

     

    Details for posterity

     

    I found a mini to USB and plugged it into a USB port on the back of the iMac and the little fawker chirped. Name appeared in Default window. Clicked ADD. Did a test print.

     

    OK

     

    Supply levels does not report info.

     

    Epson Scan did not open when device was connected as Network Device (no IP address). So I deleted and added new, clicked on local instead of Network and scanner became availble both in print set up and epson scan.

     

    Takeaway. So the device works as a local USB printer and can be shared via print sharing, I suppose.

     

    Problems were in the network settings and how driver communicated (or didn't ) with Lion as a network device.

     

    I will sacrifice two doves later as propitiation.

     

    Still wonder if Epson will fix networking in some subsequent driver.

  • 9. Re: epson printer drivers
    Carlos in New York Level 1 Level 1 (5 points)

    I had a similar problem.  Just bought an Epson Workforce 635 last week.  Epson website said  \that if the CD that came w/ the printer does not include 10.7, then "DO NOT install CD".  Kudos to Epson.  But then the website instructions were a little confusing.  So I called Tech Support.  Finally managed to install WiFi for printing.  But WiFi for scanning drivers never installed.  Epson told me it's an Apple problem.  Apple guy was on the phone with me for an hour.  Then said we can't do anything more, tell Epson to unsintall and re-install.  Called back Epson, this time a Level 2 technician took the call.  Same thing.  Moreover, I bought the printer because it claims Auto 2-sided printing.  It won't allow me to enable 2-sided printing!  It's greyed-out on MS Word. 

     

    So just got back from returning printer at Staples.  Now looking for a Lion compatible priner that does:

     

    Automatic 2-sided printing

    Automatic 2-sided scanning

    WiFi capable

    Auto Doc Feeder

     

    Anyone have a clue for a printer that works with Lion?!  

  • 10. Re: epson printer drivers
    royfromwestville Level 1 Level 1 (0 points)

    Carlos, don't mean to "raise you and see you" but I have a ridiculous situation. Recently bought an Epson 9890 large format printer which is crazy as I am merely an amateur photographer. Amazing printer. Then, because "everyone" says if you do Photoshop you must use a Mac, I just bought a Macbook Pro. No matter what the web site may say this printer, and probably most Epson printers, simply do not work with Lion. No problem, says my local Epson supplier. Simply downgrade to Snow Leopard. This makes me ecstatic because I have spent 3 weeks cross-grading, downloading, upgrading etc all my software and plug-ins from PC to Mac. Not going through that again. So, only solution is to buy a PC again (sold my old one), do all the processing on Mac, copy files to flash and transfer to PC to print. Isn't that just dripping with irony?

    Good luck with your printer.

  • 11. Re: epson printer drivers
    danielwkuss Level 1 Level 1 (0 points)

    perfect! thanks. worked for my epson AL C1100.