8 Replies Latest reply: Apr 29, 2013 3:11 PM by paulcb
aaron27 Level 1 Level 1 (0 points)

For some reason, the navigation arrow in the top status bar by the battery % is always on. And now my battery is draining much faster than normal.


I looked at the Location Services menu under the iOS Settings. I found that both the built in Maps app and The Weather Channel app are currently tracking location, given by the navigation arrow next to them in Location Services. This continues even after I manually close them and restart the phone. I can get it to turn off by switching both of the previously mentioned apps to off in the Location Services menu, but then I can't use the GPS in those apps. The battery right now is down to 34% at 8pm, with no more use today than normal. It's usually still at 60-70% this time of day. The iOS updates are all current.


I don't remember having this problem until a day or two ago. The navigation would only be active when I was activly using an app that needed navigation at that moment. I have not done any iOS updates in the last few days. I messed around with the Location Services options for the first time a few weeks ago, but haven't been in there in the last few days. I turned on the option for Facebook to get the "check in" feature to work.


If anyone knows how to fix this or explain why it's happening, I'd appreciate it. It's seriously killing my battery life.

iPhone 4, iOS 4.3.3, The iOS version is 4.3.5, not 4.3.3
  • e-dub4 Level 1 Level 1 (0 points)

    Having the same issue! Looking forward to replies!

  • e-dub4 Level 1 Level 1 (0 points)

    On another message board, I read the following:



    I had installed one app, I forget what it was called, some kind of mom calendar thing, that made my arrow always be on as well. Even if it wasnt running in the background, it would stay on. I finally uninstalled it for good.


    Go to your settings and turn off Location for each of your apps until the arrow disappears, and that may tell you the culprit...


    Some of the apps with location service had the icon next to them within the Location Services settings. I checked those first and viola! It was the Weather Channel app for me! I turned off its services and the icon is gone! I assume I can just punch in my location in the app or turn on the service for it when I need it.

  • aras52 Level 1 Level 1 (85 points)

    The arrow is there to show that an app or program uses or have used your navigation service.

    Check the settings for your apps.

    It is well explained in the manual.

  • e-dub4 Level 1 Level 1 (0 points)

    I am quite familiar with the customary use of Location Services. The issue I had was with an application that was using location services when those services are turned off. The manual to which you refer suggests that turning off the service should maintain my privacy and not use the resources of my device. There is apparently a bug resolved by turning off the services at the app level that was not resolved by doing so globally. Further insights on this issue would be most appreciated.

  • aras52 Level 1 Level 1 (85 points)

    I understand now. It sounds bad with a bug like that!

    Have you been in contact with those who made this app?

    I think you shoud also send a message to Apple App Store.

    Privacy is a serious and important matter.

  • aaron27 Level 1 Level 1 (0 points)

    Well, for some reason, I dont seem to be having the problem any more. It was happening yesterday, but hasn't happened yet today. I didn't do anything different. The arrow came back when I was using Maps, but turned off when I closed the app, like it should. I was having it stay on for the weather channel app to. Maybe it had to do with the recent update that program had.

  • bukbie Level 1 Level 1 (0 points)

    Google Now was doing it for me.  Shut it off and the arrow disappeared...

  • paulcb Level 6 Level 6 (19,095 points)

    Google Now was doing it for me.  Shut it off and the arrow disappeared...


    Ditto, even when the app was removed from the multi-taksing bar.  Had to turn it off in Privacy > Location Services.