10 Replies Latest reply: Jun 7, 2012 7:24 AM by Fred Turner
Fred Turner Level 1 Level 1 (85 points)

Probably like some of you, I have servers that I maintain still running Leopard Server, either due to the client not wanting to upgrade to 10.6 or 10.7 Servers, or simply not being able to, due to running a G5 as the server hardware. On each of these systems, I've enabled 10.6 machines to update via SUS by using the SUS modification steps in this previous thread:

 

https://discussions.apple.com/thread/2169042

 

I have started w/ those same steps here (already done from before), and after referring to Apple's KB article at http://support.apple.com/kb/ht4771 about hosting 10.7 updates on a Snow Leopard server, added an extra line to /usr/share/swupd/html/content/meta/mirror-config-1.plist:

 

<string>http://swscan.apple.com/content/catalogs/others/index-lion-snowleopard-leopard.merged-1.sucatalog</string>

 

This seems to start working and will actually download the Lion catalogs, show the new updates (e.g. 10.7.1) in the list, and allow updating to those releases for a 10.7 client I tried, but then it appears to stop working and not fully complete the download process. I get this in the SUS log:

 

Wed Aug 17 00:01:07 server.mydomain.com swupd_syncd[19541] <Info>: Started
swupd_syncd(19541,0xa06ff720) malloc: *** mmap(size=2453504) failed (error code=12)
*** error: can't allocate region
*** set a breakpoint in malloc_error_break to debug

 

I've now verified this behavior on a G5/2.5GHz DP and an 8-core Mac Pro, both running Leopard Server 10.5.8. Anybody else giving this a try? Any ideas what might be going on here?

 

Thanks,

Fred

  • Cocopocoloco Level 1 Level 1 (0 points)

    I have exactly the same problem. Somebody to help us ?

  • bodgers Level 1 Level 1 (5 points)

    The malloc error means that the swupd_syncd process tried to allocate some virtual memory (2453504 bytes, in this case) and there wasn't enough available.

     

    This isn't because you don't have enough RAM.  And it's probably not because you don't have enough disk space for VM.  This is probably happening because swupd_syncd process is a 32-bit process.  32-bit processes can have up to 4GB of virtual memory space.  For some reason, swupd_syncd is eating all of it up and running out.

     

    There are two reasons I can think of for why this may be happening:

     

    - swupd_sync in 10.5 was never designed to host updates for 3 different OS's, so it isn't as efficient as it could be with memory allocation

    - swupd_sync in 10.5 has a memory leak, which only becomes a problem when we add Lion updates to the mix

     

    Either way, it looks like we're stuck trying to work around this problem.  I tried configuring swupd to sync only Lion updates (no 10.5 or 10.6 updates) by removing references to them in 'mirror-config-1.plist'.  So far, VM for swupd_syncd has topped out at 2.34GB, instead of climbing well past 3GB before crashing with the malloc error. But all this does is confirm that, for whateever reason, swupd_syncd requires too much memory for the Lion updates.  When I add either the Leopard or Snow Leopard updates into the mix, VM grows too high and swupd_syncd crashes when I get the malloc error.

     

    For the record, the Lion updates have not actually started downloading yet.  But I'm not interested in having only 10.7 updates on my 10.5 server.  So I've stopped this experiment and reverted to just 10.5 an d10.6 updates.

     

    Once I get the 10.5 and 10.6 updates synced, I will try adding the 10.7 updates to the mix.  Perhaps it will require less VM, although I doubt it.

  • Thomas H. Level 1 Level 1 (0 points)

    Hi everyone,

     

    Thanks for the info. I'm in the same boat as the OP.

     

    I've just tried removing the 10.5 catalogue URL from mirror-config-1.plist (don't *think* there are any 10.5 machines on my network these days) to see if it can serve 10.6 and 10.7 updates only. I'll post my findings...

     

    Cheers,

     

    Tom

  • Thomas H. Level 1 Level 1 (0 points)

    So, I still got the malloc error with the SUS serving just 10.6 and 10.7 clients. Removing the 10.7 catalogue URL from mirror-config-1.plist has solved the problem.

     

    With that in mind, it would seem that the error is caused specifically by the 10.7 updates?

  • Steve Folly Level 2 Level 2 (175 points)

    Hi,

     

    Is there any update on this? Did you ever get your 10.5 server serving Lion updates?  I'm having the same problems.

     

    Cheers,

    Steve

  • Fred Turner Level 1 Level 1 (85 points)

    To contribute back to my own thread.......I realized a little bit ago that I've started seeing many-- if not all-- of the Lion updates in my non-modified 10.5.8 SUS that previously was only showing 10.5 & 10.6 updates. So, w/o the extra config bits that were causing the malloc and other errors above, I'm seeing the 10.7 updates in my SUS anyway. I'm seeing this on all my other administered 10.5.8 servers as well.

     

    Can you guys confirm and/or comment on this? I can't recall a specific case yet of a Lion machine picking up a system update (like 10.7.3) from a Leopard SUS yet, but then again, I haven't made a specific effort to check. I will do that as soon as I can.

     

    Fred

  • Steve Folly Level 2 Level 2 (175 points)

    Fred - funny you should say that... about 3 weeks ago, around about 29th/30th March, I noticed our internet usage was suddenly rocketing up towards (and past...!) our monthly limit - after investigations it turned out to be our OS X Leopard server was downloading approximately 20GB of updates.

     

    Like you, I tried to modify SUS using the steps in the link you posted. When I had the same problem as you I just reverted everything.

     

    Now, since that download at the end of March I am indeed seeing all Lion updates in the list (in Server Admin) as you are...

  • Thomas H. Level 1 Level 1 (0 points)

    Interesting. I can't contribute to the discussion any more because I actually decomissioned the ol' faithful G5 server last week, but I got an unexpected bandwidth spike around the same time, too. Did anyone actually have a 10.7 machine download and install an update?

  • Fred Turner Level 1 Level 1 (85 points)

    Well, crud. I was successfully serving 10.7 updates from my 10.5.8 Servers, without even specifically adding 10.7 links to the mirror file...until I tried to add some of the newest updates today. Now I'm back to getting the malloc error in my first post. The worst part is that there's no 10.7 option to turn back off-- it's already off. Anybody else seeing this?

     

    Fred

  • Fred Turner Level 1 Level 1 (85 points)

    It now appears that Apple has changed something to do with its catalog files, such that my 10.5 SUS is working again w/o the swupd_sync malloc crash. Basically, all of the extra Lion stuff (seemingly most damaging, the hordes of voice updates) that was causing memory overruns has been stripped so that the 10.5 SUS doesn't see it, and all is working again. The upside is that new updates for 10.5 & 10.6 can be added again; the downside is that 10.7 & 10.8 (Preview) updates are no longer available.

     

    Would love to hear what you others are seeing. I may try the Lion trick again (adding it in the conf files), just to see if it still causes swupd_sync to choke. Sure would be nice if there was someone at Apple we could contact directly about this, rather than just waiting to see when they feel like making a change!

     

    Fred