Previous 1 2 Next 25 Replies Latest reply: Jul 26, 2012 6:42 AM by zioflat
zioflat Level 1 Level 1

I did upgrade to lion on launch and noticed that textedit and preview work quite well except when  changing network location: after a few seconds of spinning ball, both crash.

Tried repairing permissions, deleting "containers" folders in my library and so on, without luck.

Anyone is experiencing the same problem?

This is an excerpt of the crash log:

 

Process:         TextEdit [663]

Path:            /Applications/TextEdit.app/Contents/MacOS/TextEdit

Identifier:      TextEdit

Version:         ??? (???)

Code Type:       X86-64 (Native)

Parent Process:  TextEdit [656]

 

 

Date/Time:       2011-08-18 01:14:19.349 +0200

OS Version:      Mac OS X 10.7.1 (11B26)

Report Version:  9

 

 

Interval Since Last Report:          7146 sec

Crashes Since Last Report:           17

Per-App Crashes Since Last Report:   15

Anonymous UUID:                      5E6B69BE-D41B-45F4-BA5B-1DD8298A76AA

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x00000001c0a529a0

 

 

VM Regions Near 0x1c0a529a0:

    MALLOC metadata        0000000108342000-0000000108343000 [    4K] rw-/rwx SM=PRV 

-->

    MALLOC_TINY            00007fc808c00000-00007fc808f00000 [ 3072K] rw-/rwx SM=COW 

 

 

Application Specific Information:

objc[656]: garbage collection is OFF

*** multi-threaded process forked ***


MacBook, Mac OS X (10.7), Unibody late 2008, 4 GB RAM
Reply by bbenny on Aug 24, 2011 9:08 AM Helpful
same here.  very frustrating.  i can confirm it does only happen when changing location from menu bar.   Macbook Air, Lion OS X 10.7.1
Reply by Topher Kessler on May 10, 2012 1:32 PM Helpful
I've figured it out. Unfortunately it is a bug in Lion that will need to be addressed by Apple, but it will not hurt a thing. When you change locations, a bug in the system's sandboxing routines is causing the system to spawn another instance of the foremost sandboxed application as a child process of the current instance of the program. This environment causes the new program instance to crash, resulting in the crash report you see. It does not affect the current instance of the program that contains your work. The only drawback here is the annoyance of the crash log, and that the network location does not get changed; however, you can get it to do so by switching to the Finder or to another non-sandboxed application and changing the location with that one as the foremost application. You can see this in your crash report above, where the process that crashes has a different process ID number (663) than the parent process (656). If you look at Activity Monitor, you will see the TextEdit program's PID is 656 (that of the "parent"). The new process quits so fast it does not even appear in Activity Monitor. Message was edited by: Topher Kessler

All replies

  • zioflat Level 1 Level 1

    UPDATE: Textedit and preview don't crash if the network location is changed throgh the network preference pane. The issue shows up only when changing network location from the menu bar shortcut.

     

    Any ideas?

  • zioflat Level 1 Level 1

    UPDATE 2: I'm having this issue both on my iMac and my Macbook, so I suppose it's a lion bug and not simply something related to something that went wrong during the update (permissions or something like this). It's both in 10.7 and 10.7.1.

    I'm going to try on my wife's Macbook to see if it's something related to some software or setting I'm using; in the meanwhile, can someone out there try to reproduce this issue? Just open textedit and change the network location from the menu bar (you should create one other than "automatic" for  "locations" to show up just below "dock"): at this point you should get the spinning ball and then a window telling you that textedit just crashed. Try to do a couple of times if it doesn't crash the first one.

    BTW I noticed that textedit doesn't crash if you have the network preference pane open and active ("system preferences" showed on the menu bar) and change the location from the menu bar.

    I think I'm going to give a call to Applecare to see if there's some plan to get this corrected in some next update.

  • bbenny Level 1 Level 1

    same here.  very frustrating.  i can confirm it does only happen when changing location from menu bar. 

     

    Macbook Air, Lion OS X 10.7.1

  • zioflat Level 1 Level 1

    Thanks for replying.

     

    Same even with my wife's white macbook (late 2009). So it seems to be a quite widespread issue; curiously it didn't surface until now, since network locations in the menu bar are all but hidden.

    However, I did already file a bug report through Apple's feedback form.

    Tomorrow I'm going to call Applecare and hear if the have any workaround or if they're already aware of this issue.

  • MatzeOne Level 1 Level 1

    I had the same problem and found the solution which worked for me using google:

     

    http://npenkov.com/2011/08/12/preview-crashes-under-mac-osx-lion/

  • zioflat Level 1 Level 1

    This seems to be a different case from the ones described in other threads about textedit and preview  crashes. Even the crash reports posted seem different.

    I didn't create any symlink (at least, as far as I know), and textedit and preview don't crash at startup but work flawlessly except when changing network location, and only from the menu bar, not from network preference pane. I'm more keen on thinking that it's something related to how network settings are managed by the os.

    Did you experience exactly the same issue?

    Anyway, I could try the terminal script you posted, except for the fact I don't know where to point the new symlink at the end (since actually I didn't create any)...

  • zioflat Level 1 Level 1

    Probably I've found some sort of workaround.

    Textedit crashes when changing network location only if it's the active window (I mean if "textedit" is shown next to the apple in the menu bar).

    So if you are using textedit (or preview) and have to change network location, first switch to another application, then change the location from the menu bar. This should do the trick.

    Anyway, I hope it will be fixed in 10.7.2.

  • EricS Level 1 Level 1
    expertise.macosx
    Mac OS X

    I'm having the identical symptoms, and am running 10.7.2, so unfortunately it's not fixed yet.

  • zioflat Level 1 Level 1

    Yep, no fix in 10.7.2. Maybe Apple was too much focused on iCloud .

    Let's hope that if enough people will report this bug through the feedback form at http://www.apple.com/feedback/macosx.html , it could end into Apple's "to do" list for 10.7.3.

  • zioflat Level 1 Level 1

    10.7.3 and textedit still crashing...

    Come on, Apple, this is really weird, this is not an isolate issue...

  • bobgutierrez Level 1 Level 1

    I do have the same issue, the only workaround i try effectively is changing to another application out of TextEdit and Preview and changing the network location.

  • zioflat Level 1 Level 1

    In a response to a bug filing, Apple told me this is a known issue already being investigated. Let's hope 10.7.4 will fix it.

  • zioflat Level 1 Level 1

    Nope.

    Bug still there in 10.7.4 ....

  • bbenny Level 1 Level 1

    video of the problem, very easy to duplicate.

     

    http://youtu.be/v_D6k2omtdM

Previous 1 2 Next