Previous 1 2 Next 28 Replies Latest reply: Jul 23, 2013 11:47 AM by Kraftwerk
boboconnell Level 1 Level 1

I have found that as I am adding my content to a wiki page, once I click the save button, the page gets stuck with a modal pop-up stating "Checking page status...".  If I refresh the page, the content I added is not saved.  I have also found that once this has happened on a given page, no further edits of the page's content are saved, regardless of the content type.  Has this happened to anyone else, and is there a solution to the issue?

  • andrewnesbitt Level 1 Level 1

    Can you turn on Safari debug mode, and show the web inspector console.  When you hit save, do you see any JavaScript errors?  Also, what does /var/log/collabd/coreclient.log say around the time of the save?



  • Atrato Level 1 Level 1

    I have got the exact same problem.


    I've tried multiple browsers (Firefox, Chrome, Safari) and they all get stuck when I edit the homepage.


    How can this behaviour be fixed?

  • Georg Egger Level 1 Level 1

    Exact same problem here, I have 2 servers on one a meanwhile 4 gig wiki is working flawlessly, on the other one, constant problems. One i have firwalled myself one is firewalled by the department, I am researching if its about some ports that need to be opened in addition.


    The problem presents itself in 2 ways:


    1* uploading of files ( 50kbyte e.g ) just timed out.

    2* Saving a page hangs on checking page status


    The workarounds so far:


    1* delete and reup a file on some other page in the wiki, every time the other upload that stalled will work again

    2* In most cases deleting the table helps, in almost all cases there is a table in pages that hang.Going back in revison, if you can definitly helps.


    Here is a log on a page that keeps hanging, everything seems ok

    -------------------------------------------------------------------------------- ----------------------------------------

    Started POST "/wiki/api" for at Wed Sep 14 10:00:46 +0200 2011

      Processing by ApiController#call as JSON

      Parameters: {"{\"authRef\": \"5CF1D6BE-ECEB-4446-9238-FA86E7DD0E5E\", \"serviceName\": \"ContentService\", \"methodName\": \"checkACL:againstEntityTinyID:asUserExternalID:\", \"arguments\": "=>{"\"write\", \"eventsveranstaltungen\", \"02D5AA46-5E5A-491A-8BBC-C20EA23D405A\""=>{"}"=>nil}}}

    req JSON:

    {"authRef"=>"5CF1D6BE-ECEB-4446-9238-FA86E7DD0E5E", "methodName"=>"checkACL:againstEntityTinyID:asUserExternalID:", "arguments"=>["write", "eventsveranstaltungen", "02D5AA46-5E5A-491A-8BBC-C20EA23D405A"], "serviceName"=>"ContentService"}



    JSON Response:



    Completed 200 OK in 53ms (Views: 0.3ms)



    Started GET "/wiki/entities/38e1dc95-e65d-426a-a8e6-0f1f63ce3a7b/latest_revision" for at Wed Sep 14 10:00:51 +0200 2011

      Processing by EntitiesController#latest_revision as JS

      Parameters: {"id"=>"38e1dc95-e65d-426a-a8e6-0f1f63ce3a7b"}

    Rendered text template (0.0ms)

    Completed 200 OK in 139ms (Views: 0.8ms)


    Started GET "/wiki/entities/56ae3fff-08db-4aa3-aaba-c02d579bb416/latest_revision" for at Wed Sep 14 10:00:53 +0200 2011

      Processing by EntitiesController#latest_revision as JS

      Parameters: {"id"=>"56ae3fff-08db-4aa3-aaba-c02d579bb416"}

    Rendered text template (0.0ms)

    Completed 200 OK in 59ms (Views: 0.8ms)

    -------------------------------------------------------------------------------- ----------------------------------------



    Upon further inquiry I checked history, and voila the page as it should be was shown correctly with the changes in the revision on #1, of course you cant revert to that, in the wikis state, this IS/should be the current page, but it is not the changes are not shown when you navigate there, only in the revision history as no1 everything looks as it should, going back one revision, then redoing the changes worked flawlessly. I think it should be clear that something goes wrong saving the page (maybe connection wise) the logs really dont help though.


    So maybe some ports need to be open besides 443 ?

  • Atrato Level 1 Level 1

    I found the issue to be in the database in the binary data for the page.


    What I did to "fix" it:


    I went on the server to look for the uid:


    bash-3.2# psql -U_postgres -dcollab
    psql (9.0.4)
    Type "help" for help.
    collab=# select uid, long_name from entity where entity_type_fk = '';
                     uid                  |             long_name             
     19a307c1-82bc-45c7-845a-21839fb222c7 | unauthenticated user
     c2248027-71b1-4ed7-b6ff-b6f9caf8f5ab | default_content.server_home.title
    (2 rows)
    collab=# select count(*) from entity_attrs where entity_uid_fk = 'c2248027-71b1-4ed7-b6ff-b6f9caf8f5ab';
    (1 row)


    I installed phpPgAdmin on the server, went to the entity_attrs table, looked up the record, edited the record to remove the value of attrs_bin, saved the record. Then I edited the record again and pasted the value which I removed earlier. When I got to the page it was corrupted but after saving twice I was able to get it going again.


    I think that a solution can be:


    1. Create a new "blank" page and save the value in attrs_bin.

    2. Put that value in a corrupted page (which hangs).


    It is not pretty but I am glad it is "working"  again.

  • patrickmoffatt Level 1 Level 1

    My Wiki page with tables hangs too and changes are not saved.

  • Svein Hopland Level 1 Level 1

    I have experienced both issues above.


    When uploading documents - .pdfs, .docs - the upload process either does not finish at all - or it finishes way to fast - and then when saving - the "checking page status" hangs.


    Also - when editing and/or adding links in tables - and also in bulletpoints - the content vanishes.


    The wiki was setup a week ago - and not used to much - just to see how it behaves - and I must say I am not impressed.


    This could have been a very good product, now I feel unsecure about the stability and performance.


    Three more things: I think there is a memory leakage somewhere - the amount of ram that is used is almost constantly on 80% - and that without any usage. Secondly the lack of admin tools - such as "show me orphan pages" is frustrating even prior to starting to use it. Thirdly - I see in the log that there are quite a few errors of various types popping up.


    And, as far as I can tell - I do not have anyone to send them to at Apple for bug fixing either.


    I have a strong feeling THAT THIS IS A PREMATURE PRODUCT, that Apple either must prioritize or call back.

  • renownentertainment Level 1 Level 1

    We had the same issue and it was fixed by editing the page and removing any lines (carriage returns) that were blank (and saving which worked right away).


    This issue occured when we tried to do a Wiki page entry on a Windows7 PC using Firefox. We tried using a Mac but once the page had that error, we were unable to save the Wiki page until doing the above. This is the only time we've seen it so far.

  • Svein Hopland Level 1 Level 1

    I am sorry to say that you have merely found a cure for a sympthome. The Server still seems to me as a not worked through, tested and prioritized product.


    Best of luck to all of you who ventures into the Server product.


    I will not.


    Apple: Get a grip.

  • Georg Egger Level 1 Level 1

    I have 2 servers, one of them ran flawless for the test phase ofthe executive staff ( mac users ) as soon as it went public, I can definitly say stay AWAY from firefox, especially uploading docs, especially with tables it posts

    garbage and sometimes pages get completly screwed. One page had 30 documents on it ...all links went into nirvana. Ever since everyone is forced to use chrome from pc ( a nice feature is add wiki calendars serverside even from windows ( add to ical ) ) the system is flawless again. firefox is bad, too many major releases in such a short time messed it up.

  • EruMantis Level 1 Level 1

    Checking page status is also in "stuck-mode", but I think I have found the trigger for this (I mean just trigger, no idea why that is):


    I have a Wiki read&write accessible for group. When I put something on a page in that wiki, all works fine. Someone from the group tries to change something or add something -> they get the checking page status.

    When I (the owner) go to the wiki again, and try to make changes, I too get the checking page status in stuck mode thing...


    So, does it screw up the access rights or something when different users try to change something in the wiki?


    Hopefully Apple will take a closer look at this.

  • Svein Hopland Level 1 Level 1

    I have started a Confluence instance - and must say that Atlassians product looks really good, and would highly reccomend that enterprise solution for anyone considering a wiki.


    But, for those who will try out the Lion Server - best of luck

  • EruMantis Level 1 Level 1

    Hey, I just talked to Apple Support. While doing that we arrived to a solution... at least in my case.


    In my wiki, I added Files to a table. That worked well until someone else wanted to add content in form of a file (like a ZIP) to the table. That completely screwed the page. Deleting the talbe and it's content made the page editable again. And if you add Files in the whitespace instead of a table (in a table it looks nicer though... more organized) it works great.


    Didn't know if that helped, but there seems to be a problem with the Wiki Server and the Postgres DB when adding Files to a table. I can think of a reason why this is... but that would be speculation.


    Long story short: check if you have any tables on your page which hold files. If yes, delete the table. That worked in my case.



    PS: that was shown in the log by a line like this: **************invalid HTML string**********

  • mcihle Level 1 Level 1

    i have the same issue... any solutions?

  • kinstonfrombeijing Level 1 Level 1

    I have the same issue as well, Please help!!!!!!!!!!!!

Previous 1 2 Next