9 Replies Latest reply: Oct 31, 2011 6:07 AM by Secret Steve
jaayne Level 1 Level 1 (0 points)

I treated my self to a new Macbook Pro with the AMD Radeon HD 6750M 1GB graphics cards..

 

Now that I've got everything up and running just dandy I Bootcamped Windows 7 (64 bit) on it to see how it would handle some gaming, I tried installing the latest graphics drivers from AMD and am presented with this error message :

 

"Your Computer does not contain a proper graphics adapter."

 

Is this normal?? Has Apple restricted the installations of drivers on the MBP or have I got a problem?


MacBook Pro, Mac OS X (10.7)
  • 1. Re: Your Computer does not contain a proper graphics adapter??
    JoeyR Level 6 Level 6 (8,275 points)

    Notebook drivers are very often specific for the notebook itself.  AMD does offer generic drivers, but performance can vary.  Did you select the correct "mobile" GPU when you downloaded the driver and not a desktop version?  Other than that, your best bet is probably to use the BootCamp driver.

  • 2. Re: Your Computer does not contain a proper graphics adapter??
    jaayne Level 1 Level 1 (0 points)

    I used the AMD auto detector software and have tried the direct approach by downloading the drivers manually and both gives the same message!!

     

    Very strange!!

     

    And yes I downloaded the correct drivers I ain't an expert but I'm not an idiot hahahahahahaha lol..

     

    Wonder if Apple Care can help but I'm assuming they won't cause it's technically a windows error??

  • 3. Re: Your Computer does not contain a proper graphics adapter??
    craiigman Level 1 Level 1 (0 points)

    I am having the same issue, but with a 27" iMac. Looking to upgrade the drivers for the Battlefield 3 beta in a few days, but getting the same problem. Anyone managed to fix this yet?

  • 4. Re: Your Computer does not contain a proper graphics adapter??
    OrphanGymnast Level 1 Level 1 (0 points)

    Yes I figured it out, I needed this to play the battlefield 3 beta and took me a while to find.

     

    http://support.amd.com/us/gpudownload/Pages/bootcamp-win7.aspx

     

    There was a mac section for the driver download on the AMD website. This link is for the bootcamp graphics driver for macbook pro, windows 64bit version.

  • 5. Re: Your Computer does not contain a proper graphics adapter??
    craiigman Level 1 Level 1 (0 points)

    Thanks for the reply, but when I tried to install it nothing happens?

  • 6. Re: Your Computer does not contain a proper graphics adapter??
    craiigman Level 1 Level 1 (0 points)

    Now it says "Failed to load the detection drive" ?

  • 7. Re: Your Computer does not contain a proper graphics adapter??
    OrphanGymnast Level 1 Level 1 (0 points)

    Worked for me. But for some reason it is saying it is an ATI catylst, but I am currently playing battlefield 3 beta so it must have worked. I still get an error that the driver is out of date, but the game starts anyways. You need like winrar or winzip and look for the setup file in the folder you installed from AMD website. Should work

  • 8. Re: Your Computer does not contain a proper graphics adapter??
    iSTIZO99 Level 1 Level 1 (0 points)

    Hi folks!  I was scouring the web for some answers and got pulled to this thread.  I've got a mid-2011 iMac 27", i7 with the 2gb HD 6970M (bootcamping Win7, 64-bit) and I also get that same error as OrphanGymnast when attempting to play the Battlefield 3 Beta.  Whenever I try to join a server it says my Catalyst version is out of date and that I need to upgrade, in turn it only references the generic AMD url.  However, the game still manages to play, but I'm not sure if I'm getting the proper performance I should be getting with the latest driver.  Anyway I tried AMD's auto detector and nothing...same message shown above in the OP.  Now I find myself here.

     

    I'm not that hardcore about pc gaming so messing around with drivers and such is pretty new to me.  From what I gather the reason for getting, the "Your Computer does not contain a proper graphics adapter." is because mobile/laptop GPU's have to rely on their manufacturers (Apple, in our case) to roll out their specific driver updates and not AMD.  I used the following links, but encountered a few problems.

     

    Driver Install Instructions for Win7:  http://support.amd.com/us/kbarticles/Pages/GraphicsDriverInstallationInstruction forMicrosoftWindows7.aspx

     

    ATI Catalyst Mobility Display Driver:  http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx#2

     

    When I tried to uninstall the current ATi catalyst it was not showing up in "Programs and Features".  I figured I could then just run the CCC and saw there was an uninstall option through there.  CCC ran the uninstall, but the progress bar got hung up about 99% of the way through and after about a half hour in that state, I decided to End Task.  By now, my display is all out of wack since it deleted the original driver.  I rebooted and proceeded to install the 11.9 catalyst and that too got hung up about halfway through for a while...had to End Task again.  Rebooted and display was still jacked up so I just threw back in my Bootcamp Support Disc and repaired drivers...now all things back to normal (display driver v8.812). 

     

    So now that I'm back at square one, would anyone that successfully updated their mobile GPU care to tell me where I messed up? I would greatly appreciate it.  I apologize for the long read, but I wanted to be as clear as possible.

     

    Thanks!

  • 9. Re: Your Computer does not contain a proper graphics adapter??
    Secret Steve Level 1 Level 1 (0 points)

    All. I have a fix after several hours of stuffing around. Another thread put me on to this. Get the AMD Preview drivers version 11.10.

     


     

    1. Uninstall the Boot Camp display drivers totally and reboot into Windows with the Standard VGA drivers.

    2. Install the Preview drivers (version 11.10)

    3. Wahlah!

     

    Seems the preview drivers contain all you need to get current iMac video drivers updated!

     

    Most importantly - I'm playing Battlefield 3 right now!!!