9 Replies Latest reply: Mar 13, 2012 4:26 AM by WolfeMan581
LCar619 Level 1 Level 1 (10 points)

Under sharing and permissions what are these "fetching" and "wheel" accounts  that seem to have shown up since I did the lion update?

iMac, Mac OS X (10.7)
  • Kappy Level 10 Level 10 (262,780 points)

    See Wheel. There is no such user account as "fetching."

  • LCar619 Level 1 Level 1 (10 points)

    The sharing and permissions for all three of my external HD's showed an added "read only" account called "fetching..."


    Your explanation for wheel is interesting but is there some reason I am missing as to why I now have three settings under sharing and permissions for my iMac HD.


    System: Read & Write

    Wheel: Read Only

    Everyone: Read Only


    Is it just trying to say that all "wheel" or admin users will still only have read access to the main HD?

  • Kappy Level 10 Level 10 (262,780 points)

    Those are the "standard" permissions for a hard drive.


    System is the "user"

    Wheel is the "group"

    Everyone is, well, everyone.


    For hard drives and other "folders" or "files" the OS is configured such that only the "system" or "root" user has read/write access. Those other users belonging to the wheel group have read-only access.


    I think "fetching" may mean the OS is looking for any other users or groups, but I confess I've never seen that before.

  • LCar619 Level 1 Level 1 (10 points)

    Thank you for the help.

  • Normand Lepine Level 1 Level 1 (20 points)

    Well, see here: https://discussions.apple.com/message/16032688#16032688


    I have the same issue. The Permissions Repair process did nothing to modify these weird privileges. What's going on?



  • RegKnick Level 1 Level 1 (0 points)

    careful with that axe, eugene...


    after upgrading from 10.6 to 10.7 I begain noticing some apparent delays in many processes. upon running disk utility there were a bunch of the ACL errors thrown and permissions overall were whacked. the suid error that's now been around since 10.5 and longer said it wasn't repairable. following the advice of apple since 10.5 or before I ignored the suid and acl errors and repaired permissions. and then again... and then again... and then again.


    the next morning i sat down to the machine, booted up, and then discovered my harddrive wouldn't allow me to open it. after more ignoring of these known errors as apple has advised on multiple threads, i attempted to manually modify the permissions on my drive simply so i could get access to it.


    the screen went blank and started some horribly long process that eventually resulted in a reboot that never ever completed. hours later after multiple recovery attempts i decided to do a complete wipe of my drive and do a clean install of 10.7 only.


    it was wonderful for about 36 hours. now wanting to run a time capsule to get a backup the disk utility shows all the errors again and there are some very strange file and folder issues showing up. i fear something awful is coming. we've been told to ignore them... i wouldn't if i were you.



  • cheekypaul Level 2 Level 2 (220 points)

    fetching, it's a big issue for the many apple users who have migrated from snow leopard to lion. i'm having problems - and a google search (because it's not well documented in apple support) - tells me it's not an isolated issue.

    i've tried the terminal resetpassword/acls route, but it hasn't solved my issue.

  • WolfeMan581 Level 1 Level 1 (0 points)


    I saw "wheel" turning up on occasion, but didn't connect it's appearance with the Lion upgrade.


    So I know I deleted the permissions for Wheel in a few places, thinking it was a leftover from another much earlier project.


    No Idea where I did this, now, so my question is have I screwed up access to whatever they were??


    I haven't really noticed anything missing (yet)