Previous 1 4 5 6 7 8 Next 108 Replies Latest reply: Mar 28, 2016 11:57 PM by reconize Go to original post
  • bazanders Level 1 Level 1

    Unfortunately Mountain Lion does NOT cure this issue, still the same with my OKI c530dn as before

  • asicloud Level 1 Level 1

    I suffered this when I first upgraded to Lion when it first was released.


    I did find this fix.

    Took me a while to find again..

    As you mention, this issue first appeared with 10.6.8 due to changes made to CUPS where a function "backend SNMPsupplies" reported warnings rather than errors. For certain brands of printers this call resulted in the incorrect information being reported back to the Mac. While the CUPS organization released a patch to resolve this it seemed that Apple did not do the same and relied on the vendors to change their drivers.


    One common workaround at the time was to modify the PPD for the printer so that the SNMP calls were not made. This is done by adding the line "*cupsSNMPSupplies: False" to the printers ppd file located in the /etc/cups/ppd. Note that you will need administrative privileges to perform this workaround.


    Before showing the workaround I have to say that I have not heard this issue happening with Lion, but then the printers I support that had this issue on 10.6.8 have no official Lion drivers yet. Given that it only just started recently you would have to question what has changed for this to appear. Does System Preferences > Software Update > Installed Updates show any update around this time?



    The following steps for 10.6.8 were posted by EFI in their Tech Ticker Alert, posted June 27, 2011.


    For this example we will use ColorPrinter as the name of the printer affected by the 10.6.8 update.


    1. From the Finder menu choose Go, then Go to Folder...
    2. Enter /etc/cups/ppd in the Go to Folder dialog box and choose Go.
    3. Find the ppd named ColorPrinter.ppd. (This is the same name as the ColorPrinter in Print and Fax with a .ppd extension. )
    4. Drag the ColorPrinter.ppd to the Desktop.
    5. Open the ColorPrinter.ppd with TextEdit.
    6. At the end of the PPD add the following line exactly as written: *cupsSNMPSupplies: False
    7. Save the modified ColorPrinter.ppd to the Desktop.
    8. From the /etc/cups/ppd folder, move the original ColorPrinter.ppd to the trash. Authenticate when prompted.
    9. Drag the modified ColorPrinter.ppd from the Desktop to the /etc/cups/ppd folder. Authenticate when prompted.


    Printing should now work as expected.

  • profinite Level 1 Level 1

    Thank you, asicloud, for this writeup. Your procedure has cured the issue once and for all with my OKI C6150dn.

  • bazanders Level 1 Level 1

    As above thanks asicloud, also worked for my oki c530dn

  • sjallyn1 Level 1 Level 1

    This did not work for me or perhaps I am not sure exactly where to put this text.

    Does it go before the metadata?

    Before the "end of PPD"?

    The PPD for the Oki C9800 is huge and i have tried to put this text in may places resulting in nothing printing.

    this is makeing me crazy, and I need this printer to work.

  • sjallyn1 Level 1 Level 1

    Also, do we need to re-add the printer? or log out? or restart?

    So far nothing has worked for me.

  • Coralin888 Level 1 Level 1

    Do not delete the printer as you will delete the .ppd file, it should just work. Make sure when you save the file in text edit you are not leaving it with the .txt extension, its just .ppd nothing else. Also its important that the old file is put in trash otherwise it will remain vaild.

  • Coralin888 Level 1 Level 1

    The last few lines of my OKI 530 .ppd file looks like this: the cupsSNMPSupplies:False is added as the very last line of the file.



    *%XML:     <string>/var/folders/wc/fcm_xsnd1ml795q72njkxt8h0000gn/T//0ea2c5033f4b0</string >

    *%XML: </dict>

    *%XML: </plist>



  • sjallyn Level 1 Level 1

    Thanks for that, but for me it does not.

    I am still very unsure where this bit of text is supposed to go.

    After the FONTS portion of the ppd, there is all this stuff and there are verious places that say END or End of PPD and I am wondering if this added text needs to be before or after which one of  the "END" bits.


    *?FontQuery: "


    { count 1 gt

    { exch dup 212 string cvs (/) print print (:) print

    /Font resourcestatus {pop pop (Yes)} {(No)} ifelse =

    } { exit } ifelse

    } bind loop

    (*) = flush



    *?FontList: "

    save (*) {cvn ==} 128 string /Font resourceforall

    (*) = flush restore"






    *% ========== Meta Data ==========



    *% DATABASE SIZE: 3903488

    *% DATABASE IDENTIFICATION: webtool_db.mdb@@\main\174







    *% PPD Last Modified 2006.07.31

    *% OS 10.4 PPD DB version 5/10/05 JDF

    *%cupsFilter: "application/vnd.cups-postscript 0 /Library/Printers/Oki/Filters/fierycupsfilter"

    *%APDialogExtension: "/Library/Printers/Oki/PDEs/EF4X3324 (FJN).plugin"

    *%APDialogExtension: "/Library/Printers/Oki/PDEs/EF4X3324 (CW).plugin"

    *% End of PPD file

  • sjallyn Level 1 Level 1

    yeah mine looks so different. I attached just the last part to my previous post.

  • Coralin888 Level 1 Level 1

    Scroll down to the very bottom of the file, ignore anything that the files say, its not relevant, you just insert the text into the very very very last line. Do not mess around with this file in any other way. If you have already done so, then delete the printer and start again as the .ppd file with be re-added on install. Clear your trash as well so you don't bring any old files back.

  • marprint Level 1 Level 1

    got same problem with our new xerox 550, we open the Terminal of the Utility folder and ping the IP address of the printer, then it worked.


    hope this will help

  • aychseven Level 1 Level 1

    Had this problem with my new Oki Data C610DN. Since all the suggestions point to SNMP supplies reporting, I just turned off SNMP in the printer's web interface. The driver can no loger see supplies levels, but this is a non-issue for me.

  • da136203 Level 1 Level 1

    Woohoo! Fixed for HP Color LaserJet CP4005 on mbpr running 10.8.2. Thanks!


    A note to some trying this:

    I had to duplicate the file in order to edit it, and then once the duplicate ppd was created (on my desktop), I had to authorize the move into the former ppd folder with a system password. Smooth sailing afterwards.


    Text was placed at the verrrrry bottom, as follows:




    *% =================================

    *% For "HP Color LaserJet CP4005"

    *% =================================

    *cupsSNMPSupplies: False

  • da136203 Level 1 Level 1



    Now my printer proxy won't close automatically.


    Similar issue to...


    Does anyone else have this problem after doing the *cupsSNMPSupplies: False fix?

Previous 1 4 5 6 7 8 Next