Previous 1 2 3 Next 504 Replies Latest reply: Sep 7, 2015 4:41 PM by T.Emnik Branched to a new discussion.
joyfromfayette Level 1 (0 points)

When charging my screen reads "charging is not supported with this accessory".  Why?

iPhone 3GS
  • brad805 Level 5 (7,340 points)

    Could be due to after market charger, firewire the list is endless.


    Try a different charger, USB cable etc.


    Clean dock port of iPhone with clean dry toothbrush. If this does not help clean dock port with some Isopropyll Alcohol.

  • Bonesaw1962 Level 4 (1,255 points)

    ditto the ideas that Brad suggested..I got this message a while back when I first tried to use an ATT iPhone car charger in a VZW iPhone...but it charged anyway....I'm wondering if it has something to do with the power output of whatever charging device is being used...

  • AHJax Level 1 (0 points)

    I am having the same issue after upgrading to IOS 5.0, however I only get the message when attached to my PC.  It worked perfectly fine prior to the upgrade. (same cord, same laptop, etc) I really hope that they get this systemic problem corrected, as it is a pain to not be able to charge while connected.

  • chris7129 Level 1 (0 points)

    hi guys ,i am having the same issue [charger is not supported with this accessory] with 3gs(4.1-[8b117] ), i  tried using new orgnl charger, tried new batetry, new home button..., It worked perfectly fine just for an hour them the problem still continues... however my problem is not solved ....i love my iphone .. kindly if any 1 has delt with this issue plz let me knw ...


    many thanks



  • liquifury Level 1 (0 points)

    I have the exact same problem.  iPhone 3gs.  IOS 5.  plug it in to my computer using the original USB cable and I get the "Charging is not supported with this accessory" error!  What gives!?!?!

  • almadison Level 1 (0 points)

    I was having the same issue with my ipad every time I connected it to my computer. That's usually where I charge the ipad. I just leave it connected via USB overnight and it's good to go in the AM. One day I started getting the error. I went through a large amount of troubleshooting and finally came to the conclusion the front USB ports on my box are going bad. I don't get the error when it is plugged into the back ports and the syncing  as well as the charging works as it should. When I get a chance I will replace the front ports, I guess.

  • Lawrence Finch Level 8 (35,063 points)

    The front ports on most computers are all the same port - a built in hub. So if you have other devices that use power plugged in to a front port there won't be enough power left for the iPhone.

  • almadison Level 1 (0 points)

    about a week ago I did not have this issue and nothing has change. I have always had enough power on the front ports of the computer to plug in and run two or three externals simultaniosly, one of those being my ipad(syncing or just charging). Just recently,in the last week or so I have strated getting this error, "accessory does not support charging." At the same time I started having issues with extrnals plugged into the front ports.

  • AHJax Level 1 (0 points)

    This issue for me started after upgrading to  5.0, and it carried over into 5.0.1.  Nothing has changed but the OS, the cables, the laptop, the phone all the same.  Apple refuses to address the NUMEROUS complaints about this issue, which leads me to believe they programmed this bug into the OS.

  • Lawrence Finch Level 8 (35,063 points)

    You missed the NUMEROUS reports from hundreds of people over 3 years who fixed this problem by cleaning the connector on the bottom of the phone.

  • liquifury Level 1 (0 points)

    Yes, this is the real issue.  Nothing has changed but the OS!  Yes, Lawrence, I have tried cleaning the connector.  No difference. 

  • AHJax Level 1 (0 points)

    Yes Lawrence, same issue.. I cleaned everything as suggested, but still no help.  Oh yeah, when it is powered completely off it charges fine.  Still think it isn't the OS?

  • Lawrence Finch Level 8 (35,063 points)

    Yes, I'm absolutely certain it isn't the OS. But I'm not going to convince you, so I will drop off this thread.

  • pwrmacbob Level 1 (5 points)

    I think you are mistaken. I am on iOS 4.3.5 and I am having the same problem. It only happens when I charge from my work PC, and it is sporatic at best. If I use a USB cable connected to an electrical outlet, it is fine. If I connect to my iMac it is fine. I think it may be the USB cable at work, but I keep forgetting to bring another one in. Maybe tomorrow.

Previous 1 2 3 Next