13 Replies Latest reply: Mar 14, 2015 1:19 PM by dianafromhove
Guy Burns Level 2 Level 2 (345 points)

Sometimes I copy info from a website and I end up with a background colour that I can't get rid of in TextEdit other than converting to plain text.

 

Example: go to http://dpreview.com/, copy some text, and paste in TextEdit. It arrives with a black background.

 

How do I get rid of the background and just leave the text?

  • Texas Mac Man Level 8 Level 8 (46,540 points)

    I copied the text & pasted into Text Edit, but the black background didn't paste.

     

    What method are you using to copy? I clicked at the beginning of a paragraph while depressing the mouse & then dragged the cursor to the end of the paragraph. Then selected Copy.

     

     Cheers, Tom

  • BDAqua Level 10 Level 10 (119,775 points)

    Are you using Paste, Or Paste & match style?

     

    I'd get say Tex-Edit Plus for OS X...

     

    http://www.tex-edit.com/

     

    Paste into that, if it's still a problem save it as ASCII & reload it.

  • old comm guy Level 4 Level 4 (2,235 points)

    From the Format menu, select "Make Plain Text" then, if desired, you can then select from the Format menu "Make Rich Text" to style things.

  • Guy Burns Level 2 Level 2 (345 points)

    Okay, this is what I do:

     

    1. Select text on a web page.
    2. Command-C.
    3. In a TextEdit or iText Express document (rich text, with formattted text already in the document), I press Command-V.
    4. Text and black background appears and I don't know how to remove the background. If I press Return at the end of the black-background paragraph, all new text I type also has a black background.

     

    I have two questions:

     

    Q1: What actually is this black background? Is it a text attribute (bold, italic, strikethrough and so on)? If so, what is it called – Black Background? Is it a separate layer (like in Photoshop) that is all black?

     

    Q2: Is it possible to do something to remove it other than setting the entire document to plain text ?

     

    Converting to plain text is not a solution as there is other text in the document that I don't want stripped of formating. A workaround is to paste the text into a new document, make it plain text, then copy and paste into the real document. A lot of work just to try and remove a background.

     

    It seems weird to me that text with black background can by copied and pasted, but the background can't be removed.

  • Limnos Level 8 Level 8 (41,255 points)

    I copied and pasted the first main paragraph but didn't use Textedit because I am using it for another document which I can't close right now and can't change TextEdit to non plain text. I did paste the text into Bean text editor and it came through with a white background. Neither Bean nor Textwrangler show the presence of any invisible characters.

     

    I also copied and pasted the whole page into Bean. Well, there's lots of formatting messed up but only the last three lines of the page have a black background.

     

    If you don't want to lose the formatting (which won't transfer that well anyway with copy and paste) perhaps try a different text editor.

  • Alias_alas Level 1 Level 1 (0 points)

    Old Comm Guy has provided the Correct Answer! Thanks!

     

    I've been looking for info on this same question, because I used the typical copy and paste key commands to get something off a web page and into TextEdit, with the same issue: background color taking over all subsequent text that I typed.

     

    Annoying workflow, but at least there are native keyboard shortcuts.

  • Alias_alas Level 1 Level 1 (0 points)

    It is annoying. Even with selected text, everything will be converted. TextEdit is obviously not really a full fledged word processing application.

     

    Having said that, try pasting into a more robust application like NeoOffice. Seems to involve even more cleanup.

  • rikbarry Level 1 Level 1 (10 points)

    Here's what I just discovered:

     

    Select the text with the colored background.

    Go to Font > Remove Style.

    Done.

  • Guy Burns Level 2 Level 2 (345 points)

    Font > Remove Style might work in TextEdit, but I normally use iTextExpress for its richer features – and there's no Remove Style option that I could find.

     

    However, rikbarry's solution hinted at another method: go to the Styles menu at the top left of every iTextExpress document window, and apply a style. That gets rid of the background.

  • rikbarry Level 1 Level 1 (10 points)

    Actually, I was referring to Apple Notes, sorry.

    But the concept would be the same in any text app with a "styles" option.

  • DonaldGudehus Level 1 Level 1 (0 points)

    Dear Guy Burns,

     

    I couldn't find "Font" nor "Remove Style" in my copy of TextEdit 1.5.  Instead, I clicked on the pulldown menu in the upper left corner of the window of my document, which is labeled "Styles".  With the text containing the offending background color selected, I then clicked on "Default" and the bad color went away.  The help guide in TextEdit talks about "color wells" and "toolbars" but doesn't say what they are or how to access them. 

     

    Donald

  • Jasmine Green Level 1 Level 1 (10 points)

    Thanks Donald, couldn't find this anywhere. Paste and Match Style was not what I wanted

  • dianafromhove Level 1 Level 1 (0 points)

    I have found in a round about way how to solve the problem.    Just copy the text into Powerpoint.  The background colour will disappear.   Then you just copy the text back into a Word document, adjust the font and size and off you go!  Simples!