5 Replies Latest reply: Mar 10, 2012 7:51 PM by llammers
g_nyquil Level 1 Level 1 (0 points)

Machine -

Macbook Pro w/ Lion

Mac mini w/ Lion

 

Both machines were purchased in early 2011.

 

On Macbook Pro, I can see Mac mini and airdrop is visible and is able to transfer file.

On Mac mini, I can't see Macbook Pro is visible in airdrop.

 

Permission setting on both machines are the same.

 

Appreciate if anyone can help.


MacBook Pro, Mac OS X (10.7)
  • 1. Re: Airdrop - can't see nearby computer
    llammers Level 1 Level 1 (0 points)

    Same issue between two 2011 macbook pros. Can't find a solution yet.

  • 2. Re: Airdrop - can't see nearby computer
    g_nyquil Level 1 Level 1 (0 points)

    Not sure how it worked... After I updated to 10.7.3 (delta update), AirDrop started working without making any change on my Macbook Pro & Macmini. However, the nearby computer is not always visible but rebooting the machine made it work again.

  • 3. Re: Airdrop - can't see nearby computer
    racso39 Level 1 Level 1 (0 points)

    Same thing here, my friend's MacBook and my MacBook Pro sometimes both fail to see each other and one of us must reboot to fix (temporarily) the issue.

     

    Until this day, this issue persists.

  • 4. Re: Airdrop - can't see nearby computer
    g_nyquil Level 1 Level 1 (0 points)

    I've recently added iMac in my hardware lists (Macmini+Macbook Pro)... and yes, same issue also occured on iMac as well, sometimes it requires all machines to reboot. Hopefully this is not the best practice from Apple.

  • 5. Re: Airdrop - can't see nearby computer
    llammers Level 1 Level 1 (0 points)

    I tried pretty much everything, and nothing worked. I even spent a few hours on the phone with mac support, and even that didn't fix it, although it did help me figure out that it was my computer that was the problem (mine originally had Snow Leopard and I had just upgraded to Lion, while the other came with Lion)… So, I went with the sledgehammer solution. I used time machine to back up EVERYTHING, did a fresh install of Lion, then copied everything back. Guess what? Didn't work - same problem.

     

    After this, I took a real sledge hammer to it… Fixed the problem right up . Actually, I realized the problem must have been with some system configuration that was carried over from before my upgrade to Lion. So, I decided to give the fresh install another try - this time copying only my Users and Application directories, leaving the Library and System directories out of it. This fixed the problem. I wish I knew exactly which file was caused the problem, but I don't.