4 Replies Latest reply: Aug 25, 2011 4:33 PM by JimHdk
rebeccafromtrumbull Level 1 (0 points)

I am connected to wifi but Internet doesn't work. Software updated and settings reset. Still no luck. I pod touch

iPod touch, iOS 4.3.3
  • JimHdk Level 7 (28,320 points)

    Despite the connection indication you may not really be connected to your WiFi network.


    Your router may not have given your iPod a valid IP address. To check on this go to Settings > Wifi > your network name and touch the ">" to the right to see the network details. If the IP address shown starts with 169 or is blank then your router didn't provide an IP address and you won't be able to access the Internet.


    Sometimes the fix for this can be as simple as restarting your router (remove power for 30 seconds and restart). Next, reset network settings on your iPod (Settings > General > Reset > Reset network settings) and then attempt to connect. In other cases it might be necessary to update the router's firmware with the latest from the manufacturer's support web pages.


    If you need more help please give more details on your network, i.e., your router make, model and version, the wifi security being used (WEP, WPA, WPA2), etc.

  • rebeccafromtrumbull Level 1 (0 points)

    I tried restarting my router and still getting the same problem. The ip address starts with 169. I am using a ubee router and wep encryption. We have an iPad2 that is working fine as well as the pc I am typing this on. I am not sure of the make and model but it is  a cabel modem.

  • lllaass Level 10 (172,150 points)

    As a test, I would set up the router with no encryption.

  • JimHdk Level 7 (28,320 points)

    You should probably test your iPod on some other networks to see how it functions there. If it has problems elsewhere it may need service. Have you tried Settings > General > Reset > Reset network settings?


    Presumably your ubee wireless router/modem was supplied by the cable company? These often are not capable of a firmware update by the customer. Perhaps a call to your ISP for service wouldn't hurt.


    You should not be using WEP security. WEP was deprecated by the WiFi Alliance in 2004 for being completely insecure.