13 Replies Latest reply: Dec 25, 2011 1:32 PM by andrgant
2020pdx Level 1 (0 points)

I am attempting to setup a new Airport Express wireless router and I am recieving this error message

an error occurred joining the selected wireless network

This is the same issue that occurred with my old Airport Express (I got a new one today to attempt to remedy the situation).  The old AE worked in the Apple Store and connected to my Mac Book Pro (10.6.8) just fine in the store.  On the second visit to the store a new Express was suggested and I got home this afternoon, plugged in the new AE, and the same problem exists.  The connection with Comcast works fine when I run my ethernet cable connection directly to the laptop.  At this point it seems that there is interference on the frequency from some other device, but I am not running anything (e.g. wireless phone) that can be blamed.  It may be another unit in my building nearby that has a device that is interferring with the connection, but obviously this cannot be verified.  Suggestions?

MacBook Pro, Mac OS X (10.6.8)
  • Bob Timmons Level 10 (95,560 points)
    The old AE worked in the Apple Store and connected to my Mac Book Pro (10.6.8) just fine in the store

    The Express was configured to "create a wireless network". Your laptop saw the network that the Express was providing and connected to it.


    An error occurred joining the selected wireless network network

    This is a totally different situation than the "test" in the Apple store. Here, you are trying to provide the Express with information to become a client of another wireless network that is being provided by another wireless router.


    If the Express is not joining the network, it has not been provided with the correct information to do so.....probably a security related setting.


    What device is providing the wireless network there? What is the exact type of wireless security that this device is using?

  • 2020pdx Level 1 (0 points)

    Thanks for your reply, Bob.


    Here is my situation, hopefully described more clearly:


    Computer: MacBook Pro, OS X 10.6.8

    ISP: Comcast

    Modem: Linksys (provided by Comcast)

    WIreless router: Airport Express (new from Apple Store yesterday), replacing an older Airport Express

    Security: currently none, as I have not yet set up the new AE, because the error message listed above is coming back when connection attempts are made.


    Two weeks ago, my wireless network was working just fine with the old Airport Express until one night the connection failed abruptly.  Although, I was able to connect to another wireless network that is running in my building without security and I could connect to my ISP with an ethernet cable connection, I was unable to get the connection working with through my Airport Express, which was using WPA personal security.  When testing the same computer and old Airport Express in the Apple Store, using the same WPA personal security and password, the old Airport Express worked fine.  Apple Store sent me home with a new Airport Express yesterday to see if it might be a hardware issue (old Airport Express).  The Genius Bar guy suggested that if the new Airport Express did not connect that it might be an issue with frequency interference from another device in my building.  I am now attempting to setup the new Airport Express (security not yet established) and getting the same error message.  Also, my OS X administrator password has not changed.


    Hopefully, that answers your questions and explains things better.

  • Bob Timmons Level 10 (95,560 points)

    Thanks for the info, but in simple terms, I am not sure how you are trying to configure the Express.


    "Create a wireless network" configures the device to provide a new wireless network. In this case, the Express connects directly, and permanently, to your modem with an Ethernet cable in order to obtain an Internet connection.


    "Join a wireless network" configures the Express to connect to an existing wireless network using wireless only. This would mean that you have another wireless modem/router providing a wireless signal. In this case, the Express connects just like a computer does....you identify the network that you want to join and enter the wireless password to connect.


    If your existing wireless network does not use security, then you would not need to enter a password to connect. If your network is using security, then you have to "tell" the Express what type of security the wireless router is using and provide the correct password to the Express as well. Otherwise, it will never join the network and you will receive an error message each time you attempt to configure the device.


    Which way are you trying to configure the Express?

  • 2020pdx Level 1 (0 points)

    I am attempting to "Create a wireless network" with the Airport Express wired to my modem through ethernet cable.  There is no existing wireless network and no network security.

  • Bob Timmons Level 10 (95,560 points)

    Thanks for the clarification. Now, we need to know more about your "modem" in order to provide the correct settings for the AirPort Express.


    Can your provide the make and model number of your "modem"?

  • 2020pdx Level 1 (0 points)

    Motorola SURFboard, Model: SB5120

  • 2020pdx Level 1 (0 points)

    I was mistaken when I said the make was Linksys, earlier.

  • 2020pdx Level 1 (0 points)

    I went to Apple Store again today and setup the Airport Exp at the Genius Bar.  The Airport Exp successfully connected over their network, the security settings are now WPA2 Personal and device is set to scan automatically for different available frequencies.  Upon returning home plugged in Airport Exp and my computer is able to discover the device, however, after inputting the WPA2 personal password the device is unable to connect with my laptop.  I recieve a "connection timeout" error message.


    I have run the Airport Utitlity to attempt to change Airport Exp device settings, but the Utility is unable to discover the Airport Exp.


    Can anyone suggest help?

  • Bob Timmons Level 10 (95,560 points)
    Motorola SURFboard, Model: SB5120

    I am sure that you are aware that you need to perform a complete modem reset whenever you change the device that the modem is connected to, correct?


    In other words, if you have connected your computer directly to the modem to get online....you will have to reset the modem first before you attempt to connect the AirPort Express device to the modem.


    Although the folks at the cable company will likely tell you that the modem will reset in a few minutes, what they may not tell you is that it often takes 15-20 minutes for the equipment at the cable company to fully reset and issue a fresh connection. So, keep the modem powered down at least 30 minutes after you push the reset button.


    Then, you will need to perform a Factory Default Reset again on the Express when you are ready to connect it to the modem.

  • 2020pdx Level 1 (0 points)

    I tried this approach and come up with the same problem.

  • Bob Timmons Level 10 (95,560 points)

    My neighbor has the same exact modem as you and an AirPort Express. I configured things for him several months ago and just checked with him again. No issues after several months.


    I cannot explain why what works for him does not work for you, but suspect that there is a firewall setting on the modem that needs some tweaking. Perhaps your service provider could help with this.

  • 2020pdx Level 1 (0 points)

    As stated before, the connection works just fine when connected directly to modem through ethernet cable and there is no security or firewall protection on the modem side.  I'll keep trying, but thanks for your attempt to help me resolve this, Bob.

  • andrgant Level 1 (0 points)

    I've been having a similar problem, and my thinking right now is it's tied to OS 10.6.8. I've seen reference to similar issues with 10.6.8 elsewhere. We have 4 devices in my house (Macbook Pro w/ Lion, iPhone 4s w/ iOS 5.0, Macbook w/ 10.6.8, 2006 iMac Core 2 Duo w/ 10.6.8).


    • With AX set to join my existing wireless network (from a Belkin router), then only the two most modern devices (Macbook Pro & iPhone) are able to connect to my Airport Express for Airplay to my stereo. They can also connect to internet at the same time. The older two computers running 10.6.8 can see AX but don't connect when we try Airplay.
    • If I Create a new network for the AX, then all devices can see it, but the portables (i.e. all but the iMac)  cannot do both Airplay and connect to internet at the same time. The iMac can connect to internet and stream to Airplay because it is connected to router via ethernet.


    I have tried repeatedly with different security settings (e.g. see entries by SPSherm and Mike the Banker at this similiar thread), i.e. either no security on either Belkin or AX, or WPA2 personal on both Belkin and AX, and the issue remains the same.


    Also, the AX is old. Firmware is 6.3 and apparently I can't update. But I know from the local Mac store that the latest firmware is 7.6. I don't know if that's the reason the older machines can't see the AX if it's part of my existing network.