7 Replies Latest reply: Aug 2, 2013 10:20 PM by iBlink
kalmicka Level 1 Level 1 (0 points)

Hey everyone,


I managed to get afp,smb and webdav to work. However, webdav only works for me if I setup the user with a home directory, otherwise it won't connect at all and give me this error in /var/log/apache2/error_log: "[error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:59780 (*) failed" Now I did setup everyone with a home directory and still one user is now experiencing the same problem again. Smb and afp work fine, just webdav is giving me a headache. Does anyone know what the problem is or what I can try?


Thanks for the help

MacBook Pro, Mac OS X (10.7)
  • ousbigkpls Level 1 Level 1 (15 points)

    I was able to resolve this by looking at the /var/logs/system.log and finding that the file that was autogenerated by the webdav process had a syntax error in it.


    In my case, the rewrite string was missing the quotes and as a result, webdav failed to start because it didn't load the file. In my experience, the WebDAV sharing file only gets rewritten when File Sharing is stopped and started.


    Do the following:

    1. Check /var/logs/system.log for any errors being thrown by org.apache.webdavsharing.<a username on your system>
    2. Backup the file /etc/apache2/httpd_webdavsharing_sharepoints.conf
    3. Open the file in emacs or some text editor that can verify that quotes, XML delimiters and the like have been successfully closed
    4. Save the file - if you made changes
    5. Try logging back into the server using webdav (it shouldn't make any difference if this is performed from an iOS device or from a computer.)


    If that fails - bounce the File Sharing service to make it regenerate the /etc/apache2/httpd_webdavsharing_sharepoints.conf file again and go back to step 1.

  • iBlink Level 2 Level 2 (180 points)

    Fixed my issue, but what if the web service keeps changing the file back (without quotes) when file sharing is turned off and then on?

  • kalmicka Level 1 Level 1 (0 points)



    pushed the wrong button. Sorry about that. Can't seem to uncheck the answer as the correct one. I don't seem to have this error anymore on the new version of mac os x server, but maybe it was because of a new installation. This error kept making me crazy...

  • ffg80 Level 1 Level 1 (0 points)

    Hi Kalmicka:


    When you say that you don't get this error anymore with the new version of OSX, you mean fresh install or the latest version of the server. I just got into the situation of dealing with this problem. Same issue with my WebDAV file (""). Also changes back to how it was in the beginning (missing ""), although in my case it seems to change back after a while, even without restarting the file sharing service.


    Appreciate the help

  • iBlink Level 2 Level 2 (180 points)

    For me, a clean install of the same version made things right.

  • ffg80 Level 1 Level 1 (0 points)

    Thanks iBlink


    So you are saying that your experience is that the webdav config file doesn't change back to having syntax errors (missing "") after doing a fresh install of the server; even when you restart the file sharing service?

  • iBlink Level 2 Level 2 (180 points)

    That is correct.  I am assuming something was corrupt and not working as it should.  Ever since the clean install, we have not had any issues using webdav.