Previous 1 2 3 4 Next 58 Replies Latest reply: Jan 17, 2016 8:07 PM by TigerKR
Saint Mac Level 1 Level 1

How to fix VNC, Apple Remote Desktop (ARD), and screen sharing in OS X 10.7 Lion.

You can skip all the other threads and just read this.


First let's fix the Lion computer.

  1. Open System Preferences > Sharing
  2. Turn OFF Screen Sharing, Remote Login, Remote Management, and Remote Apple Events (just turn everything off)
  3. Now turn ON Screen Sharing, Remote Login, Remote Management, and Remote Apple Events
  4. Now turn everything OFF again. We have just "kickstarted" those services.
  5. Now enable the services you want. If you just want to access your computer through VNC or screen sharing, just turn on Screen Sharing.
  6. If you want Windows computers to access it, go to Screen Sharing > Computer Settings, click the VNC checkbox, and enter a VNC password.


If you administer a bunch of computers with ARD, then turn Remote Managment on. If you don't know what that last sentence means, leave Remote Management and remote Apple Events off.


The computer should now work. If not, reboot it.


If it still doesn't work, then you should try downgrading to ARD 3.4, but I don't think this is necessary.



Let's access the Lion computer from another Mac:

  1. From the other Mac, open /System/Library/Core Services/
  2. There is an application called Screen Sharing. Make an alias of it (click and drag while holding Apple and Option) in the Applications folder. Or drag it to the Dock.
  3. Now open the alias (or click the Dock icon).
  4. Type in the Bonjour name or IP address of your computer.
  5. Enter your OS X username and password.
  6. Tell it to save your password.


Viola, now you can use this to connect to your Lion computer, without having to login twice. You can also connect to Windows computers running VNC with it.


You can also connect by going to the Finder and hitting Apple-K or going to the Finder menubar Go > Connect to Server and finding the correct server. That will then launch Screen Sharing.



Let's access the Lion computer from a Windows PC:

  1. Open your VNC client
  2. Enter the Lion computer IP address
  3. Enter your VNC password
  4. You will now have to re-login with your OS X user password (unless you get a Windows client that supports direct login, but I don't know of one at the moment)


Let's access the Lion computer from an iPhone or iPad:

You could download Screens from the Apple store or...

  1. Download Mocha VNC Lite from the Apple store for free
  2. Configure Mocha but enter not just the VNC password, but also the Mac OS X user and password
  3. Viola, you can now VNC without logging in twice.




What did we actually do?

The key is called kickstarting ARD. You can find info here:, We did this manually by turning them on and then off.

This is like rebooting those systems. Once rebooted, they should work correctly. I don't believe that downgrading to ARD 3.4 is necessary, but instructions are here from Reubania (towards the bottom).


The second issue is around double-login. If you run a multiuser machine, this is a great feature. For most people, it's annoying to login twice. By configuring the Screen Sharing and Mocha apps to use OS X authentication, we bypass this annoyance. If you want to have double login for multi-user reasons, simply don't setup/save your password, or save the password for the account you do want to login with.

iMac, Mac OS X (10.7.1), Apple Remote Desktop
  • Saint Mac Level 1 Level 1

    It appears that Windows VNC sharing is still flakey after doing this. It will often freeze the login screen after a few seconds. Here are some options:


    Type your password fast. If you can type before it freezes, you can login. This may take several tries. Once you login, it should work fine.


    Kickstart the server again. This seems to alleviate the problem, but it appears to come back over a short period of time. You can try to SSH into the server and issue kickstart commands through the command line and then try to VNC.


    Get a Windows VNC client that supports OS X authentication. RealVNC Enterprise appears to support this, but is not free. The free versions of most Windows VNC clients do not appear to support this at this time.


    Downgrade to ARD 3.4.

  • bobapplesup Level 1 Level 1

    You gotta be kidding me. I have spent the last 2 days fiddling with everything about ARD to get it to work again on my two Lionized systems. Numerous reboots, adding users, removing users, firewall on/off, log reading torture, etc.


    I did what you suggested and turned everything off, then on, now it all works again! Thank you.


    But why didn't going through reboots do the same thing the kickstart does? The services are shut down and restarted right?


    I did not have remote apple events on but do now, was this part of the problem?


    Again, thanks very much.

  • Saint Mac Level 1 Level 1

    I'm not sure why rebooting doesn't work. The kickstart might have something to do with Remote Apple Events (I found I had to turn it on and off as well), or it might be that stopping the service through Settings does something different from just stopping it during a shutdown.


    Either way, glad to hear it's working.


    I know some users are still having issues with VNC from Windows clients, but for everyone else, I think this will solve their issues.

  • Debbie Fligor Level 1 Level 1

    There's also clearly some VNC application issues feeding into this problem.  Remote Desktop (the application) is working fine for me, but iSSH on the iPad and Chicken of the VNC on my Mac do not.  I followed your instructions as closely as I could.  on a headless system  you can't turn all three things off at once, but I used kickstart to shutdown and restart ARD while only having SSH on. I can still only get to they grey login screen and type partial text with iSSH.  I grabbed the Mocha VNC free version and it works fine, probably because it's logging straight in before the timeout. I really don't want to buy yet another app for this (and Mocah free wont mouse).  I hope things come together for the app vendors quickly.



  • Felis Level 1 Level 1

    So this mean I'm NOT able to use OSX Lion Screen Share to acces my on my old Quad Core XP box using RealVNC Free edition, unless I spend money on either a. A Windows VNC server which support latest ARD, or b. A Lion app that support good plain old no-auth-needed VNC connection?!

  • Saint Mac Level 1 Level 1

    VNCing into an XP box from a Lion box is fine. No problems there. I use the built in Screen Sharing to do this (or previously Chicken of the VNC).


    It's if you want to VNC from a Lion box from an XP box that is a problem and you need to kickstart, get a new Windows VNC client, downgrade ARD, or install a different VNC server on Lion.

  • wjones3 Level 1 Level 1

    Good day everyone,


    I too was having problems with the Screen Sharing feature after upgrading to Lion. Even after upgrading to the latest version of 10.7.1, nothing. All suggestions proved unsuccessful for me, however, I was able to do the following:


    One of my MacPro's has Lion 10.7.1

    The second has Snow Leopard running 10.6.8


    Both machines has multiple drives installed in the drive bays for backup purposes - the secondary drive.


    From an Ubuntu 10.10 machine I test the ssh feature and was able to successfully access the machines. However, that was not the case when I used my Mac's. So, I started the Snow Leopard machine booting with the secondary drive which has Snow Leopard 10.6.7.


    Guess what?! I am able to use screen sharing, file sharing, and remote management without an issue from Lion --> Snow Leopard and vice-versa.


    So in my case, it appears there may be something buggy with Snow Leopard 10.6.8 not allowing the feature. For now I shall keep it at 10.6.7 until there is a fix. Another option is to upgrade the machine to Lion and see what sort of results I get. For now I cannot because the user isn't interested in Lion.


    Just my 2 cents.

  • ryanfrommadison Level 1 Level 1

    Thanks for this support, but I'm still having the problem of doing Screen Share manually.


    Basically the only issue I had when switching to Lion was to have to approve the share each time on the sharing machine. This seemed ridiculous to me-- or that there should at least be a workaround. When I try to do it manually, by accessing the app in CoreServices, I get an error whether I try using my IP or server name [error is "Connection Failed to.. Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer.."


    Any suggestions?


    Many thanks.

  • Scott Hagberg Level 1 Level 1

    Thank you for taking the time to post your solution, Saint Mac!  It worked perfectly for me, and saved a ton of frustration.



  • Cybermancln Level 1 Level 1

    Unfortunately this doesn't seem to solve the VNC related issues in a mixed environment (i.e. windows, Linux). Still having intermittant issues despite this and other similar solutions.


    Hopefully Apple brings out a fix, as this is a painful showstopper for those running headless servers.



  • kevin283 Level 1 Level 1

    All praise Saint Mac, your step-by-step worked perfectly.  Now I can demo Back To My Mac for my customers!

  • darthcain Level 1 Level 1

    Turning stuff off and on is not a fix. It is a workaround. Sorry to be negative. My similar issue is that the screen sharing checkbox will not check. Even though remote management is turned off.

  • massivesquat Level 1 Level 1

    My problem is with realvnc when my macbook pro's display is off.  Everything works great when the mac's display is on, however once it goes off, realvnc wont work at all...any ideas what I'm doing wrong?  I'm freaking going nuts here ever since the day lion was released!!!!!  Thanks!

  • Phlasher Level 1 Level 1

    Using Lion, Screen Sharing not remote Managment - stopped and kickstarted them a few times for good measure.


    I finally got the thing to work on a second signon from my iphone using Mocha VNC.  I was able to finally connect on (User 2) when I used VNC on user 1 (Easy, UID, Password), switched to user 2.


    Got logged out of VNC - lost connection (as expected as User 1).


    Connected again from Mocha as user 2 (using "general password" not UID/pw as per Lion although the target IS Lion). 


    No error, but screen grey, but no failure as before (wrong UID/PW combo). 


    Eventually walked back to Mac (Lion 10.7.2) see user 2 session on display, switched back to User 1 (on Mac) and noticed that suddenly the iPhone/Mocha/User 2 screen is no longer grey but has (whatsit) galaxy background.   Only it's User 3 a very limited (child) user (no pw on Mac - maybe I ... ???) 


    Switched to user 2 using the iPhone.  Galaxy disappears into black hole only to emerge as the User 2 galaxy background on iPhone VNC.


    On the Mac I remain User 1, slowed (8GB, core 2 due 2.4Mhz with 1 GB on User 2, .5 Gb on user 3)


    Works. somehow.


    Go figure.

Previous 1 2 3 4 Next