Previous 1 2 3 4 Next 57 Replies Latest reply: Sep 21, 2012 5:28 AM by Mike Cianci Go to original post
  • UpgradeManiac Level 1 Level 1 (60 points)

    Screen Sharing also broke for me after updating to ARD Client 3.5.1. I've been trying a lot of stuff over the past few months without success (including repairing permissions, kickstarting ARD using the checkboxes, and kickstarting ARD with terminal commands).


    I'm currently running OS 10.6.8 on a Mac Mini and a MacBook Air. When trying to initiate Screen Sharing through the Finder window, I've been getting the "Authentication Failed" message. However today I discovered a workaround: If I initiate Screen Sharing using the local IP address ("vnc://") it works!


    It still bugs me that I haven't been able to get it to work normally, but at least I have the functionality back.


  • fwmaietta Level 1 Level 1 (10 points)

    After reading and trying these different methods, I am still having trouble connecting to my Macbook from my iPhone. I am using the built in ScreenSharing in Lion, and Mocha on the iPhone. I've noticed that when I turn my firewall off, that I am able to connect from my iPhone to my macbook using Mocha. However, when I turn it back on, I am unable to connect. I opened up and was looking at the logs as I was trying to log into into my Macbook, and saw this:

    10/9/11 8:38:49.472 PM Firewall: Deny screensharingd connecting from to port 5900 proto=6


    So I went into my firewall settings, and sure enough, it's listing the "screensharingd" there in the list, but it says that it is set to allow incoming connections. I'm at a loss here as to what to do. The firewall says that it's ok with screensharingd receiving the connections, however the logs in are saying that it's being denied.


    Anybody have any information that may help me out?

  • fwmaietta Level 1 Level 1 (10 points)

    Well I feel pretty stupid having just fixed my problem about 10 minutes after I posted the above request for help. I'll explain how incase anybody else had this problem.


    I went into my firewall settings that shows the list of all approved/unapproved applications, right clicked on remotesharingd, and hit show in finder. Move finder to the background and go back to the firewall settings. Right Click/Two finger tap on remotesharingd, and hit the delete button. Bring Finder forward again, and drag remotesharingd from the finder window to the list of approved/unapproved apps in the firewall settings. Viola, I was then able to connect once again using Mocha VNC. now shows that my connection from my iPhone are be accepted/permitted.


    Just a theory, but it seems like the firewall just needed to be updated with the remotesharingd file. Maybe the file had possibly changed or been corrupted in some way and this was throwing off the firewall causing it to think that it was an intrusion attempt. Anyways,

  • DrGamma Level 1 Level 1 (0 points)

    Have problems with mini Lion server. Did the kickstart as suggested and got in once, then problem returns on logout unless go through the whole kickstart process again. Makes my server useless for a lot of things I have been doing for years with the system I replaced. Hope Apple fixes this bug in Lion.

  • Gregory Rivers Level 2 Level 2 (450 points)



    accessing my Mac Pro running 10.7.2 from an iPad with Remoter works fine until I use a Hot Corner to 'Put Display to Sleep'. if I do this, Remoter is absolutely unable to connect to the Mac.


    if I don't use 'Put Display to Sleep' and allow the display to sleep according to Energy Saver settings, Remoter can connect to the Mac.


    BUT... if I turn on 'Security/Require password', then Remoter is able to wake the screen and begin to connect. however, the connection will always time out. just before the connection times out, an image of the screen with the login window is returned to Remoter.


    fun fun fun...

  • Boxcar Level 1 Level 1 (0 points)

    What if you aren't using Lion? What if you are still using Snow Leopard?

  • edyleemd Level 1 Level 1 (0 points)

    I tried kickstarting my iMac and MacBook (both on Lion) and it didn't seem to change anything. I could screen share from work with Back to My Mac, but when I was at home on my own wireless network, I couldn't screen share at all. So irritating. I found this fix, which does seem to work. It involves replacing ARDAgent with an older version, 3.4. This does seem to work, so far.




    Instructions by tchaga:


    1. Download ARD 3.4 (RemoteDesktopClient.dmg), mount it, look inside the package/Contents, copy the Archive.pax.gz to the desktop.


    2. Expand the Archive.pax.gz and navigate inside the resulting folder Archive to /System/Library/CoreServices/RemoteManagement


    3. Navigate to the same folder at the root of your HD (i.e. HD/System/Library/CoreServices/RemoteManagement)


    4. Copy ARDAgent from your HD/System/Library/CoreServices/RemoteManagement to the Desktop and then delete it from the HD/System/Library/CoreServices/RemoteManagement folder (you need admin password).


    5. Copy ARDAgent from Archive/System/Library/CoreServices/RemoteManagement to HD/System/Library/CoreServices/RemoteManagement (you need admin password again).


    6. Restart

  • fpalattao Level 1 Level 1 (0 points)

    i tried the steps you described but for some reason when I use a pc laptop with windows xp to connect using real vnc or ultra vnc.  I get a grey screen connecting with my macbook having lion 10.7.2.


    Any other ideas?  If I use another mac to connect it works but it wont work from a pc to my mac.

  • tee.vee Level 1 Level 1 (0 points)

    If I try to VNC to my mac os x Lion server, usually the logonscreen blocks.

    I read all your postings and found out how to kickstart ARD on the server.

    Unfortunately kickstarting does only help in exeptional cases.

    Usually I have to reboot the lion-server.

    After reboot I usually can connect exactly once.

    Any further attempts will fail again until I reboot the server.

    Is there a way to avoid the loginwindow by submitting the logon info directly via VNC?

  • robert233 Level 1 Level 1 (0 points)

    Thank God for Saint Mac!! I found that the steps from Saint Mac definitely work...the only thing is it didn't work at first for me.  I noticed it was asking to save in my keychain so I decided to poke around a little and found that there was duplicate items for my various systems on the network in keychain access.  I sorted by kind and all of my computers were listed as network passwords.  Removed all the items on every computer for all the different computers.  Once that was done, used the steps from Saint Mac and it worked like a charm.  Thank again!!

  • tee.vee Level 1 Level 1 (0 points)

    I could not find any false items in my keychain.

    I kickstarted ARD and then killed all loginwindow processes (including the loginwindow console).

    This had the same effect als all users would have logged off.

    This helps and is a lot better than rebooting the server.

    But there is still the disadvantage, that the users running processes are lost.

    Any ideas for workarounds which less impact would be appreciated very much.

    Thank you again.

  • PeteHrad Level 1 Level 1 (0 points)

    For those of you who are getting the 'gray screen' when connecting via a VNC client, I have found if I use Mocha VNC from my iPad and configure the settings with my Mac ID and password, it works.  Apparently the gray screen we are seeing is the login screen minus the objects to login.  I am going to try to connect with Real VNC tomorrow.

  • rawsaxy Level 1 Level 1 (35 points)

    I'm hoping you can tell me if what I've been trying to do is possible. I was under the impression it was, but several Apple technicians from AppleCare told me it is not.


    I have an iMac running Lion at home, and several blocks away at a relatives house, they have a MacBook Pro running Lion, and an iMac running Leopard. I wrote down the IP addresses from all computers by going to, and all computers have a static IP. All I'm trying to do is Screen Sharing, which is enabled in all 3 computers, Allow access for All Users (tried "only these users", but same issue), "Computer Settings" I've tried checking VNC viewers...password, Anyone, none of them, etc.


    Screen Sharing is the only service checked. I tried your suggestion on all 3 computers as well, but can not connect when I go to the GO menu in the finder and select Connect to Server and enter:  vnc:// and the IP address. I keep getting "Connection failed to "the IP address I entered" I did try Screen Sharing using iChat, and that worked perfectly. The AppleCare specialist also told me to open the Finder window and see if "SHARED" appears in the is not there in any of the computers. These computers are not in the same household, as I stated. I was told that the computers are too far away for this to be done, but I said I am not trying to connect remotely via Wi-FI, but rather, remotely via the internet using the IP Address.


    Is what I'm trying to do even possible? I'm not interested in 3rd party apps, nor are any of the computers a dedicated server. My reading on this topic gave me the impression that as long as you left your computer turned on and had Screen Sharing enabled, you enter the IP address, and you should be able to connect to it.


    Any help, guiding, and comments on this issue will be appreciated.



    In God's Harmony

  • rawsaxy Level 1 Level 1 (35 points)

    Well, spoke to another Specialist, and seems I can't do this as I thought. If anyone differs, let me know.

  • TheCraw Level 1 Level 1 (5 points)

    From what you describe I can see a couple of issues. One is that the machines you have on the far network are behind a router. This means there are 2 IP's that you have to sort out first the IP on the machine is just the IP ot it on the local network and not the IP of it on the internet. The way you can check if this is the issue is you can set up one of the machines in a DMZ zone and then hit it from your house to the IP of the router. (this is not a great long term solution as the DMZ puts that machine directly on the internet. If you can connect then you know it can be done when needed but it is a limited solution because you have two machines there it sounds like you want to be able to get to. But if it works you can hit which ever computer you need to as they can put whichever machine you need to talk to in the dmz zones via the router as needed.


    Not sure what you are exactly trying to do. Don't know if you are trying to control them or just see the screen. If you are just trying to view a screen you could do it easily via something like skype which can share the screen. Also if you are up to version the latest lion that has caused the problem in this list then good luck as I have similar problems as the other people and since the upgrade can't get either the remote desktop or the share screen to work.