Previous 1 2 3 4 Next 58 Replies Latest reply: Jan 17, 2016 8:07 PM by TigerKR Go to original post
  • guillame Level 1 (10 points)

    Adding the rule for port 5900 TCP worked well after 4 days and several boots. It may be that Apple just forgot to add it to the firewall when "enable screen sharing..." is selected. I guess this is after the upgrade to 10.7.3.

  • Go-Figure Level 1 (0 points)



    For once I looked before I leaped!  I can now use the screen from my MBA/Lion from my MBP8.3/SL.


    Lion continues to disapoint.  Is there hope for Mtn. Lion....

  • Eddie in Canada Level 1 (0 points)

    Thank you people.

  • Rob Snow Level 3 (560 points)

    I can't find "screensharingd" on the list.

    Where do I find this?

  • jason@eit Level 1 (0 points)

    I have studied this issue rather deeply, but nowhere have I seen a description of my problem. I run Lion on a Mac Mini and try to access the shared screen using VNC viewer free edition on a PC running Windows 7. I pass the initial connection, my VNC password is accepted, but the shared screen only just flashes open and immediately closes, sometimes giving an error message saying that the connection is closed. I have tried several of the work arounds and fixes suggested but to no avail.


    All comments are valuable.



  • Rob Snow Level 3 (560 points)

    Hi all


    This issue seems to have resolved itself.

    I switched on this morning and everything could connect to each other.


    Didn't do a thing!!


  • nachotech Level 1 (0 points)

    Saint Mac -- thanks very much for documenting this.  I had this problem on two Lion iMacs that I couldn't access from a Lion Macbook Air.  Your trick of turning everything off, on, off, then back on again really works!!!


    I hope Apple can fix this soon.

  • jason@eit Level 1 (0 points)

    The solution is found here:


    In plain English: You have to configure VNC viewer for Windows for Full colour resolution _and_ force the old protocol v3.3. Then you can access the Mac host irrespective of you are logged in or not on the Mac.



  • StS Level 1 (0 points)

    Disconnecting a second screen which is connected to the Mac you want to control solves this too, but there's a much simpler solution.


    Open the Screensharing app on the Mac you want to connect from and go to preferences:

    * The default setting you'll see is to scale to fit your screen

    * Set this to "Show original size" (or whatever this will be called on an english OSX)


    Now you can connect to your other Mac just fine, without needing to disconnect its second screen and you can even set screen sharing to scale via the Menu- or Toobar. The important bit is, that Screen Sharing's prefs remain to be set to "Show original size".


    This is ridiculous and really needs to be fixed by Apple. Pretty please!

  • don montalvo Level 2 (345 points)

    ssh over and kill loginwindow process...then connect fine and does not kill any other process you're running on the target Mac.


    Apple knows all about this bug (many of us have submitted to RADAR and have discussed with Apple engineers), hoping it's resovled with 10.7.5 when it's released (hopefully soon).



  • john lewis Level 3 (700 points)

    Lol. That didn't happen then! Looks like theyre essentially ignoring the problem, hoping it will go away.


    But every time they ignore the problem, provide no documentation to prove it works (and just let people flounder along unable to connect remotely), about 1000 IT techs buy an MS terminal server instead or their boss will fire them. All that profit going to the darkside. Genius.

  • Omniasoft Level 1 (0 points)

    Dude, you rock.  I have been fumbling with the iOS VNC Viewer on my iPad for 1+ hours trying to get my dual monitor Mac to work with screen sharing.  Your suggestion of turning off the password requirement did the trick.  Turning off this requirement forces VNC Viewer to ask me for both my Mac username and password, and the remembered credentials get me in every time.  Kudos to you!



  • Mike Cianci Level 1 (0 points)

    Awesome! Thank you Saint Mac. Worked like a charm!

  • TigerKR Level 1 (30 points)

    You're a genius Saint Mac, thanks!

Previous 1 2 3 4 Next