Skip navigation

iTunes won't let me restore

2087 Views 13 Replies Latest reply: Aug 30, 2011 2:13 PM by lllaass RSS
MChill623 Calculating status...
Currently Being Moderated
Aug 28, 2011 6:28 PM

I tried to sync and it says it can't read the contents of my iPod. It says I should restore it but when I try to do that it will download but right after that it says connecting error when my connection is perfect. Any help?

iPod touch, Windows 7
  • Caltain Calculating status...
    Currently Being Moderated
    Aug 28, 2011 6:33 PM (in response to MChill623)

    The first thing to check is the physical connection to the iPod.  Start by making sure that the iPod is attached directly to the cpu or laptop and not through a USB hub.  Most of the time, connection errors with a device are caused by the lag time when other programs are accessing other USB devices on the hub.  The two datastreams sometimes hit at the same time and one or the other will time out while waiting for the packets that just got in a wreck somewhere out in USB land.

  • Carolyn Samit Level 10 Level 10 (84,490 points)
  • Caltain Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 28, 2011 6:54 PM (in response to MChill623)

    Can you post the exact text of the error messages you get?  I know it's time consuming and a pain to go through it again, but it's important to know what itunes thinks is wrong.

  • Caltain Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 28, 2011 7:49 PM (in response to MChill623)

    Excellent!  Now we're making some progress.  What version of iOS is your touch running?  (Settings -> General -> About)

  • Caltain Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 28, 2011 8:40 PM (in response to MChill623)

    Okay, great!  Since you were willing to do the restore, I'm assuming that there isn't anything on your touch that you haven't already decided to say goodbye to.  If that's not the case, then we can go a different route to try to get at the things that are irreplacable. 

     

    So, what we are going to do is to go a step beyond restore to something called DFU mode.  DFU mode stands for Device Firmware Update.  The short scoop on the story so far is that in a normal sync situation, iTunes and some background processes on your PC connects with the running iOS on your touch and does it's thing.  For some reason, that wasn't working, so iTunes announced that you need to reset the device.  As you have discovered, resetting the device is also not working in this case.  Enter DFU mode.

     

    DFU mode moves things to a more basic level.  In DFU mode, iTunes will connect directly to your touch without actually booting the iOS operating system.  That removes the iOS from the process.  We are going to use DFU mode to re-flash the latest version of iOS to your touch so that we can restore your apps, mail, data, etc., and get you on your way.

     

    None of this, by the way, is anything you caused or did wrong.  Sometimes things just don't mesh perfectly. 

     

    To enter DFU mode:

    1. Start iTunes and connect your touch to the PC as normal.
    2. Press and hold the Sleep/Wake button on the top and the Home button on the face for 10 seconds.  It needs to be pretty close to a real 10 second span.
    3. After the 10 seconds, release the Sleep/Wake button, but continue to hold the Home button.
    4. After some time, you should see a message pop up on the PC screen.  The message should say that iTunes has detected a device in recovery mode.
    5. Now you can let go of the home button and let iTunes restore the firmware on your touch. 

     

    After you have successfully gotten iTunes to restore your touch's firmware and all is well with your touch, you can then use the normal iTunes restore process to get all your stuff back on your touch. 

     

    Sorry the reply took so long...had to eat some dinner...

     

    Let me know how it comes out.  I'm not sure if I'll still be online by the time you get back to me, but I'll respond to any issues as soon as I get back online. 

  • lllaass Level 10 Level 10 (135,820 points)
    Currently Being Moderated
    Aug 29, 2011 2:57 PM (in response to MChill623)

    Try a direct download and then install the iOS update.  The beginning of the following also says how to install the download .

    iPod, iPhone and iPad Firmware Download

  • rickfromsurrey Calculating status...
    Currently Being Moderated
    Aug 30, 2011 1:03 PM (in response to MChill623)

    okay so there was another usb beside it so I took that out, now the itunes and usb screen came up on my ipod, when i tried restoring it, at the end there was a mssg that says "network connection timed out", make sure your network seetings are correct and your network conection is active or try again later

  • lllaass Level 10 Level 10 (135,820 points)
    Currently Being Moderated
    Aug 30, 2011 2:13 PM (in response to rickfromsurrey)

    Have you disabled your computer's security software?

    The timeout error menst there was a problem with the computer commumicating with the Apple servers.

     

    If you computer is using wifi, try a wired connection to your router.  I had the problem with my Mac using wifi.  It was better when I used an alternate wifi access point I set up.  I have not had that problem since I purchased a new wifi router.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.