8 Replies Latest reply: Dec 9, 2011 9:12 PM by Kurt Tappe
Ian999 Level 1 (0 points)

With Lion and the latest Safai I repeatedly have this problem. The Safari content disappears and is reloaded, and I get the error message 'Safari web content unexpectedly quit'. It now happens more than a few times a day, and is rapidly becoming annoying. Any suggestions as to how to fix?

  • Mr Pi Level 2 (275 points)

    Bump.

    Everyday with more than a few well trusted sites. My latest have been Twitter and just now Unity3d.com

    Very annoying.

    Pi

  • sridvijay Level 1 (15 points)

    I have been getting this problem too. I fixed it by reseting Safari. When Safari is opened click Safari on the Menu Bar and then click reset Safari. This WILL REMOVE YOUR SAVED PASSWORDS HISTORY AND ANYTHING THAT YOU HAVE STORED!! But it fixed the problem!

  • Matt W (TechnicalMac) Level 1 (25 points)

    Think this happens more with Safari 5.1 and certain sites.

     

    You can choose NOT to reset saved passwords and autofill in Safari if you wish, assuming that this problem isn't linked to saved passwords and autofill, of course. I'm having this problem, too, and I've reset within the last week. Looks like I'll need to do some more testing.

  • Malcolm Rayfield Level 7 (28,075 points)

    Since Lion, I have had the same problem on many websites, including Apple's <http://www.me.com>.

    Resting Safari does not fix it.  A fresh install of Lion onto an empty drive, with no other software or plugins installed, still has the problem.  It does work with OSX with a Safe Boot.

    <Mac OS X: Starting up in Safe Mode>

    but you probably don't always want to run in Safe Mode

    <Mac OS X: What is Safe Boot, Safe Mode?>

  • Malcolm Rayfield Level 7 (28,075 points)

    I have found a workaround that is less drastic than Safe Mode.  Enable Safari's Debug menu with the Terminal command:

    defaults write com.apple.Safari IncludeInternalDebugMenu 1

     

    The Debug menu should appear to the right of Safari's Help menu.  In the Debug menu, uncheck:

    Enable Canvas Accelerated Drawing

  • Ian999 Level 1 (0 points)

    I solved the problem by moving to Chrome. It is a lot better than it first was.

  • marcel.b Level 1 (10 points)

    Had excatly the same problem! I hate fussing around with settings and "workarounds." I want simple click and browse - so Chrome it is for now!

  • Kurt Tappe Level 2 (180 points)

    Bump. I'm having the same problem in OS X 10.6.8, fully patched including Safari 5.1.2. Only happens (so far) on MobileMe. Fixing permissions and rebooting have no effect. Chrome accesses the site without issue. I know I used to be able to access MobileMe on this Mac...I'm having to assume some patch issued by Apple in recent months broke this though I use webmail so rarely that I cannot pinpoint which one.