8 Replies Latest reply: Sep 27, 2012 8:14 AM by Dinesh India
mohdyahya Level 1 Level 1 (0 points)

my ipad 2 was working nicely till yesterday when suddenly give me error msg no sim card

what should i do


iPad 2, iOS 4.3.3
  • antoN1961 Level 1 Level 1 (0 points)

    Hi. There seem to be multiple topics on this Forum referring to the same issue: iPad 2 with SIM installes suddenly seems to 'loose' the SIM and reportsmin the top left corner: No SIM. A popup screen appears: No SIM card installed.

     

    I have the same issue, not resolved yet. What I have seen/tried so far:

    - after hard-shutdown the problem is gone. Then after a while it comes back

    - same story when enabling Flight Mode. After a while the issue comes back.

    - i have replace the SIM card. When turned on it all worked fine, after 30 mins I got the same error.

    - it does not aooear to be a hardware problem, because then it would be more consistent

    - it also does not aopear a software problem

    - i have phone AppleCare. They did not know this problem. They suggested me to do a total system reset.

     

    To be continued...

  • antoN1961 Level 1 Level 1 (0 points)

    I have performed a system reset: Settings > General > Reset > Reset All Settings. All data remains on the iPad, but just the settings are reset. It did not resolve the issue; after 10 mins the No Sim error appeared again.

     

    So then I performed a full reset: Settings > General > Reset > Reset all content and Settings. After this I added the SIM card and since then it has worked fine. The data/content was place back after connecting it to iTunes. When asked 'do you want to restor existing iPad' i decided to build a new one.

    Hopefully the problem is now resolved...

  • antoN1961 Level 1 Level 1 (0 points)

    The problem did not go away after a complete wipe & restore.

    I turned it in for repair. I got it back with the note that Apple had upgraded the firmware and after 12 hours I had the problem back again, only not as often as before.

    Perhaos iOS 5 fixes this....?

  • Kinsem Level 1 Level 1 (0 points)

    I've the very same problem as you, this started just after upgrading my iPad 2 to iOS5 and now it's happening more and more often.

    I tried to switch-off, reset, restore, re-insert the SIM multiple times but nothing fixed the issue for more than a couple of hours. That's really annoying and lot of people seem to have this issue :((

     

    I don't know what else to try... I'm afraid than even sending the iPad for repair will only be a waste of time!

  • Kinsem Level 1 Level 1 (0 points)

    Update: I got a replacement SIM from my carrier but the problem persisted, so I took my iPad to Apple service and they replaced it with a new one.

     

    Now I'm happily connecting to my 3G network again

     

    My suggestion for people experiencing the same issue is to try a "minimum troubleshooting" i.e. restore your iPad and the like but do not waste much time before going to Apple service if the problem continues.

  • mrfuj Level 1 Level 1 (0 points)

    Experienced the same problem and after reading all the posts I going straight to the apple store tomorrow and ask for a replacement. I will post an update of there response later.

  • mrfuj Level 1 Level 1 (0 points)

    Just got back from the Apple store, indicated that I followed this thread, reset the iPad, updated the IOS, went to service provider tried different sims. Was in and out of the Apple store in Mississauga, Ontario within 10 minutes with a new replacement iPad2. Thanks to all of you and to Apple.

  • Dinesh India Level 1 Level 1 (0 points)

    After reading all the posts, seems like a Hw problem and solution is replacement. My IPad just missed one year warranty and Indian apple repair Center is asking for huge money to try repairing it almost $ 349...seems like buying a new one instead...