Previous 1 4 5 6 7 8 Next 111 Replies Latest reply: Oct 13, 2012 4:07 AM by tonwurm Go to original post
  • lohogan Level 1 Level 1 (0 points)

    Yes, keep dbs below 0 on all the patches and your CPU usage is much less.

     

    I added a Universal Audio UAD-2 Solo Laptop card and moved almost all of my effects processing on to the Sharc processor on the card. (It plugs into the Express34 slot.)

     

    Now I'm running at about 45% usage when nothing is happening, but the max usage puts me up to about 85%, instead of over 100% so often. Apparently, a lot of my CPU usage was from multiple instances of EQ, compression, and an instance of Space Designer. Some of these weren't even enabled, but they were still using cycles. (Use the Goldverb instead of Space Designer for reduced CPU, btw. Probably up to 10% some of the time.)

     

    I'm using multiple 1176LNs, LA2As, and a reverb, with excellent results. Since this is live, I'm running with no sample buffers, which adds about 10% CPU load, but with the processing being done on the card, the peaks have smoothed out. Plus, it sounds AWESOME. I processed the strings through an LA2A, and they got so creamy I can pour them on my pancakes. This is the one! I'm guessing I have about 50% more processing power.

     

    Check them out at http://www.uaudio.com/

  • Beethree Level 1 Level 1 (0 points)

    I am having CPU spikes as well.

    I am running Mainstage 2.2.1 on Lion, on a new Mac Mini Server, i7 with 2 SSD and 16 Gigs of RAM. The spikes, as far as I can tell,  are specific to Kontakt 4, and more specifically related to use of the sustain pedal. Even in an otherwise empty concert, running Galaxy Vintage D piano in Kontakt, where the CPU usage is around 20%, occasionally when lifting the sustain pedal, or less frequently while depressing it while playing, the CPU will peg, and I will get pops.

    This does NOT happen if I run Kontakt as a standalone app. It is absolutely specific to Mainstage. Even running Galaxy with all its functions (harmonics, pedal noise, etc) turned off, the problem still occurs.

    I do not get this using the same controller (VAX77) with Ivory, or with any software pianos (I own a few from Sampletekk) loaded into EXS24. Those same pianos loaded into Kontakt will glitch on me.

     

    So Native Instruments might claim that it is not on their end, since standalone Kontakt works fine. And Apple may claim that it is not on their end, since other instruments work fine. All I know is that Kontakt does not work glitch free at all for me when playing piano and using the sustain pedal within Mainstage. I am going to try to figure out how to run standalone Kontakt as an external instrument and see if that kludges a fix for me, as this functionality is quite important to what I do.

  • calogerofrommenfi Level 1 Level 1 (0 points)

    I had the same problems.. i had macbookpro core 2  2.4 GHz, i replaced it with an new Macbook pro Core I7,  2,9GHz 8GByte Ram,  and now it works fine.

  • mpweaver Level 1 Level 1 (0 points)

    Beethree - Did you ever come up with an acceptable  workaround for the Mainstage spikes?

  • lrizzo2001 Level 1 Level 1 (25 points)

    Yep, that's exactly what I had to do.    Nice huh?   had to spend another 2500 to fix the problem.

     

    Your Welcome Apple.

  • Synthonia Level 1 Level 1 (35 points)

    I had the same issue,

    I solved coming back to Snow Leopard and mainstage 2.1.3

     

    just from time machine

     

    cheaper solution

     

    no spike anymore

  • tonwurm Level 1 Level 1 (5 points)

    disabling multi-processor support and memory-server in kontakt helps avoiding cpu-spikes, at least with my system (macmini with rme-babyface, sample-buffer at 128)

Previous 1 4 5 6 7 8 Next