Previous 1 2 Next 28 Replies Latest reply: Jul 21, 2012 9:48 AM by MindlessPotato Go to original post
  • AppleGenius14 Level 1 (0 points)

    Thank you so much!! This was very helpful and saved me from a potential computer catastrophe! Wonderful explination!

  • vietnt Level 1 (0 points)

    Thank you!

    It's great

  • Ahmad Aliff Level 1 (0 points)

    Hi. I have this problem of tryiing to re-create back the root account. It says that attribute status: eDSPermission Error. Can you help me with this?

  • JMaine Level 1 (5 points)

    Dude if you're ever in Dallas, TX look me up!! I OWE YOU A BEER! Thats some GREAT knowledge right there. JMaine

  • Luiginsky Level 1 (0 points)

    Please, tell me if someone solved the problem to "reinstall" the "System Administrator"! Or should I reinstall Lion?

  • jr smith Level 1 (0 points)

    I read too quick too but was able to reinstall the "System Administrator" record by clicking + button at the lower left and renaming "untitled 1" to "System Administrator". I had to add a few missing records within "System Administrator" but after that, I followed the directions correctly and can now login as root.

  • theories Level 1 (0 points)

    I made the same mistake as many others here and deleted the "System Administrator" record.  I'm trying to add it back with the sign but it still isn't working.  Do you remember which missing fields you had to add to "System Administrator" to get it to work again?

  • jr smith Level 1 (0 points)

    Here are the fields/attributes I added or changed

     

    NFSHomeDirectory - /var/root

    PrimaryGroupID - 0

    RealName - System Administrator

    RecordName - root

    UniqueID - 0

    UserShell - /bin/sh

  • shepar38 Level 1 (0 points)

    Luckily I had backed up my image to an external drive before I clicked the wrong minus, so I just restored from that and verified that the OP's method does work to fix the root account login issue.

     

    But since I am right in front of it here are the values of the original root account if it helps anyone else:

     

    AppleMetaNodeLocation     /Local/Default

    GeneratedUID                    FFFFEEEE-DDDD-CCCC-BBBB-AAAA00000000

    NFSHomeDirectory            /var/root

    PrimaryGroupID                 0

    Real Name                        System Administrator

    RecordName                     root

                                            BUILTIN\Local System

    RecordType                      dsRecTypeStandard:Users

    SMBSID                           S-1-5-18

    UniqueID                          0

    UserShell                          /bin/sh

  • shepar38 Level 1 (0 points)

    Apparently within the last hour 10.7.3 update came out. It has fixes for Directory Services, but doesn't list this particular issue. If I end up testing it out later on I'll report back on whether the root login still breaks or not.

     

    10.7.3 details:

    http://support.apple.com/kb/HT5048

  • theories Level 1 (0 points)

    I finally got it to work!.  This is awesome.

     

    Much thanks to jr smith, shepar38 and of course Crazy Skull Guy.  It took a combination of all three techniques to work my way out of this one.

  • SP Forsythe Level 5 (5,380 points)

    I too would like to thank the OP for this thread.

     

    I was stumped, and I took my MBA into the San Jose (Cupertino's closest) Genius Bar. All the Techs were stumped, and the lead "Genius" said "we've got corruption here", that I needed to erase and reinstall Lion.

     

    I generally take such statements to mean the lead idiot is out of ideas.

     

    The only thing corrupt was the overestimation of his own knowledge.

     

     

     

    The OP's solution worked fine.

  • Joe Pyrdek Level 1 (140 points)

    For some reason, probably because of a posting I put in a similar thread a few weeks ago, I just got this thread in my mailbox.

     

    The thing that worked for me IN 10.7.2 was significantly safer and easier.

     

    Log in with an Admin account

    Open Terminal

    Type in (without quotes) "dsenableroot"

    enter your admin account password

    enter in a password for the Root account.  (it does not have to be the same PW used previously)

    Verify the new Root Password

    exit terminal.

     

    Up to 10.7.2 that enabled Root to be used.  When you are done, go to the Directory Utility / Edit and disable Root.   If you need Root again after it was disabled, you can use the Directory Utility / Edit to re-enable.  The fix survives log off, restart, cold start and even crashes.

     

    I tried the "dsenableroot" in Terminal and it still allowed me to enable root using the process above.  However,

    after 10.7.3 it seems that going the Directory Utility / Edit route requires you to enter a new root password everytime you try to enable root.  If that is the way Apple chose to "fix" the problem, it seems a lot more of a hack than an actual fix.

  • MindlessPotato Level 1 (0 points)

    Thank you so much! I don't know how You've come up with this but that's great! But I guess I'll never disable root again.

Previous 1 2 Next