10 Replies Latest reply: Feb 9, 2014 5:50 PM by TDobbs
CipBal Level 1 Level 1 (0 points)

Does anyone know how to sort out the process "mtmfs" using up 98% of my cpu and heating up the core so much that the fans are running full bore all the time?

 

I have quit the process in Activity Monitor and this stops it temporarily but I am looking for a better solution.

 

Thanks


MacBook Pro, Mac OS X (10.6.7), 2.2 Ghz Intel Core i7 GB 1333 MHz
  • Peggy Lynn Level 4 Level 4 (2,470 points)

    A Google search indicates that mtmfs is Mobile Time Machine file system daemon.

     

    I think that might be for the snapshots Time Machine makes for laptops when they aren't connected to their Time Machine drive. Try turning Time Machine off in System Preferences when you aren't connected to your Time Machine drive.

  • CipBal Level 1 Level 1 (0 points)

    Thanks for this Peggy.

     

    My concern is that if I turn TimeMachine off next time I turn it on it will demand to do a full backup which will take ages, but perhaps this is not the case?

     

    Also this is rather a pain to do as I connect up my TimeMachine Hard drive at the end of each day to make a backup!

     

    Thanks anyway.

    Crispin

  • normnod Level 4 Level 4 (2,870 points)

    Disable TM then use TimeMachineSceduler (http://www.klieme.com/TimeMachineScheduler.html) to set it to do a once a day backup when you are connected. I've been using this for about a year since I installed my second drive in the CD bay without problems. TM will only backup changes btw, full backups are only performed the first time.

  • Peggy Lynn Level 4 Level 4 (2,470 points)

    I would fully agree that is highly inconvenient to not have the option to disable snapshots without turning Time Machine off but Apple did not solicit my opinion on the matter. You might want to give AppleCare a call to express your unhappiness with snapshots being an ill- mannered CPU hog.

    Apple - Mac OS X - Feedback

     

    I've not had any problems with Time Machine wanting to make a full backup because I've turned it off for one reason or another. If you use TimeMachineScheduler you need to disable the scheduling you set through that software should you wish to return to normal Time Machine scheduling for any reason.

  • CipBal Level 1 Level 1 (0 points)

    Thanks normnod. This seems a good solution.

    Crispin

  • CipBal Level 1 Level 1 (0 points)

    Thanks Peggy, I will follow this up with Apple.

    I am going to give TimeMachineScheduler a try.

    Crispin

  • dgerman Level 1 Level 1 (5 points)

    On my MacBook Pro  10.7.1

     

    mtmfs is disabled in    /System/Library/LaunchDaemons/com.apple.mtmfs.plist

     

    <key>Disabled</key>

        <true/>

     

    but:

    /var/log/notice.log    shows

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: com.apple.backupd-auto launchd job disabled

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: com.apple.backupd-wake launchd job disabled

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: com.apple.backupd-attach launchd job disabled

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: com.apple.mtmd launchd job disabled

    Oct  9 14:09:57 smackerPro mtmfs[3465]: filesystem unmount attempted from stopFS

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: com.apple.mtmfs launchd job disabled

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: Cleaning up local snapshots on volume /

    Oct  9 14:09:57 smackerPro UserEventAgent[11]: Cleaning up local snapshots on volume /Volumes/DATA/

    Oct  9 14:09:57 smackerPro mds[76]: (Normal) FMW: DOUBLE SLASH Rename (source) - p:11 ac:4 am:51c1 t:57622115738851

    Oct  9 14:09:57 smackerPro mds[76]: (Error) FMW: DOUBLE SLASH Rename (destination) - p:11 ac:4 am:51c1 t:57622115738851

    Oct  9 14:09:57 smackerPro mds[76]: (Normal) FMW: DOUBLE SLASH Delete - p:11 ac:3 am:5c1 t:57622376115790

    Oct  9 14:09:59 smackerPro UserEventAgent[11]: com.apple.backupd-auto launchd job enabled

    Oct  9 14:09:59 smackerPro UserEventAgent[11]: com.apple.backupd-wake launchd job enabled

    Oct  9 14:09:59 smackerPro UserEventAgent[11]: com.apple.backupd-attach launchd job enabled

    Oct  9 14:09:59 smackerPro UserEventAgent[11]: com.apple.mtmd launchd job enabled

    Oct  9 14:09:59 smackerPro UserEventAgent[11]: com.apple.mtmfs launchd job enabled

    Oct  9 14:09:59 smackerPro mtmd[6206]: Set snapshot time:1318183801 (current time:1318183799)

    Oct  9 14:10:04 smackerPro com.apple.mtmfs[6207]: /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T//mtmfsMap6207

  • softwater Level 5 Level 5 (5,370 points)

    Peggy Lynn wrote:

     

    I would fully agree that is highly inconvenient to not have the option to disable snapshots without turning Time Machine off

     

    You can disable local snapshots and still use TM.

     

    In Terminal, paste this command:

     

    sudo tmutil disablelocal

     

    To reverse the command

     

    sudo tmutil enablelocal


  • John Zwiebel Level 1 Level 1 (40 points)

    FWIW:

     

    Turning off time machine works, but it took at least 5 minutes, maybe as much as 10, before my Mac recognized TM was off and the process stopped using all the CPU.

  • TDobbs Level 1 Level 1 (0 points)

    I understand why a Time Machine snapshot process would hog CPU, but I've also found the process is the third most active process for network activity. In addition to being a frustrating resources hog, this raises some concerns for data privacy as well. Why is a process that inventories my entire hard drive using the internet?

     

    Hopefully I'm being ignorant of some basic functionality that would explain this...