7 Replies Latest reply: Mar 25, 2013 9:45 AM by Matt Crawford2
wwwolf Level 1 Level 1 (0 points)

I'm on Lion on a new machine, having bravely used the Migration Assistant to move apps/user files/settings from the previous one. All pretty seamless I'm delighted to say (apart from obviously losing my Rosetta-dependent apps of course ) However...

 

Weird problem with Stacks - I can't drag & drop from my Downloads or Documents stacks any more - it makes no difference whether I'm using Fan, List, or Grid view, I have to "Open In Finder" and drag from there to move anything. Pain in the **** to have to do this with every download.

 

This is only happening in my main account (with admin rights), but not in another account on the same machine (also with admin rights), where everything seems to be working as normal.

 

  • I tried removing Downloads from the Dock and dragging it back on. No joy.
  • I compared ownership & permissions (in Terminal) on the directories in both accounts - they're exactly the same.
  • What should I check/recreate next...?

 

Thanks, Jon

  • 1. Re: Stacks won't let me drag and drop
    Barney-15E Level 8 Level 8 (35,295 points)

    Sorry I don't know why its doing that, and I'm just guessing at this.

    Try deleting your com.apple.dock.plist and com.apple.dock.db files from your user/Library/Preferences folder. You'll have to rebuild your Dock as that will wipe out any customizations you made. It should reset to the default setup.

     

    Also, I didn't know you could do that. I always have mine in List view, so its not available. Makes me think I might want to reconsider using Grid. Sorry you have a problem, but thanks for enlightening me.

  • 2. Re: Stacks won't let me drag and drop
    wwwolf Level 1 Level 1 (0 points)

    Thanks Barney - I mightgive that a go when I've  moment to document my (simple) customisations so I can rebuild... except that now I think it's not just a Stacks/Dock problem.

     

    I now suspect a more extensive problem with Finder - a feature I use a lot is dragging the favicon from the address bar in Firefox to the Desktop or another folder to create a web page alias - that stopped working - then when I dragged an attachment out of Mail to drop in a folder, all my Finder windows and Desktop icons vanished and Finder restarted (annoyingly reopening all its windows in the same Space).

     

    If this sounds familiar to anyone who knows a fix, do let me know, otherwise I think it might be time to wander down to the Genius Bar...

  • 3. Re: Stacks won't let me drag and drop
    Barney-15E Level 8 Level 8 (35,295 points)

    Unless there are some hints in the console (Utilities folder) logs, I'm not sure what to do about that.

  • 4. Re: Stacks won't let me drag and drop
    quickthyme Level 1 Level 1 (0 points)

    I have this issue as well. However, I would like to add that it's not just Stacks. Both Stacks and email attachments are affected.

     

    I have two lion iMacs. One of them does allow me to drag and drop attachments and Stack items, the other does not. Both are at the same patch level and for the most part have the same configuration. Both were clean installs of Lion.

     

    Dragging and dropping from Finder windows work just fine. So far it's only these two scenarios that I have noticed it. I think it's also worth mentioning that I can drag fine, it's the drop that doesn't work.

  • 5. Re: Stacks won't let me drag and drop
    marcelobarbosa Level 1 Level 1 (0 points)

    Same problem here, no drag & drop from stacks on the Dock...

     

    (using Mac OS X 10.7.2)

  • 6. Re: Stacks won't let me drag and drop
    Indros Level 1 Level 1 (0 points)

    I had this same problem back in Snow Leopard, with no apparent cause.  It was solved (temporarily by logging out and back in).  The only solution was a fresh install of Snow Leopard. 

     

    I'm sorry to say that the problem cropped up again today in Lion on a complete new machine where nothing had been migrated.  The logout/login option solved it, but I'm unclear of the cause.  All I did today was install TweetDeck and Twitter apps, and messed around with Adobe Air (which seems to not work on Lion).

  • 7. Re: Stacks won't let me drag and drop
    Matt Crawford2 Level 1 Level 1 (95 points)

    I had the problem that I could not drag a file from the Downloads stack to a Finder window. (OS X 10.7.5)

     

    I tried "killall Dock" from the Terminal and that did not help.

     

    I did a "Relaunch" of Finder from the "Force Quit" box and that did fix the symptom.