Skip navigation

Using Terminal to upload a file to Charter webpage

2365 Views 5 Replies Latest reply: Aug 28, 2012 2:26 PM by leroydouglas RSS
ReidMac Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 4, 2011 7:48 PM

I am trying to upload a file to my Charter webpage directory.  I have successfully logged in but cannot figure out how to transfer or upload the file.  See code lines from terminal below.  Once I get to the ftp> command at the end what should I try?  I have tried with the "put" and without and also have put a space between put and the /.  the file is on my desktop and I am dragging it into the terminal window. 

 

Thanks

 

 

 

reid-mccallisters-imac:~ Reid$ ftp xxxxx@webpages.charter.net

Connected to webpages.charter.net.

220 FTP Server ready

331 Password required for xxxxx

Password:

230 User artinfo logged in

Remote system type is UNIX.

Using binary mode to transfer files.

ftp> put/Users/Reid/Desktop/dali_gala_lincoln.jpg

  • BobHarris Level 6 Level 6 (12,505 points)
    Currently Being Moderated
    Sep 5, 2011 6:39 AM (in response to ReidMac)

    ftp> pwd

    ftp> cd  /to/the/destination/directory

    ftp> binary

    ftp> put  /Users/Reid/Desktop/dali_gala_lincoln.jpg

    ftp> exit

     

    The 'pwd' command will tell you what ftp thinks the remote directory location is.  Use the 'cd' command if that is not where you want to store the file.

     

    The 'binary' commands tells ftp to NOT try and convert text file line endings from <LF> to <CR><LF> or to <CR> or any number of other remote operating system line ending rules.  'binary' says just copy the file as is.

     

    There is a space between 'put' and the file you want to transfer.

     

    You might be better off trying to use something like CyberDuck, a GUI ftp utility, or any number of other GUI ftp utilities you can find over at <http://MacUpdate.com>

     

    As an alternative, if your ISP supports ssh, scp, and sftp, if you want to stay with the command line, you would be better off using scp as it is a more straight forward copy syntax, plus ssh, scp, and sftp are all secure file transfers, where as ftp is totally insecure, including the transfer of your password in clear text when you log in.

     

    Try CyberDuck

    iMac, Mac OS X (10.6.7), 27" i7, MacBook, MacMini, etc...
  • Facepaintingmom Calculating status...
    Currently Being Moderated
    Aug 28, 2012 8:57 AM (in response to BobHarris)

    I have this same issue when attempting ftp with Charter, in particular, when upload to the file dir that I have created. I get a message that states there is no such directory, such is as follows:

     

    230 User jndbrewer logged in

    Remote system type is UNIX.

    Using binary mode to transfer files.

    ftp> cd Resumes

    250 CWD command successful

    ftp> put /Users/donnabrewer/Desktop/Donna_Resume_ftp.pdf

    local: /Users/donnabrewer/Desktop/Donna_Resume_ftp.pdf remote: /Users/donnabrewer/Desktop/Donna_Resume_ftp.pdf

    229 Entering Extended Passive Mode (|||42739|)

    ftp: Can't connect to `209.225.8.65': Operation timed out

    500 Illegal PORT command

    550 /Users/donnabrewer/Desktop/Donna_Resume_ftp.pdf: No such file or directory

    ftp> pwd

     

     

    transfers are binary with charter, dialog states when logging in via terminal

     

    help? thanks!

    Donna Brewer

  • Facepaintingmom Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2012 9:41 AM (in response to ReidMac)

    Im hoping to get some answers to this one, without using GUI. What did Charter tell you?

  • leroydouglas Level 6 Level 6 (13,330 points)
    Currently Being Moderated
    Aug 28, 2012 2:26 PM (in response to ReidMac)

    ReidMac wrote:

    . Since I don't have the time to learn the UNIX commands for terminal I downloaded the 15 day version of Fetch to do the job--which it did--and I will pay the money to register.  Looked at Cyberdog online but saw comments about it being a little finicky for larger downloads and decided I would go with the classic Fetch which I had used before.

     

     

    You can not go wrong with Fetch.  Good choice.

    MacBook Pro, OS X Mountain Lion (10.8.1), 2.4GHz IntelCorei5 320GB HD 8GB RAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.