7 Replies Latest reply: Sep 5, 2011 12:31 PM by rickair
rickair Level 1 Level 1 (0 points)

Help please.  I have an iPhone 4 that keeps using an inactive email account to send messages.  Even if I am replying to a message directly from my comcast email account, the message uses the inactive account as the reply.  It uses the inactive account for everything....photos.  Everything I have read says to go into mail preferences and select the "Default Account" tab and select the account I want to use.  But I don't have that tab in my preferences.  Thanks!


iPhone 4
  • rickair Level 1 Level 1 (0 points)

    Also, I completely deleted this email account from the phone, yet it still continues to use this to send!

  • rickair Level 1 Level 1 (0 points)

    Just added the inactive account back on to the phone.  Changed my Default to my comcast email account, but it is STILL sending from the inactive gmail account....

  • AdamKB Level 2 Level 2 (330 points)

    Is it possible you configured your Comcast account to use your Gmail email address? Double-check all your account settings and make sure it's not in there.

     

    Also, what Outgoing (SMTP) server and login are you using? If you've configured your Comcast account to use the Gmail SMTP server, Gmail might be inserting its own address as a security feature.

  • rickair Level 1 Level 1 (0 points)

    Everything appears to be correct on the phone (using comcast STMP server, etc.).  A workmate suggested it is probably the way my iTunes is set up.  Will check that this afternoon when I get home.

  • AdamKB Level 2 Level 2 (330 points)

    I can't think of any setting in iTunes that would cause your emails to go out using a phantom email address.

     

    How do you know this is happening? Can you paste some detailed email headers?

  • ChrisJ4203 Level 8 Level 8 (36,030 points)

    Go into Settings>Mail, Contacts, Calendars>and select the Comcast account. From there look at the Outgoing Mail Server. It shoudl list the Comcast SMTP server. Touch that button and it will take you to another settings page for SMTP. It will show you the Primary SMTP server along with other SMTP servers. If the gmail server is listed there, then you can touch on it and turn it off. That should take care of it. The iPhone will try and use the SMTP server you have listed for a particular mail account, however, if that server is unavailable, it will take the next one on the SMTP list until it gets to one it can use.

     

    Edit: Make sure that you have removed the checkmark in iTunes in regards to syncing mail acocunts. That only has to be done once, if at all. If you have it set to sync mail accounts each time you sync the iPhone, it is going to re-copy the accounts you have on the computer back to the iPhone. All it copies is the settings though.

     

    See if this helps you out.

     

    Message was edited by: ChrisJ4203

  • rickair Level 1 Level 1 (0 points)

    That was it, Chris.  Thank you!  And thanks to Adam for trying to help me too!