4 Replies Latest reply: Sep 6, 2011 12:55 AM by 50hils
50hils Level 1 Level 1

I have a new iphone and can't send email.

 

It keeps asking for my email account password.  I've entered it several times, changed it online several times.  No joy.

 

Please help.


iPhone 4, iOS 4
  • ChrisJ4203 Level 9 Level 9
    expertise.iphone
    iPhone

    I suggest that you delete the email account and re-enter it. There seems to be a problem in the way you set up something. It probably has to do with the SMTP server since you say it has to do with sending mail.

  • 50hils Level 1 Level 1

    Thank you but I've done this several times.  I've been online with my laptop to amend the password online several times.  I've been on the phone to my broadband provider when my laptop email stopped working.  That was fixed after an hour on the phone, only to be undone again when I rang my iphone service provider who didn't seem to know what they were doing.  I've been fiddling for ages with the set up in the hope that I stumble on something that works, but no luck.

     

    I think I;ll have to steel myself to ring them again in the morning and hold out for someone more experienced or go to see a Genius.

     

    Thanks anyway.

  • ChrisJ4203 Level 9 Level 9
    expertise.iphone
    iPhone

    Well, maybe the problem isn't the iPhone, it is at the provider end, the email provider that is. You said you had problems with the email on your laptop. Are you trying to sync the email accounts with iTunes to the iPhone or creating them individually? Has email ever worked on the iPhone? Once you get it to work on the computer, then try and set it up on the iPhone. I'll assume you are using an email client on the iPhone, or are you using a web based email?

  • 50hils Level 1 Level 1

    I solved this problem by chance after lots of tinkering about.  My laptop email issue was solved by entering my Yahoo password in the Sky logon.  No idea why that worked but it did.

     

    I deleted both my Yahoo email account from my iphone and also my Sky account.  I then made sure my wifi was off.  Then added my Yahoo account first, then Sky account, then switched off the phone and switched back on again.  Then switched wifi back on.  Hey presto, I was able to send and receive emails.

    I now have another question...