4 Replies Latest reply: Nov 16, 2011 5:54 AM by frank124
eldrik Level 1 (65 points)



I upgraded my existing Snow Leopard Server to Lion Server.


In the past I could reach the Servers Webmail only via https disabling http access via Server Admin Tools.


If I am now using https://servername.com/webmail I get the message (translated from german) "Webmail is disabled. You can enable it via Server program".


If I am changing the URL to http:// webmail is working lika a charm.


But where can I force the system to disable http:// and instead activate the https:// URL?


Best regards


Mac mini, Mac OS X (10.7.1), mini Server 2011 with LS 10.7.1
  • Atrato Level 1 (25 points)

    In the Server app configure the correct SSL certificate for the webservice.

  • LogMeCode3 Level 1 (70 points)

    Since you're talking webmail, are you accessing it via the built-in Wiki website, or otherwise?  And do you have web services setup for secure usage with an SSL certificate?  Since you're able to type in http (without the 's') and it's not redirecting you automatically to https, I'm thinking that you need to configure your web servces for secure use.  In Lion, Server.app, Web Services, you would click on the '+' symbol and add a website.  It can be the same domain name as the server created default website, but the port needs to be 443 (it could also be www.servername.com, if that's how you'd like to access your website).  That should redirect all inquiries to your http site to https.  As mentioned above, you also need to make sure that your web services are configured with whatever SSL certificate you're using.  You do that in Server.app too -- choose your machine under the hardware area (left side) and then choosing 'settings' and then click the 'edit' button for SSL Certificate.  You probably need to have Wiki services turned on as well, if you don't already.

  • Mac-Fan_ Level 1 (0 points)

    Hello Eldrik


    Are you able to connect also from the "outside" world (Internet) to your webmail service ?


    I got this issue:



    The strange thing is, that from internal (LAN) side, it is working properly, but from Internet side, I've got the authentication page, but the Webmail frontend can not talk with the IMAP server (connection failure)....


    Did you tested the "outside" szenario as well ?


    Many thanks


  • frank124 Level 1 (0 points)

    Have a look in



    should point to your local servername instead of $h

    the original  $h will be replaced by your external fqdn which is not enabled in mail.


    $rcmail_config['default_host'] = 'tls://macserver.examle.com';